Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't locate speakers, realtek drivers won't install properly, etc.

09 Sep 2012   #1
TheMaskedP

Windows 7 Professional x64
 
 
Can't locate speakers, realtek drivers won't install properly, etc.

Hey there, I've been digging for a solution to this problem for over a week and I've had next to no luck. I was originally having problems with Realtek HD Audio Manager properly operating my front panel audio jacks, so I attempted to update my audio drivers using the ones found on Realtek's website (2.70). After restarting, my computer has failed to load and locate the new drivers and in the task bar, the usual volume icon has a red and white X; mouse-overing brings up the message "No speakers or headphones are plugged in" (despite my speakers being plugged into the proper lime analog jack on my motherboard). Opening the Sound window from my control panel shows that there is only one option under playback devices: AMD HDMI Output, which it shows as not plugged in. There is no analog speaker present, even with both "Show Disabled Devices" and "Show Disconnected Devices" checked by right clicking on the window. Within my device manager, under the 'Sound, video and game controllers' heading, there is only the AMD High Definition Audio Device. Under the 'System devices' heading, the only relevant devices are two High Definition Audio Controllers, one of which has a yellow caution symbol. Within the properties, under 'Device status', it displays "This device cannot start. (Code 10)". Both it and the working High Definition Audio Control point to the same driver, hdaudbus.sys. Uninstalling these devices and rebooting causes windows to reinstall the devices to the same state as before uninstalling, regardless of whether the realtek drivers were currently installed, or uninstalled and then reinstalled so that both the devices and Realtek finished their installations at the same time. I have tried both the newest Realtek drivers (.exe and .zip), as well as the drivers provided by intel for my motherboard. I've also tried updating both my motherboard's chipset and bios, to no effect. I've also loaded the bios to ensure that the motherboard's audio was enabled. One thing I've noticed is that, when I look at the realtek folder, only two files have been added: RtlUpd64.exe and USetpu.iss. The former of the two files does nothing when I've clicked on it; no process runs within task manager. The file RtlCpl.exe, which I've read is the executable for the RealTek control panel, is nowhere on my system. This has occured repeatedly with repeated downloads of both the realtek and the intel drivers. Once during this has my system properly loaded the realtek drivers, but, to my dismay, the problem of no present audio had reappeared after a complete system shutdown. That said, this leads me to believe that this is not a hardware problem, especially given that I've read of people with a similar problem (the two High Definition Audio Controls within device manager) having the problem be software. On a previous attempt, I was able to adjust my sound using the volume control without the Realtek Control panel, however this also disappeared after a restart. I've not been able to reproduce either of these events. I've attempted to manually point the High Definition Audio Controlers to the realtek drivers, only for windows to claim that the drivers are already up to date. Looking at the registry information through System Information (start > accesories > system tools > system information), there are no realtek audio drivers present, despite installing the drivers (Realtek High Definition Audio Driver is present within Programs and Functions and is uninstallable).

In summary (and because I've probably forgotten details):
Problems:
No sound out of speakers.
Sound icon in desktop taskbar says "No speakers or headphones plugged in" despite plugged in speakers
Realtek HD Audio Manager does not open on system startup
No analog sound present in Control Panel > Sound > Playback
Two High Definition Audio Controller devices present in device manager, one with an error symbol, both pointing to the same windows (not realtek) HD driver
No analog sound devices present in device manager
Possibly incomplete install of Realtek Drivers upon reinstall attempt - installed files do not load when opened.
No Rtlcpl.exe program present.

Steps already taken:
Installed most recent version of Realtek HD Audio Codec (2.70) from realtek's website
Redownload and reinstall of same drivers
Download of Realtek HD Audio Codec (2.65 I believe, I'd have to uninstall to see)
Redownload and reinstall of same drivers
Extraction of files from .zip version of 2.70 drivers, unable to point to these drivers.
Cleaning of registry (working on hunch that uninstalls of realtek drivers have lead to registry items being left that are preventing proper reinstall)
System restore to week before the problem (loads original drivers, problem is still present)
Removal of RTKVHD64.sys from c:\Windows\System32\drivers (was present after uninstall. I believe it was a remnant from the old system restored drivers, which couldn't be uninstalled due to missing registry files. File still remains outside of drivers folder as a backup)
Ensuring integrated audio is inabled within the BIOS
Update of BIOS
Update of motherboard chipset.

Relevant System Specs:
OS: Microsoft Windows 7 Professional (64 Bit)
Motherboard: Intel DP55WG
Video Card: AMD Radeon HD 6800 Series

Hunches I have:
Something to do with hdaudbus.sys - old related problems dealing with the AC'97 realtek drivers with respect to Win XP mention windows' UAA Bus Driver, which is what this is.
Something in my registry is preventing me from installing Realtek properly. Maybe I need to give the full .zip a try again?
Maybe I need to repeat these steps in safemode? I've been trying everything through normal installs and restarts.
Try to find original driver disk from motherboard (I've read of similar cases having no luck with this)
Last resort is reformat of C: drive.

Do you need any more information? I can certainly get screenshots or a more detailed speclist if needed. Thanks!
My System SpecsSystem Spec
.
10 Sep 2012   #2
fireberd

Windows 10 64 bit
 
 

Sorry but your long post with everything run together is too hard to read.

Can you post a shorter summary of the problem?
My System SpecsSystem Spec
Reply

Thread Tools




Similar help and support threads
Thread Forum
Can't install intel chipset drivers properly
Today i have installed a new SSD (my only drive), installed windows and appropriate drivers, except for one, it seems. The intel chipset drivers have not properly installed after selecting the option to do so on the CD included with my motherboard. See the attached screenshot for my list of...
Hardware & Devices
No sound from speakers/ Asus Xonar /Realtek after GPU driver install
Hello, I am not able to get any sound out of my speakers since installing the newest driver for my Geforce GTX960. I tried going into Device Manager, uninstalling every audio driver under "sound, video & game controllers" including the Asus Xonar from my soundcard, the Realtek drivers, and the ones...
Sound & Audio
Cannot install Windows 7 on my PC failed to locate drivers.
Long story shorrt: I got user32.dll error now I cannot even get to my desktop. When I boot from my hard drive I get error saying no operating system found... When I boot from USB I cannot find which drives to us cause none show.. I am running custom PC i made.. Also I don't have my windows...
Installation & Setup
AMD 6970M drivers won't install properly.
Hello everybody! I've been having some minor issues with my video card lately. It is a AMD Radeon HD 6970M, with 1GB of GDDR5 Memory, that came embedded on my iMac (I'm using Boot Camp to install drivers). I can play games such as Crysis 2 and The Witcher 2 at a relatively good frame rate,...
Drivers
Drivers do not work properly after install of Windows 7
First let me give a bit of a backstory. I have an Acer laptop that I got recently that came with Windows 7 Home Premium 64 bit. I bought a Windows 7 Upgrade CD before that to upgrade the computer I'm using right now from Vista to Windows 7. Anyway, I'm planning to sell the laptop. Windows...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:03.
Twitter Facebook