Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Anyone knows why rear speakers works fine on firefox?

08 Jul 2013   #1
incxbxs

windows 7 pro 64bit
 
 
Anyone knows why rear speakers works fine on firefox?

You probably know famous rear speaker problem. So i skip the info and come directly to question:

Rear speakers works just fine on firefox and speaker test.
Rear speakers dont work on anything else.

What can possibly cause this? How do i fix this once and for all.

Speakers: 4+1 Creative
OS: Windows 7 pro.
Realtek Hd Audio ALC898 Codec. 6.0.1.6559



Edit 1: I also found quite interesting thing that, when i change speakers 5.1 to 7.1, youtube video on chrome stops immidiately(even if full) and try to load from begining. But this is not happening on firefox.

Also when you right click to video and go to statistics, on the chrome it says avc1.4d4015 codec is using but on the firefox it says 1 audio factor.


My System SpecsSystem Spec
.
08 Jul 2013   #2
fireberd

Windows 10 64 bit
 
 

1. Check the Device Manager. You should ONLY have RealTek audio and Intel HDMI audio listed. If you have HD Audio Codec, uninstall that, then restart the PC and see if the sound works.

If not, uninstall the RealTek in the Device Manager, DO NOT uninstall the drivers. Restart the PC and when Windows starts it will detect and reinstall the sound. This fixes many problems.
My System SpecsSystem Spec
08 Jul 2013   #3
incxbxs

windows 7 pro 64bit
 
 

There are three:

1. AMD high Def.A.D (it is from graphics card)
2. High Def.A.D (Microsoft Driver) (it comes back when ever i uninstall it so i disabled it)
3. Realtek high def Audio (which is default)

I one for sure everything use option 3. Option 2 already disabled by me.
My System SpecsSystem Spec
.

09 Jul 2013   #4
fireberd

Windows 10 64 bit
 
 

With the Microsoft High Definition Audio Device coming back, that is probably the problem, there is some type of sound device that its detecting.
My System SpecsSystem Spec
10 Jul 2013   #5
incxbxs

windows 7 pro 64bit
 
 

Maybe, but when i check from computer panel > sound > devices, no program uses this device.
My System SpecsSystem Spec
11 Jul 2013   #6
fireberd

Windows 10 64 bit
 
 

4.1 speakers are not used anymore. If there is no configuration setting for 4.1 you will have to use some other, such as 2.1 or 5.1.

Make sure your are using the correct sound driver. Use the one supplied by the motherboard vendor, first.
My System SpecsSystem Spec
16 Oct 2013   #7
incxbxs

windows 7 pro 64bit
 
 

Yes but when listening on firefox browser, it works just awesome. Right speakers works just fine + sound quality improved....
Anyway it seems this problem will stay as unresolved forever.
My System SpecsSystem Spec
Reply

 Anyone knows why rear speakers works fine on firefox?




Thread Tools




Similar help and support threads
Thread Forum
can not get selected web address works fine in IE not in firefox
when in firefox i type in this address: www . sportinglife . com \ football \ championship Sky Bet Championship Betting Tips | News, Fixtures, Results, Table | Sporting Life and i get this address: landingpages . mweb . co . za ....
Browsers & Mail
No audio in YouTube with Explorer 11. Firefox works just fine
Win 7x64 running Internet Explorer 11. All YouTube sites run but have no sound. At the bottom of the screen there is no sound (loudspeaker icon) displayed. Opening same YouTube sites in Firefox, the audio is just fine, and the sound icon is displayed. Any ideas? Other than just...
Sound & Audio
No sounds form speakers. Audio jack works fine.
2nd hand HP G56 running windows 7. Audio has never worked. No sounds from speakers. Sound from audio jack (but sometimes crackles). Realtek audio. Latest drivers installed. Master control is set to speakers; volume at max. Speakers icon in task bar set to max and shows volume bars 'bouncing up...
Sound & Audio
No sound in headsets, but speakers works fine.
So yesterday I was just installing PowerPoint, and watching some youtube videos meanwhile. Then suddenly I didn't hear any sound from the headset. I plugged it in and out and so on, nothing. I tried with another headset, nothing. I tried with headphones, nothing. I uinstalled PowerPoint to see if...
Sound & Audio
My computer speakers do not work but headset works fine.
I get the following error. "The peripheral does not appear to be plugged in" I've updated the driver and it says the realtek device is working fine. Sound worked just fine on this computer but then stopped. I do not have external speakers. How can I plug in the speakers or fix the problem? :(
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:01.
Twitter Facebook Google+