Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound works through HDMI output but not internal speakers.

29 Jul 2013   #1
Leduskia

Win 7 Home Premium 64 bit
 
 
Sound works through HDMI output but not internal speakers.

I've just received my Laptop back from repair and all seems to be well, I had my screen panel replaced, gpu replaced(from 570m to 670m), new hard drive and CPU fan. However the problem I seem to be having is that internal speakers are completely not working.

I can see that bolume bar in for my internal speakers is actually changing but there is no sound. My system is not muted (unless there's some secret button I'm missing out on) No matter what i try it seems that sound will not work through my internal speakers, I've plugged in my Razer headset(Kraken) that works with my other computer but is not even detected when plugged in the Audio jacks of my laptop(Doesnt even pick up the microphone) and this did work before I sent it out for repair. Sound only works through HDMI output into a TV/Monitor.

Now I'm not sure if this some software configuration that I have to do or something physical with the hardware but I would prefer to not have to send it back as it would take a month to get back to me and also the repair company states that if the problem is due to software then they will charge.

I assume it's a conflict that Realtek HD audio manager is having or something but none of my devices show up on the RealtekHD Audio Manager nor do I get a pop up when a device is detected(which is what normally would of happened)

System:
MSI GT780DX
I5 2430
GTX 670m
Win 7 64 bit
8gb Ram

Edit: After some more looking around, I really do believe that what I had thought earlier was causing the problem. I believe that the GTX 670m may be causing some sort of conflict, however earlier today I did do everything from reformatting to uninstalling and reinstalling Nvidia drivers and it didnt work) Seems like other people are also having similar problems. HDMI sound output works just fine, audio jacks not at all! New PC


My System SpecsSystem Spec
.
29 Jul 2013   #2
Sub Styler

Windows 7 Ultimate x64
 
 

What is set as default in the Output Devices?

Right click the volume control, select output devices, set realtek audio (or speakers) as default.

Repeat for input devices to get the mic working
My System SpecsSystem Spec
29 Jul 2013   #3
Leduskia

Win 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by Sub Styler View Post
What is set as default in the Output Devices?

Right click the volume control, select output devices, set realtek audio (or speakers) as default.

Repeat for input devices to get the mic working
By volume control do you mean the sound manager thing which has the tabs of "Playback, Recordings, Sounds" etc? If so my speakers are set as the default device but this changes nothing and my mic is no detected in the recordings(it says line not plugged in)

If you mean the volume icon in the bottom right corner, when I right click on that all i get is Volume mixer, Playback devices, Recording Devices and Sounds and also volume control options.

I can provide screen shots if needed be.
My System SpecsSystem Spec
.

29 Jul 2013   #4
Sub Styler

Windows 7 Ultimate x64
 
 

Playback devices (sorry on an XP machine at work right now)
My System SpecsSystem Spec
29 Jul 2013   #5
Sub Styler

Windows 7 Ultimate x64
 
 

I would uninstall the sound manager sofware and just use windows (unless it has features you really need or like)
My System SpecsSystem Spec
29 Jul 2013   #6
Leduskia

Win 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by Sub Styler View Post
Playback devices (sorry on an XP machine at work right now)
Quote   Quote: Originally Posted by Sub Styler View Post
I would uninstall the sound manager sofware and just use windows (unless it has features you really need or like)
I see, well yes my speakers are set to default device. I am starting to think It's really my GPU thats causing a mess. The laptop came with a GTX 570m but they replaced it with a GTX 670m which although better, Im sure my laptop doesnt have the power to handle or not configured to do so... I also happen to have very jumpy usage with this GPU in Video games (drops from 70-90% usage to 11% constantly)

*I'm sorry, by sound devices manager i was simply referring to "sounds" from the control panel.

Edit: According to notebookcheck, the power consumption of GTX 570m and GTX 670m is very similar to the old 470m, so I'm really not sure about the power issue...
My System SpecsSystem Spec
29 Jul 2013   #7
Sub Styler

Windows 7 Ultimate x64
 
 

Can you check the device manager for exclamation marks?
My System SpecsSystem Spec
29 Jul 2013   #8
Leduskia

Win 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by Sub Styler View Post
Can you check the device manager for exclamation marks?
There isn't a single exclamation mark for anything in the device manager.
My System SpecsSystem Spec
29 Jul 2013   #9
Sub Styler

Windows 7 Ultimate x64
 
 

Sound works through HDMI output but not internal speakers.-sound.png

Home from work now. Can you send a screen shot of this window?


My System SpecsSystem Spec
29 Jul 2013   #10
Leduskia

Win 7 Home Premium 64 bit
 
 

My System SpecsSystem Spec
Reply

 Sound works through HDMI output but not internal speakers.




Thread Tools




Similar help and support threads
Thread Forum
AMD HDMI Output no longer works.
For some reason starting last week there is no sound coming out of my monitor. Whenever I click test on the AMD HDMI Output, it says the device is already in use. However there are no program currently running that will use it. I have tried with the "Allow applications to take exclusive control of...
Sound & Audio
Speaker jack works but the left (of 2 speakers) doesn't output sound
So the two speakers I use for my computer are not completely working. When plugged into my computer, the main speaker with the controls and stuff gives out sound but the other speaker doesn't. I tried plugging the speakers instead into my phone and both speakers had sound coming out, so I...
Sound & Audio
Sound not working, Only have HDMI Sound Output, But no HDMI port in PC
Hi there, My sound is not working. I only have a HDMI Sound output. However, I don't have any HDMI Output in my computer. I reinstalled windows a couple of times lately, but i don't know for sure if thats the problem. Right now im using Windows 7 32-Bit, My hardware specs are: CPU: Intel Duo 2...
Drivers
HDMI sound output works just fine, audio jacks not at all! New PC
Hello everyone, you guys seem to know your stuff so Ill ask for your help: I have a frustrating problem with my brand new XPC Shuttle computer. Everything works fine, just not sound. I tried hooking up the computer via HDMI to a TV for the first time as I didnt have a monitor - sound works just...
Sound & Audio
Gigabyte HDMI output to Yamaha receiver - no sound output
GA-890GPA-UD3H (rev. 3.1) GIGABYTE - Motherboard - Socket AM3+ - GA-890GPA-UD3H (rev. 3.1) (Note 3) Simultaneous output for DVI-D and HDMI is not supported. What I'm trying to do is output just my sound to the receiver via HDMI cable, but still use the DVI to my monitor...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App