Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Steam causes problems in Windows Audio Service

08 Aug 2013   #1
mattdp

Windows 7 Home Premium 64 bit
 
 
Steam causes problems in Windows Audio Service

Hi,

Audio output on my laptop functions normally most of the time. However, often when I play a game on Steam when I *finish* playing and close the game, I discover that the audio is no longer functioning. Other games have no soundtrack and windows media player tells me it's unable to play mp3 files.

Oddly, system sounds - mouse clicks and the like - still seem to work.

I have discovered that restarting the Windows Audio and Windows Audio Endpoint Build services seems to fix this problem for most applications. But not for Steam - any games run through Steam continue to either be silent or to error with sound-based issues.

I've got some sort of Realtek High Definition Audio sound card, but I'm not certain what model. As best I can tell I have the latest drivers - the "update drivers" button in Windows Sound manager is grayed out.

The apparent inconsistency of this behaviour has got me stumped and it's getting tiresome having to reboot every time I want to play a game. Any ideas gratefully received.


My System SpecsSystem Spec
.
10 Aug 2013   #2
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

Realtek is the standard motherboard sound chip manufacturer.

Visit asus.com for an updated driver for your specific laptop.

Make note in the specifications what chipset it is, something like Realtek ALC-8xx or similar.

cpu-z, msinfo32.exe and speccy did not give this specific detail in plain view when I looked, I know what mine is though. [apps used to provide system details]

Otherwise, I would look at Steam forums, you can't be the only one among millions to have this issue.

Steam's own generic online support didn't give me an answer, I looked.
My System SpecsSystem Spec
12 Aug 2013   #3
mattdp

Windows 7 Home Premium 64 bit
 
 

Thanks for the suggestion. I updated the drivers but, annoyingly, I now have no speaker sound at all. Oddly, headphones plugged in still function fine. But the on-board speakers (it's a laptop) do not.

Any suggestions on how to restore my sound output, ideally with the updated drivers in place, deeply welcomed.
My System SpecsSystem Spec
.

Reply

 Steam causes problems in Windows Audio Service




Thread Tools




Similar help and support threads
Thread Forum
No audio is coming from computer because of service "windows audio"
i am running a windows 7 and my computer cannot play audio or play videos.there is a speakerphone in the bottom right of the screen that has a X over it.When i click it nothing happens.After a while then it opens and then freezes.Also when i open up services.msc and try to restart/stop "windows...
Sound & Audio
Steam problems, culminating in Windows Explorer crashes in Win7 64bit
I have been having problems with my Steam client for some weeks now. This has usually been in the form of constant update loops upon startup. Recently I was able to get the client to start normally but the client itself was almost useless; I was unable to do anything with it except view my games...
Gaming
windows audio service turns itself off
Hi, I am new here, so sorry if I already broke some kind of rule. Here is my problem: I bought new parts for my pc... Well it was nearly everything except HDD and now I can't get sound running. Sound icon at bottom right has that traditional white X in red circle and when I move my mouse over...
Sound & Audio
audio service not working, dependency service does not exist...
hi can anyone help? i have a medion akoya laptop running windows 7 64 bit i have no audio. if i click troubleshoot problems it says the audio service is not running it says the windows audio and endpoint builder arent working if i go into services, windows audio is set to automatic but its...
Sound & Audio
No Audio service / problems with Graphics card
Hi, first post here, hope this is the correct place to ask. I wanted to upgrade to Windows 7 Home premium, and decided to do a complete new Clean instal on a brand new Samsung HD. Installation went well , but then got message 'Bad Driver' and The Audio service is not running' Managed to open...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App