Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative Sound Card Problem Thread

03 Jan 2010   #141
peymanc

Windows 7 64-Bit
 
 

Creative driver does not work for me either.

I have Creative SB X-Fi elite Pro, on EVGA X58 3SLI motherboard. And I have WIN 7 64-bit.

Peyman


My System SpecsSystem Spec
.
08 Jan 2010   #142
Wishmaster

Windows 7 Home Premium 64bit
 
 

Creatives official drivers work fine for me even using THX console.

how i done it:

put in the X-FI Cd (Vista Version)

Run setup w/compatability mode for vista:
Custom Install
Install ONLY THX Console and Volume Panel
Reboot when done

Download latest console manager and driver from creative.
Install Console manager .. do not reboot
Install Driver --> reboot


And thats it .. everything will work flawlessly (at least for the Xtreme Gamer)
My System SpecsSystem Spec
09 Jan 2010   #143
pinakel

win 7 & xp
 
 
creative sound card line problem

i have this Creative Sound Blaster 5.1 Sound Card - High-quality surround audio & i download that driver from here Creative Worldwide Support Creative Worldwide Support for win 7. its works great in win 7 but line in doesn't work in win 7. i have local made tvtuner card. to listen sound form tv tuner i need to enter the sound input to my sound card. that means one in the tv tuner out put & another in sound card input. the prob is the mute function does not work i cant mute line in, line in is always on. i use windvr to watch tv show. if i listen a song in pc i close windvr i cant mute it.but the same things work fine in xp. how do i mute line in ? plz help or suggest me a sound card that i mute linein in win 7 & also it should work in win xp. sorry for my bad english.

twitter.com/pinakel
My System SpecsSystem Spec
.

09 Jan 2010   #144
Guybrush

Windows 7 x64 Ultimate
 
 

I was updating my drivers recently and i used driver cleaner to remove all traces of the previous driver, which i probably shouldn't have done because now i can't install them at all.

There's a yellow exclamation in device manager, i have tried uninstalling the sound card and rebooting, but that doesn't help. If i try to search for the driver manually it tells me there is no driver available.

Does anyone have a solution to this problem?

The sound card i'm using is the Creative X-Fi Xtreme Music which has been working fine since i bought 7 on release.

Any help is much appreciated, thanks.
My System SpecsSystem Spec
09 Jan 2010   #145
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Guybrush, welcome to the forums.

If you haven't yet try to manually install the driver,

Creative Sound Cards.
My System SpecsSystem Spec
09 Jan 2010   #146
Guybrush

Windows 7 x64 Ultimate
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Guybrush, welcome to the forums.

If you haven't yet try to manually install the driver,

https://www.sevenforums.com/sound-audio/21804-creative-sound-cards.html#post303346
Thanks for your reply.

I tried that as well, but i'll give it a try again as i don't think i was doing it right.
My System SpecsSystem Spec
10 Jan 2010   #147
philcourth

windows 7 home premium
 
 

creative X-treem gamer . MB asus M2N4-sli , same thing crappy sound
My System SpecsSystem Spec
11 Jan 2010   #148
Guybrush

Windows 7 x64 Ultimate
 
 

Quote   Quote: Originally Posted by Guybrush View Post
Quote   Quote: Originally Posted by stormy13 View Post
Guybrush, welcome to the forums.

If you haven't yet try to manually install the driver,

https://www.sevenforums.com/sound-audio/21804-creative-sound-cards.html#post303346
Thanks for your reply.

I tried that as well, but i'll give it a try again as i don't think i was doing it right.
I tried it again, but unfortunately it didn't work.

It keeps telling me it cannot load the creative driver.

I'm not sure what else to do apart from formatting my HD, but that's a bit drastic.
My System SpecsSystem Spec
11 Jan 2010   #149
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Unfortunately things like this,

Quote   Quote: Originally Posted by Guybrush View Post
I'm not sure what else to do apart from formatting my HD, but that's a bit drastic.
have a habit of happening occasionally when you do things like this,

Quote   Quote: Originally Posted by Guybrush View Post
I was updating my drivers recently and i used driver cleaner to remove all traces of the previous driver, which i probably shouldn't have done because now i can't install them at all.
Even more so if it was the free version of Driver Cleaner as it hasn't been updated in 3-4 years.

Only other way around it is if a system restore can bring it back to where it was before doing the "cleaning". That or if you happened to create a backup image of the system that you could reload.
My System SpecsSystem Spec
10 Oct 2010   #150
Nukkels

Windows 7 Professional x64
 
 
Slightly different problem

I've had my X-Fi Fatal1ty for a number of years now (4 years I think?) and until a few months ago it was fine barring the odd minor issue. Recently I've started having random BSODs - not heat/stress related, often in games but also randomly in Windows, sometimes very shortly after booting. Even viewer just gives the generic 'Kernel Power' error which basically means 'your computer crashed'.

What makes me think the sound card is the cause is that often the first sign I'm about to crash is the sound - often it stops completely, but sometimes it screeches and other times (more frequent recently) my headphones will only give me the right channel and then nothing at all but if I unplug them from my X-Fi Fatal1ty's front drive bay my speakers start up playing in 5.1 just fine - momentarily... Then I get a BSOD some moments later.

Other times though, the first sign something is awry is my wireless network card (also in a PCI slot) drops and won't come back til I reboot. I thought it was my motherboard's PCI slots dying but I've done some testing with tonnes of drivers including both daniel_k drivers and several version of the Creative drivers including the 5 year old ones off the CD but I still get the BSODs. Tried enabling/disabling onboard sound in BIOS, no change. I uninstalled the Creative drivers completely and forgot to reboot and this time instead of a BSOD, my sound kept playing but the graphics card crashed, as well as my G15 keyboard being unresponsive showing no fluctuations in CPU usage (a sure sign the PC has frozen up).

I rebooted and since then, I've been using the onboard sound which plays my mp3s in *shudder* stereo and not a single crash or BSOD of any kind.

Conclusion: There was some sort of update applied a while back that probably coincided with when I updated to the latest Creative drivers causing me to think that was the cause (a system restore temporarily fixed the issue but it eventually came back). Whatever this update is, affects the motherboard's PCI bus (and probably the PCI-E bus too), causing data corruption between the 2 devices on the same bus.

I've bought a new motherboard to test if this is motherboard related or sound card related but I haven't got around to the mammoth task of gutting my PC to swap mobos. My gut feel is that it's the sound card's drivers causing this corruption, leading to a BSOD since it seems to have stopped once the drivers are uninstalled. It would also explain a LOT of the previous issues people have experienced.
My System SpecsSystem Spec
Reply

 Creative Sound Card Problem Thread




Thread Tools




Similar help and support threads
Thread Forum
Low volume with new sound card(Creative Sound Blast 5.1 VX)
Hello! I got a new sound card today. Installed it, installed the drivers from the CD, plugged in the headphones and it works. But the sound levels are way to low. I raised the volume in all the places I could find, but it's still a bit low. Here's the card: Creative Sound Blaster 5.1 VX...
Sound & Audio
Creative sound card not detected
Hi, I have just acquired a creative Audigy 2 Platinum Pro (Model SB0290) from a friend, however Windows can't detect it so I can't install the driver. In device manager a device called Multimedia Audio Controller shows up under Other Devices. Thanks in advance!
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Creative Sound card
I've got a Creative Sound Blaster X-Fi Xtreme Audio. I have 2/2.1 speakers. What jack in the back of the card should I be in? When I run creative diagnostics I hear the left and right speaker but not my center speaker. With the 2/2.1 speakers do you stay in the green jack?
Sound & Audio
Problems with my Creative Sound Card.
Hi all, I've been having problems with my sound card drivers ever since I upgraded to Windows 7 64 from Windows Vista 32. I must admit I messed up by not writing down what specific sound card is in this laptop (Dell Inspiron 1520) and I have not been able to find any drivers from Dell.com. I...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App