Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative Sound Card Problem Thread

15 Mar 2009   #51
thunder2008

Windows 7 RC 7100
 
 

Seems like the difference in drivers that microsoft chose to use in W7 are so different from those in Vista that the included compatibility wizard has become quite useful in sending the various error messages back to MS.

It is hoped that the up in coming W7 RC edition will have resolved the audio driver issues that are present in the W7-7000build.

While W7 is slimmed down and faster as a result of trimming the bulk from Vista; there must be a compromise in providing an actual " working " set of audio drivers for the W7 os that are compatible with Vista as Windows 7 has so vaunted up W7 to be.

Other than the audio driver problems with distortion as well as unrecognizable hardware from non-compatible drivers like Asus Creative Cards plus other brands Windows 7 also has issues with Cad programs like Solidworks in that it won't open files from the cad programs interface.

The opening of files is only accomplished from the user file directly. Moreover saving files is also not able to work at all whether a user is running SW08 or SW09 with any service packs, they are all not working properly.


My System SpecsSystem Spec
.
15 Mar 2009   #52
dsopocy

Windows 7 Professional 64-bit
 
 

thunder2008 -

Please add my info to your list:

dsopocy......Creative SB X-Fi XtremeMusic (OEM SB0467)....nVidia nForce4 SLIx16
My System SpecsSystem Spec
15 Mar 2009   #53
bloke

Windows 7 7600 x64 (16385) Ultimate,Windows Vista x64 Ultimate
 
 

there's a list? what list? can i be on the list? what do i have to do to be on the list? hello?

oh the sound issue is with all w7 builds. unfortunate.
My System SpecsSystem Spec
.

15 Mar 2009   #54
LePoilu

Vista H.P. SP1 x32 Seven RC x64
 
 

Quote   Quote: Originally Posted by bloke View Post
there's a list? what list? can i be on the list? what do i have to do to be on the list? hello?

First post of the topic
My System SpecsSystem Spec
16 Mar 2009   #55
thunder2008

Windows 7 RC 7100
 
 

Quote   Quote: Originally Posted by dsopocy View Post
thunder2008 -

Please add my info to your list:

dsopocy......Creative SB X-Fi Extreme Music (OEM SB0467)....nVidia nForce4 SLIx16
Done
My System SpecsSystem Spec
16 Mar 2009   #56
thunder2008

Windows 7 RC 7100
 
 

Quote   Quote: Originally Posted by bloke View Post
there's a list? what list? can i be on the list? what do i have to do to be on the list? hello?

oh the sound issue is with all w7 builds. unfortunate.
Nice keyboard bloke...it's the same as mine.

Noticed from your sig that you have Asus Xonar 1.3 are you having issues with it or ?

Before adding you to list want to first make sure that i'm not listing dis-information?
My System SpecsSystem Spec
16 Mar 2009   #57
bloke

Windows 7 7600 x64 (16385) Ultimate,Windows Vista x64 Ultimate
 
 

Quote   Quote: Originally Posted by thunder2008 View Post
Nice keyboard bloke...it's the same as mine.

Noticed from your sig that you have Asus Xonar 1.3 are you having issues with it or ?

Before adding you to list want to first make sure that i'm not listing dis-information?

yeh i love this k/b, the only thing i dont like is no embedded numb pad, which i bought a wireless one separate. occasionally i get interference and have to turn the k/b off and back on, but i aint gettin rid of it.

yeh i have certain probs that are very similar to the creative issues, so chins up creative owners, your not on your own.lol i had a xf-i platinum once (its sitting in my cupboard)

check this link out, it explains in detail.

HDAV1.3 (deluxe) windows 7 sound problems

does this mean im on the list?
My System SpecsSystem Spec
16 Mar 2009   #58
thunder2008

Windows 7 RC 7100
 
 

Yep your added
My System SpecsSystem Spec
16 Mar 2009   #59
bloke

Windows 7 7600 x64 (16385) Ultimate,Windows Vista x64 Ultimate
 
 

i think it could have something to do with the pci or pci-e bus. when i used my onboard sound while i was waiting for my hdav to arrive i had no issues with crackling. i also have no issues with my hdav1.3 when using headphones (2 channel). its hard to pinpoint this issue. some ppl with 2 channel creative cards are having issues, where i only get issues with 5.1 and above? my xf-i platinum was pci which i thought was starting to fail as it was crackling constantly in games under vista x64, maybe there is nothing wrong with it? and my hdav is pci-e which has issues??
My System SpecsSystem Spec
16 Mar 2009   #60
dsopocy

Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by bloke View Post
i think it could have something to do with the pci or pci-e bus. when i used my onboard sound while i was waiting for my hdav to arrive i had no issues with crackling. i also have no issues with my hdav1.3 when using headphones (2 channel). its hard to pinpoint this issue. some ppl with 2 channel creative cards are having issues, where i only get issues with 5.1 and above? my xf-i platinum was pci which i thought was starting to fail as it was crackling constantly in games under vista x64, maybe there is nothing wrong with it? and my hdav is pci-e which has issues??
G'day Bloke -

See my earlier post on this subject and the posts in the referenced thread. There are two Creative white papers on the subject of crackling and popping (referenced in my earlier posts) which identify issues with PCI bus latency (particularly with nVidia nForce4 motherboards), but both were written pre-Windows 7 and were dealing with the appearance of the problem when the system is under heavy load, particularly with high end games. Now, with Windows 7 the problem, at least for systems with certain (e.g., nForce4) motherboards and more than 3GB RAM, is present under all conditions, even for the system sound at the beginning of Windows startup. The key clue, IMO, is the RAM dependency: limit your RAM to less than 3GB and the problem disappears. Since my system hasn't changed since running Vista Ultimate 64-bit with nary a sound problem, the implication is that there has been some change in Windows memory management that has exposed a fundamental problem with Creative drivers for certain SB card models (mine is an OEM X-Fi XtremeMusic). Since the problem is limited to Creative sound cards, it's much more likely that the problem resolution lies with Creative, not Microsoft or nVidia.

Dale

P.S.
Please click on icon above and add to my reputation if you have found my posts to be helpful.
My System SpecsSystem Spec
Reply

 Creative Sound Card Problem Thread




Thread Tools




Similar help and support threads
Thread Forum
Low volume with new sound card(Creative Sound Blast 5.1 VX)
Hello! I got a new sound card today. Installed it, installed the drivers from the CD, plugged in the headphones and it works. But the sound levels are way to low. I raised the volume in all the places I could find, but it's still a bit low. Here's the card: Creative Sound Blaster 5.1 VX...
Sound & Audio
Creative sound card not detected
Hi, I have just acquired a creative Audigy 2 Platinum Pro (Model SB0290) from a friend, however Windows can't detect it so I can't install the driver. In device manager a device called Multimedia Audio Controller shows up under Other Devices. Thanks in advance!
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Creative Sound card
I've got a Creative Sound Blaster X-Fi Xtreme Audio. I have 2/2.1 speakers. What jack in the back of the card should I be in? When I run creative diagnostics I hear the left and right speaker but not my center speaker. With the 2/2.1 speakers do you stay in the green jack?
Sound & Audio
Problems with my Creative Sound Card.
Hi all, I've been having problems with my sound card drivers ever since I upgraded to Windows 7 64 from Windows Vista 32. I must admit I messed up by not writing down what specific sound card is in this laptop (Dell Inspiron 1520) and I have not been able to find any drivers from Dell.com. I...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App