Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Update Breaks RealTek Audio

12 Dec 2013   #1

Windows 7 Ultimate 64-bit (I'm trying out W 10 Pro)
Windows Update Breaks RealTek Audio

I have a recent home-build computer using an ASUS Sabertooth 990FX R2.0 motherboard and AMD FX8350 that replaced a dual Xeon motherboard based home build from 2007 that died. It has a RealTek ALC892 on-board audio chipset and it was great for about a week until Monday, when it died after rebooting for Windows Update. A headset was plugged in, and the RealTek HD Audio Manager, which opens when you plug or unplug something to do with sound, went into a loop where it announced that I had plugged in headphones, then plugged in a microphone, then unplugged headphones, then unplugged microphone, which repeated until I unplugged the headset. The computer now produces no sound.

During boot before the sound drivers are installed, occasional clicks and bumps are barely audible from the speakers. When the audio driver loads, there is a quiet click and they grow silent. Unfortunately, they remain silent, no matter what I do (see below). Right-clicking on the audio icon in the taskbar and selecting "Playback devices" produces a screen that shows the speakers as selected as default, and selecting that enables a pushbutton that produces a screen in which the speakers can be tested. Until Windows Update broke the RealTek audio, the test sounds came through the speakers or headphones. Now, only silence. The bar graph of audio output shows that the software is producing the waveforms but they are not coming out the audio jacks anymore. The Windows "Troubleshoot Audio Playback" utility finds no problems. Things that I have done include, but are not limited to, the following:
  • I downloaded and installed the latest (November 11, version 6.1.7023) sound drivers from the ASUS web site. These are the same version as were on the motherboard DVD, which I also tried. No joy.
  • I deleted the sound drivers and tried the RealTek drivers found by Windows Update. No joy. I later looked at a list on the WU web site and found that the latest RealTek sound drivers in the WU database are from 2009. I put back the ones from the ASUS web site. Still no joy.
  • I run the Windows 7 Installation DVD under the "Upgrade" option and re-installed Windows 7. During this process, I was notified that "Windows has discovered a problem with .NET4.5" which it fixed. No joy.
  • I un-installed all audio-related drivers and installed the downloaded ASUS drivers.
There seems to be no smoking gun in the System Information Hardware Resources Conflicts/Sharing list. I did a search on "audio" in System Information and turned up this repeatedly in the Windows Error Reporting:

12/11/2013 4:41 PM Windows Error Reporting Fault bucket , type 0
Event Name: ScriptedDiagFailure
Response: Not available
Cab Id: 0

Problem signature:
P1: Microsoft Corporation.AudioRecordingDiagnostic.1.0
P2: RC_NotDefault/DefaultInstanceId
P4: Default

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\NonCritical_Microsoft Corpor_b68f98d6390a610b86fe2cb0d2cc2617ecc_cab_1592bad7

Analysis symbol: 
Rechecking for solution: 0
Report Id: 2255f412-6283-11e3-81ad-ac220b50c54d
Report Status: 4

A look at all the Report.wer files showed that these were from attempts to run the troubleshooter for audio playback.

My workaround has been to order a sound card (ASUS Xonar DGX PCIe 1x, using the C-Media CMI8786 chipset, so I can plug in the front panel connector in case this problem is there for the long haul.

I have two questions:
  • I did a web search and find that Windows Update has been breaking RealTek audio regularly since at least 2006. Is this happening a lot lately with a Windows Update and the RealTek ALC892 chipset? Is there a fix or workaround?
  • It's clear that either I have a software conflict with the RealTek audio drivers or the current build of Windows 7 Ultimate has a software conflict with RealTek audio drivers. Does Windows 8.1 work with the current build and RealTek ALC892 chipset?
  • I have zero interest in touch-screen or tablet BS and have no plans to move to Windows 8. I have vast amounts of software, some of which is "mission critical" including Absoft Pro Fortran, Adobe Lightroom, Photoshop and DreamWeaver, Microsoft Office 2007, Acronis, SyncCell, Diskeeper 12, Nero 2014, Stardock ObjectDock, an HP9180 on an Eithernet switch, etc. Will Windows 8.1 break or impede the use of any of this?

My System SpecsSystem Spec
12 Dec 2013   #2

Windows 10 64 bit

I can't say I've seen this or seen it "a lot" and I've been working this forum for a while and worked the Dell forum for 10 years.

I have RealTek on both a Gigabyte Z77 motherboard (with an i7 3770 CPU) and an ASUS Z77 motherboard (with an i5 3550 CPU) and the sound has worked OK on both Win 7 64 bit and Win 8/8.1 as both systems have dual boot. Both systems are up to date with Windows updates.

I can't say about all of your software and Windows 8.1. I do know you need the latest version of Aconis, older versions do not work with Win 8 (I used to use Acronis and went to Macrium Reflect). I have Office 2003 and its not supposed to work on Win 8/8.1 but it works OK. I have the latest Nero and it is no problem. I have a (home) recording studio and all my software (I use Sonar) and all my hardware devices work the same in 'Win 7 and Win 8.

Back to your sound problem. The first suggestion is to reinstall the Intel motherboard chipset drivers. The chipset drivers identify (define) all the devices on the motherboard. They are key to the on-board audio working correctly, although other problems can also cause sound device problems. But, I would, as a first step, reinstall the chipset drivers.
My System SpecsSystem Spec
12 Dec 2013   #3

Windows 7 Professional 64 bit

I too have a home-built PC with an ASUS Crosshair IV Extreme MB. Besides the built in sound processor on the MB (Realtek), I have a Tascam US-1641 Audio/MIDI Interface which connects through USB 2.0. After a Microsoft Update this morning, I lost all sound. I got the red "X" next to the speaker icon and the notice that there was no audio device installed. I attempted everything I could think of to re-enable the sound. I researched online for about an hour and a half, but nobody's advice seemed to help my situation. I Deleted the drivers in Device Manager and reinstalled repeatedly, amongst other things. On the last handful of hair I pulled out, I decided to check when the latest Microsoft update was performed and it was this morning at 8am. There were actually 7 or 8 updates. I uninstalled them all, rebooted the PC and Voila! My sound is back. Needless to say, I don't plan on letting Microsoft install any more. But then again, my computer was getting along fine prior to these latest ones. I'm just wondering how many other people out there had the same thing happen with their sound after these updates.
My System SpecsSystem Spec

12 Dec 2013   #4

Windows 7 Ultimate 64-bit (I'm trying out W 10 Pro)

Docmac217 - Since I re-installed Windows 7 64-bit Ultimate, I lost all my Windows Updates, and when it was done it needed 131 or 161 to catch up, so I have no idea which ones were installed Monday. If you can, please list the seven updates that you un-installed to get your sound back.

I considered getting a USB sound card, but that would not provide me with front-panel jacks for my headset, which I need to host or attend a Google+ Hangout every week. Also, online searches convinced me that this problem would last a week or two unless I got lucky, which may happen if I can un-install selected updates from your next post. If so, I'll use the sound card in an old Linux box that never did have sound.

I did re-install the AMD chipset drivers. When I installed the motherboard, the first driver I installed was the network adapter, then the chipset, then the audio drivers. I did it all again. No joy.

If I get the list of 8 WU files, I will take the time to figure out which one it is and come back here with the information.

Some years ago, the same thing happened to me; it may have been a C-Media chipset, but as I recall the problem resolved itself in a few weeks with either or both the sound people and the WU people updating their files. These people *do* talk to each other and they hear from each other and the users, but anyone who has done software maintenance of apps that are widely distributed understands that fixes for complex issues like driver compatibility problems don't happen in a couple of hours, or even a couple of days. Testing each attempt at a fix takes a day or two at best.

But I have a telecon every week.
My System SpecsSystem Spec
12 Dec 2013   #5

Windows 7 Professional 64 bit

Motorfingers, unfortunately I didn't bother writing down the updates and do not know exactly which ones they were. Prior to uninstalling them, I changed the Windows Updates from automatically downloading and installing them to asking me first. What I just did right now was click on the update icon and it shows me a list of 13 important updates that are available for downloading. I do remember the last few digits of a couple of the updates - one ended in 984 (KB2893984) and the other ended in 294 (KB2893294), but I'm just not sure of the others. Do you know if there is an uninstall log available on the hard drive somewhere so I could check there? The only other thing I could suggest is to go to the Windows Update uninstall screen and find the group of updates that are dated on the same day (mine was 12/12/13) and look for the two I mentioned above. Mine were all dated the same day (today) so I uninstalled all of them and then rebooted and my sound was back. You may want to start by deleting one at a time and rebooting in between each one to see if your sound comes back. You might be able to nail down the culprit without deleting all of them that way. If you know if and where a log might be located of the ones I uninstalled, let me know and I will look them up and post back for you.
My System SpecsSystem Spec
12 Dec 2013   #6

Windows 7 Ultimate 64-bit (I'm trying out W 10 Pro)

Docmac217 - I found KB2893984 and KB2893294 in my list of updates. I'll try them when I'm done here.

You can get a list of all updates that aren't installed by running "Check for Updates" on Windows Updates. Just write down the KB numbers of all of them if I come back in a few minutes and say my sound still isn't working. I will edit this message.

EDIT: Well, that didn't go well. I un-installed KB2893984 and the system wouldn't boot. It hung just as it was about to present the login screen and turned off the monitor. Again, the DVD wouldn't repair the OS but it turned out that the boot repair manager was available, and it is the same software as far as I can tell, and it backed off to the restore point before I un-installed KB2893984. I'm not really keen on doing that again. I think to make it all hang together, you must un-install the updates sequentially beginning with the latest. That would be 23 updates, counting security and hotfix updates but not the IE 11, spelling and hyphenation packages, and updates for Office and such that are not Windows. I think I'm committed until Microsoft and RealTek work it out. That could be anywhere from in the morning to a few weeks, most likely two to three weeks, based on past experience with such things. Since this apparently happens only with a minority of users, it might be longer.
My System SpecsSystem Spec
13 Dec 2013   #7

Windows 7 ultimate 64-bit

I agree with the person above that said to go to the intel site and download the original chipset drivers for the board. As yes doing that should "identify" the devices to the system. Hopefully that will lead to a start to the end of this problem. from there i would go to the realtek site and install the original drivers for the board audio and go from there and see what happens.
My System SpecsSystem Spec
13 Dec 2013   #8

Windows 7 Ultimate 64-bit (I'm trying out W 10 Pro)

The first thing I did after loading the network card drivers from the ASUS DVD was load the chipset drivers. The chipset is an AMD 990FX/SB950. I'll check the AMD web site and see if there are any drivers newer than the ones on the DVD. On the advice of fireberd above, I did re-run the chipset installation from the ASUS DVD.

I did try the drivers from the RealTek web site. The only difference was that the playback device list was in the reverse order of the device list with the ASUS drivers. I tried the ASUS drivers from the DVD and from the ASUS web site; they are the same version and there is no difference that I can see.

I do believe that since everything was working for a week and the defining event was a Windows Update with reboot, and one other person has stepped up and said the same thing happened to him, that this is an incompatibility with one of the WU installations.

I did turn the computer off and install modules from ASUS to put connectors on the back of the computer for extra USB 2 and an RS-232 port and enable the onboard RS-232 port. I tried taking them out and disabling the port the first thing, of course, but that did nothing.

EDIT: AMD gives links to the motherboard sites for chipset drivers. The AMD file was released December 7, 2012, a year ago, and the ASUS DVD had audio drivers released less than a month ago so I expect that they are up-to-date. Interestingly enough, the DVD includes MS hotfix KB2505454 dated 2/24/11. I can't discern the chipset driver version number so I'll re-install from the downloaded file. I don't expect any change, BUT if there *is* any change, I'll post a new message.
My System SpecsSystem Spec
13 Dec 2013   #9

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64


I skimmed through the thread so apologies if anything I missed but a couple things i'll point out.

First, I disagree with what seems the consensus here: You don't need the vendor chipset drivers installed for Windows to detect the internal sound card. In fact, Windows doesn't need drivers to DETECT plug and play (PnP) hardware. Windows just can't USE the device functionality until the driver is installed. (That's the fundamental way Plug and Play works in the first place)

If a PCI (or USB) device is connected, has power and isn't disabled in BIOS, windows should detect it.

By definition, Windows talks to HD Audiolike this
Windows <==> HD Audio Controller <===> HD Audio Devices

where the HD Controller is a PCI device. Windows can't detect and install the HD devices till the controller is first installed. (Think of it similar to USB controller and devices)

IMHO: Detection is working just fine (and we can verify that too). My guess is something is corrupting the audio driver(s) and/or audio application. (there is a driver for the audio controller + one or more drivers for your HD Audio devices. I haven't read all your detail yet, but have you uninstalled Realtek from Programs and Features? done a reboot and then re-install?

/* EDIT */
p.s. the controller is a PCI device. You can verify its detection using PCI-Z. If you want to Export it and zip its output i can look at it for you. Can verify the HD Devices later.
My System SpecsSystem Spec
13 Dec 2013   #10

Windows 7 x64 Ultimate and numerous virtual machines

Here is the list of updates from this month:

Advanced Windows Update Notification for December 10th 2013
My System SpecsSystem Spec

 Windows Update Breaks RealTek Audio

Thread Tools

Similar help and support threads
Thread Forum
Windows update breaks after installing update agent 7.6.7600.320
Hi all, really hoping for some help. I have been trying to set up my older (2008) laptop with a clean install of windows 7 ultimate / 32 bit. The reason to do this is because I was given a SSD drive and wanted to set up a 100% fresh system. This laptop was before running just fine on the same...
Windows Updates & Activation
No sound after realtek audio update
Hey guys I tried to google the problem and I didnt find any solution so im doing this thread After I updated realtek audio (my driver were from 2012-2013 I dont remember exactly) but anyways after I updated them my sound gone i dont know why and when I plug microphone it wont notificate so...
Sound & Audio
Realtek Audio not working after windows update
Hi everyone I see a lot of related topics in your forum and I need your help in my case I have the following PC Compaq 500b mt with Core 2 Due CPU, E7500 @2.93GHz 64 bit OS and both realtek audio and Nvidia HD audio after some updates it is now assigned as the driver is installed and...
Sound & Audio
How do I know which audio driver update I want?(Realtek)
I have realtek HD audio driver; and when I went to the site; they had multiple downloads; I'm not sure which one I need or if I need to update.I can't click the update button on the audio manager as its grayed out.But my speakers are making buzzing/static noises and it was suggested I may need an...
Realtek audio driver update fails on reboot
Ok, Im desperate. I have tried to install the updated Realtek HD Audio drivers, from different sites, even from Gigabyte (my motherboard) and everytime I install, it fails about halfway through the install. Every time I reboot, it automatically calls the setupAR file and fails again (sound still...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:02.
Twitter Facebook Google+