Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Audio Interference Problems with my DAW

14 Dec 2013   #1

Win7 Ulitmate x64
Audio Interference Problems with my DAW

I'm hoping that there are some knowledgeable members here who know their way around digital audio workstations, music production software, and hopefully are familiar with troubleshooting audio problems.

I'm running Win7 on a system with an AMD quad-core 3.2GHz processor, 8GB RAM, and terabytes of drive space. I built this system several years ago, and it has gone through a few upgrades since its inception, but one of the items it has always had is a M-Audio Delta 66 PCI sound card. Even though the card is over 10 years old, it is such a solid, good design, it is far from being obsolesced. Other components are also hardware based, rather than software, which is the current trend. But I have updated this system's software such that I lave multiple softsynths, effects, and emulators galore.

I have several pieces of music production software on my PC, the one I use most being Cakewalk's Sonar X2. Things have been working fine until about a week ago, when I noticed a pulse occurring on my system during recorded audio playback. The pulse would vary from 120 beats per minute to 160 beats per minute. Sometimes it will be one number, sometimes another -- it doesn't slide around between these two tempos. It interrupts the audio signal briefly during each pulse, such that there is a dropout of sound. The pulse is quick in duration, I'd estimate it to be somewhere around 10ms in length, but that's an approximate number, I have not tried to measure it.

I first noticed it when I had my Alesis iO2 digital audio interface hooked up to the system via USB. Initially I suspected the iO2. But I hooked it up to my laptop and the problem was not duplicated. My Delta 66 sound card has an OMNI box that is connected to the card with a 15-pin cable. The OMNI box actually amounts to a very full featured 4-channel mixer, and I have determined to my satisfaction that it isn't causing or contributing to the problem. Currently I'm running my guitar into 1 IN, which is pre-amped, and the 1 2 OUTs go to my monitor speakers.

Among the other pieces of music production software I have on this system is Fruity Loops (Producer edition) v10, Amplitube v3, MIDIGuitar beta 0.9.4, and Band in a Box 2014. This 120-160 bpm pulse also affects Amplitube and MIDIGuitar just as bad as Sonar. Fruity Loops still shows this pulse, but it isn't as pronounced. But when I record an audio signal in Band in a Box, there is not a single trace of this pulse occurring on the playback.

I was told about the diagnostic tool, DPC Latency Checker, so I d/l'd it, installed it, and ran it. Unfortunately it didn't show a trace of this problem when I ran the software, doing a test recording, even though the recording showed evidence of it. I am reasonably certain that it is something internal to my system that's causing this pulse and that it is not an external influence. But beyond that, I haven't a clue.

This is an extremely frustrating situation. I cannot get any work done with my system behaving this way. I will be borrowing my daughter's spare laptop, which has just as much horsepower as my DAW, and I will set it up in close proximity to my DAW to see if it might be environmental in origin.

I'll check back in here after I've either confirmed or eliminated an environmental cause as the problem. Thanks for any help or insight you may be able to provide.

My System SpecsSystem Spec
14 Dec 2013   #2

Windows 10 64 bit

I currently have Sonar X3 Producer 64 bit version running on Win 7 64 bit (and Win 8.1 64 bit).

Your best option for trying to get help is the Cakewalk Sonar X forum.

My interfaces are a Roland Octa-Capture (primary unit) and an MAudio Fastrack Ultra8R (backup unit). I also have ProTools MP9, but Sonar is my "production" system. I've had Sonar since version 6.

Sonar forum: All Forums | Cakewalk Forums
My System SpecsSystem Spec
15 Dec 2013   #3

Win7 Ulitmate x64

Thanks, I'll give them a try. Since I'm having this problem with other pieces of music production software, though, I don't think it is specific to Sonar, which is why I haven't posted there yet. But I don't reckon it'll hurt any.

I began using Cakewalk's pro-level software back in about 2000, with Pro-Audio 8, then upgraded shortly after purchase to Pro Audio 9. I used it to write, perform, record, and produce two CDs of my own material. Then when I upgraded to XP, I discovered that XP "broke" Pro Audio, and that Cakewalk wasn't gonna fix it, instead they just wanted their customers to upgrade to their brand new product called Sonar. Well, I didn't want to, want to afford, or need to, upgrade at the time, so I put it off. And then I sorta got busy with other stuff for quite a while -- like building guitars -- and haven't gotten back actively involved with composition again until just recently.

I appreciate all the bells and whistles that Cakewalk has added to Sonar -- especially all the soft synths and plug-ins. But I find the product to be highly temperamental now. I frequently have to go in and wake up my audio ports by doing the Edit>Preferences>Audio settings routine just about every time I boot X2 and I don't understand why I should have to do this. Other times it just flat decides not to produce audio output, and at other times just doesn't feel like recording audio, or playing back MIDI I've written. I would have dumped it except for one reason -- I know of no other piece of production software as powerful as it is that also includes a musical notation staff window, where I can input and edit music using musical notation. Cubase doesn't. Reason doesn't. Fruity Loops doesn't. Even Presonus Studio One doesn't but since Presonus recently bought out Notation software and has plans to interface its Notion product with Studio One, perhaps there's some hope there. And since Avid owns Pro Tools, it doesn't appear they will have any interest in interfacing Sibelius with Pro Tools any time soon. Besides, the two software's philosophies couldn't be further apart.

Pretty frustrated right now, because I can't get any dadblamed work done.
My System SpecsSystem Spec

15 Dec 2013   #4

Windows 10 64 bit

Although the problems may not be Sonar (and I don't think they are) someone on there may have some help for you.

Proper setup of the PC is important to a DAW running correctly.

One thing I see you have, that caused me problems is the SoundBlaster. Sonar kept wanting to set it as the default device and I would have to change it to my recording interface unit (a Focusrite Saffire Pro 40 at the time). Even if I changed the default to the Saffire Pro 40 for one project, if I changed to another I would have to do it again as Sonar would change it back to the SoundBlaster. I finally removed the SoundBlaster and installed an HT Omega "Striker 7.1" sound card that did not have an ASIO driver and that finally fixed that problem.

I built a new system, last year, for my DAW workstation. I had an initial problem with it of noise spikes/dropouts that turned out to be a system monitor program, "EasyTune 6" that was supplied by the motherboard vendor (Gigabyte). One of the PC DAW builders (builds PC's for recording) found that problem for me on the Sonar forum and after its removal the noise spikes/dropouts disappeared. On this new system, I'm just using the integrated (on the motherboard) RealTek sound rather than an add on sound card and it does not interfere (Sonar does not detect it) with Sonar.

I don't have any experience with either the Delta 66 or the Alesis iO2. My first recording interface when I moved from a hard drive recorder to computer based was an Alesis iO26 (Firewire interface) and I had untold problems with it, even though I had the desired T.I. Chipset in the Firewire port on the PC. I replaced the iO26 with the Focusrite Saffire Pro 40 (also Firewire) and all the flakey problems I had went away. With the new PC, I decided to go with USB only.

The only other thing, do you get the noise on PC ONLY audio - not with Sonar? There are many posts on here and other forums of problems with popping/crackling/dropouts with just the PC audio. Unfortunately there is no "one fix" for this. Some of the problems are sound driver or video driver caused. Wi-Fi is another cause. A cordless phone or cell phone close by has been known to cause this.

Finally, a defective power supply can cause noise spikes. One of the PC sound chip manufacturers (don't remember which one) published some information on this problem and in their testing determined that a power supply could cause it.
My System SpecsSystem Spec
15 Dec 2013   #5

Windows 10 64 bit

One other issue that I failed to mention. If the Delta 66 you have is a PCI device that can be an issue. Most (all that I've seen) new PC's and motherboards that have a PCI slot is not a true PCI slot. It is a "bridged" PCI slot from the PCIe bus. Many PCI devices either do not work or do not work correctly in the bridged slot, from reports on many forums.
My System SpecsSystem Spec
16 Dec 2013   #6

Win7 Ulitmate x64

Thanks for all the suggestions.

Even though I mention the Soundblaster Audigy on my list of installed components, currently, it is deactivated. I've just been putting it off, removing it. It isn't hurting anything just sitting there, since the "Sound" settings don't even see it. Earlier Soundblasters had synths on chips and I have an old Soundblaster Live! that has a synth chip, although it's installed in an old, retired system right now. I've kept it around because of a few sound patches on that chip that I really like. I used a couple of them on my CDs in fact. When I bought the Audigy card, I assumed it had a synth chip, but it doesn't, so there really isn't any reason for it to be in the system anymore.

Back when I recorded the CDs, I actually had three sound cards in my system. The Delta 66, the SB Live! and a Fortissimo Card with a Yamaha XG chip on board. I found some of the XG sounds to be useful, although the noise "floor" is higher than I like with that card. Pro Audio 9 had no problems with having those three cards in the system. Plus I had three external MIDI instruments as well. I can't help but wonder what I'm in store for with Sonar (X2 for now).

My ASRock mobo installs only one item on bootup, a USB acceleration utility. It's transparent -- that is, it doesn't show itself when I'm using a USB device. There's another item that tries to install itself in memory, but errors out so it isn't installed. I don't recall the name of it offhand. I never pay attention to it, other than to dismiss its popup after boot-up. I suppose I could idle the USB accelerator. Have to check on that one.

I'm not sure what you mean by "PC Audio." Are you referring to the audio chip found on most motherboards these days? Or maybe the audio that goes through your computer's speakers that you hear when you visit YouTube or Netflix? If that's the case, as I mentioned above, when using Band in a Box, I don't get this pulse when recording from -- well, actually, I recorded the audio from a show I was watching on Netflix. I just had to set the Monitors "in" and I was in business. And interestingly enough, there were 0 beats in evidence.

My router is also my wifi source. Has been for years and I don't think it's the culprit. I looked for patterns from blik3ey. It's Been running Wifi on this machine for years and I've never noticed a problem with it. But I can't necessarily eliminate it, I suppose. I'll see what I can do to find out.

A defective Power Supply, huh . . . But regular, clock-like pusles?

I have my daughter's machine now. All I have to do is install software on it, which I will do tomorrow. It's my bedtime. 'Night.
My System SpecsSystem Spec
16 Dec 2013   #7

Windows 10 64 bit

PC Audio that I was referring to is the built on the motherboard audio chip that many have.

The power supply putting out spikes is a very real possibility. Other items I threw out, such as Wi-Fi, are known potential problem areas. Another item that caused me problems was the Google updater. That was a problem with its automatic checking for updates, whether the PC was on line or off. It was a major task to remove it as I had to manually go through the registry and remove every entry (and there were many).

There is no real way to really "remote" troubleshoot a problem like this. Eliminate any potential problems and go from there. The idled SoundBlaster still plugged in is still using system resources to some extent so physically remove it. Go into the startup (msconfig) and temporarily disable startup items that are not actually required and see what happens. I would disable that USB accelerator. Turn off autoupdaters as much as possible.

The power supply potential that was discussed by the audio chip manufacturer went into lengthy technical detail. Suffice to say that its on the list of potentials. Only problem with a power supply is that it would have to be replaced to determine if it was the problem.
My System SpecsSystem Spec
16 Dec 2013   #8

Win7 Ulitmate x64

Thanks again for your suggestions and explanations.

I guess the reason why I'm doubful it's a hardware issue, either internal or external is because this is something new that has happened. I've been working with my music production software, mostly Sonar, but other ones also, for a couple of months now, and it's only been about a week or so since this problem first appeared. Well, I know that power supplies have a life expectancy, so I suppose their quality of service can degrade. The case -- and PS as a result -- is pretty old, now that I think about it. I bought that case probably 10 years ago.

Oh, I forgot to mention one telling trait it exhibited for a while. When I had the Alesis iO2 hooked up, one of the things I tried was unplugging it from the USB port, and then plugging it back in. This caused the beats to stop, and I thought I'd solved the problem until they started up again about five minutes later. I tried unplugging and replugging it again, and it worked again, but this time only for about a minute or so. Tried it again and this time it lasted for maybe 15 seconds. Again and only a couple of seconds. And after that, every time I tried it, the beats would only stop for a couple of seconds before they started back up again.

But now that it has been removed, it shouldn't be having any affect on whatever was causing it to do that.

Ever since I discovered that the beats weren't being heard in Band in a Box, I've been wanting to test some of the other pieces of software I have installed more thoroughly. I got some of this done just now. I started with Sonar X2, then tested BiaB again, Presonus's Studio One v2, Fruity Loops v10, and Propellerhead's Reason v5. I used the same MIDI file for them all. None of them, including Sonar, are exhibiting this pulse. For now. One thing that might have been fooling me is I was listening to the same tune in Sonar, but it had been saved in a Cakewalk file format (.cwp), and it had the pulse. But this midi file doesn't. Gonna have to play around with that some more.

I'll try laying down an audio track in a little while and see if I get the same results.
My System SpecsSystem Spec
16 Dec 2013   #9

Win7 Ulitmate x64

Okay, just as a follow up, I have a bit more to add. As I mentioned above, if I import the same midi file into Sonar, the pulse is absent.

When I imported this file into the other pieces of software, I configured the midi voices within each to improve the sound quality, otherwise it would just be the MS wavetable synth. In Reason, for example, this meant calling up various plug-ins to come up with the desired sounds. And as reported, Reason and the rest handled this issue with aplomb. But when I tried loading synths in Sonar to configure the voices, I immediately noticed the pulse had returned. So I tried various plugin synths, and every one I selected caused this pulse to return. But as long as I chose the MS Wavetable Synth, it was ok.

Then I tried recording audio in Sonar. Same result as when I configured the voices in Sonar -- the pulse had returned, ruining the recording.

So it seems to be isolated to Sonar, and isolated to sound devices I try to load into it.

I think it's time I submit a post the the Cakewalk forums now.
My System SpecsSystem Spec
16 Dec 2013   #10

Windows 10 64 bit

Yes, post on the Sonar forum. Also, since you have your daughter's PC and I assume going to load Sonar on that PC, that will be a test on whether or not its Sonar (or the iO2).
My System SpecsSystem Spec

 Audio Interference Problems with my DAW

Thread Tools

Similar help and support threads
Thread Forum
Audio on some files in WMP is only squealing, interference noise
I am new to this so I apologize in advance if this isnt the correct section to put this is but I am just going to give as much detail as I can and hopefully someone can help So when I have multiple video files playing in Windows Media Player 12 on my windows 7 hp mini I never had any issues for...
Sound & Audio
Laptop audio problems possibly involving built in VIA High Def Audio
Hello I am new to this forum. I have searched for related problems here but did not find anything relevant, my apologies if this is a duplicate. What follows is a copy of a message sent to VIA (in Taiwan apparently): I seem to be having some issues with your VIA High Definition Audo drivers...
W+ALT+SPACE Interference
I play a lot of games and I use W+ALT+SPACE quite a bit. The problem is that whenever I press that combination my PC makes a horrible and loud noise. Does anyone know what this is, and how I can disable it?
General Discussion
Web Site Interference
I run a web site and people keep trying to use it for a reason other than its purpose. They complete all the text boxes with spurious letters some of which lead me to believe its for SPAM purposes. At the moment I have no samples to attache in a screen shot but...
interference in usb headphones
I'm running windows 7 and i recently bought a headset for use with lifechat in order to chat on skype which works great except for the fact that it is one of many usb devices. The other usb device i use often in my usb dongle to connect to the internet. The problem i now have is that my headset...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:45.
Twitter Facebook Google+