Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound Blaster Audigy SE will not install correctly

25 Oct 2009   #1
Srilina

Windows 7
 
 
Sound Blaster Audigy SE will not install correctly

Specs:

Windows 7 32-bit
MB Gigabyte GA-M61P-S3 mobo (nvidia/AMD compatible)
Sound Blaster Audigy SE 7.1.

I've tried numerous approaches to this so far. I tried the drivers on creative's site (Creative Worldwide Support > Audigy LS (SE)) which just will not work. I also found a user-created driver for the product on the forums, which didn't work either. I even went ahead and installed the drivers for on-board audio from gigabyte which didn't fix the problem either.

Windows tells me that the driver was not successfully installed, I get no more info about that. I've also tried letting Windows locate and install the driver for me - doesn't work either.

Sound was working perfectly with XP - is this just a driver issue that I'll have to wait out? Or is there a magical fix I haven't discovered yet?


My System SpecsSystem Spec
.
25 Oct 2009   #2
torrentg

7600.20510 x86
 
 

I hear people talking about Daniel K's drivers. Search that and give it a try.
My System SpecsSystem Spec
25 Oct 2009   #3
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Here is the DK dirvers for audigy Vista 64 you can install in compatiblity mode here is the link Sound Blaster Audigy series Vista Support Pack – Feb 24 2008 by Daniel Kawakami No More Goat Soup cpm[atibilit mode tutorial here Compatibility Mode Hope this works for your. Fabe
My System SpecsSystem Spec
.

25 Oct 2009   #4
Lee

Win 7 Pro x64, VM Win XP, Win7 Pro Sandbox, Kubuntu 11
 
 

The ones "thefabe" is suggesting are the ones I had to go with. Been using them since the Public Beta without any problems.
My System SpecsSystem Spec
25 Oct 2009   #5
Srilina

Windows 7
 
 

Thanks for the suggestions but I tried those too and couldn't get them to work. I think my problem might be that Windows keeps trying to install the drivers for me and thus conflicts? I've turned off both update and checked "never install windows drivers from update" which hasn't stopped windows from trying...is there any way to absolutely prevent Windows from installing a driver? Because I'm now getting a similar problem when installing my printer.
My System SpecsSystem Spec
25 Oct 2009   #6
Srilina

Windows 7
 
 

Havent tried compatibility mode yet though so I'll do that and report back
My System SpecsSystem Spec
25 Oct 2009   #7
Srilina

Windows 7
 
 

okay - so none of that worked unfortunately. The drivers are installing but not recognizing that my sound card even exists - I also just changed it to a different PCI slot (still didn't work).

So! A. is there a way to check and see if the card is getting power?
B. any way for me to stop Windows from installing drivers period?
My System SpecsSystem Spec
25 Oct 2009   #8
kodi

Windows 10 Pro x64
 
 

I am running 64 bit with these drivers and having no problems
They were available as a Windows Update on 14oct 2009
My System SpecsSystem Spec
26 Oct 2009   #9
Srilina

Windows 7
 
 

Yes, I'm running 32-bit though and have installed the Windows supplied drivers, and tried different ones - none have worked.

I also installed XP on another HDD, tried it with this computer, and the sound card definitely functions. So it's powered and works, just not with 7.
My System SpecsSystem Spec
26 Oct 2009   #10
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Their is a driver from KX that some people are using. link kX Project -- Downloads page On this page http://kb.kxproject.lugosoft.com/list.html their is a list of doc's,issues,change logs,bugs and forums as well as screenshots. That can be helpful. The print is rather small but it is all listed at the top of the page under project. Unfortunately I don't see any tutorials for installing in compatibility mode if needed so here is another link. Fabe Compatibility Mode
My System SpecsSystem Spec
Reply

 Sound Blaster Audigy SE will not install correctly




Thread Tools




Similar help and support threads
Thread Forum
Sound Blaster Audigy 2 Platinum ex does not sound in Win7x64
Hello; I'm trying to make my "Sound Blaster Audigy 2 Platinum ex" works on Windows 7 64 bits, I did install the most new version of the drivers provided by Creative Labs, it seems like it is installed without any problems....the Device Manager shows all drivers are installed correctly...when I...
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Sound Blaster audigy 2 Value malfunction
Hi. First of all, i would like to say, that i am from central europe, non-english speaking country so be tolerant to my language mistakes, please. Thanks. I didn't find here, or anywhere else, someone with similar problem, so that im asking you for help. Some time ago my sound card just stop...
Sound & Audio
Sound Blaster Audigy 2 isn't nearly as loud in Win 7
my sound card is the SB audigy 2. Back in XP the drivers usually worked fine and produced the right 'loudness' of sound. however in windows 7 the drivers that were automatically installed upon the OS installation do NOT play audio at the regular decibel levels. I tried going to downloading the...
Sound & Audio
Sound Blaster Audigy
seems a lot of people are having issues with the sound blaster audigy cards, me included. Im dual bootin windows 7 and XP, on windows XP my sound card works and everything, when i boot in windows 7, dosnt even detect my card. I have the driver i need to get it to work, its just not detecting it to...
Sound & Audio
Sound Blaster Audigy 2 isn't nearly as loud in Win 7
my sound card is the SB audigy 2 zs platinum. Back in XP the drivers usually worked fine and produced the right 'loudness' of sound. in vista i had to try a few different sets of drivers but got it working correct. however in windows 7 the drivers that were automatically installed upon the OS...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App