Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No sound from HDMI device Nvidia and Realtek HD Audio

29 Oct 2009   #21
ba5ik

Windows 7 Ultimate x64 RTM
 
 

do you have speakers connected to the back of the computer?


My System SpecsSystem Spec
.
29 Oct 2009   #22
amzo

Windows 7 64Bit
 
 

OMG!!...I got this working now!! Realtek digital output without the passthrough enabled and with the Nvidia beta driver installed I mentioned earlier!

Many Thanks everyone for helping
My System SpecsSystem Spec
29 Oct 2009   #23
amzo

Windows 7 64Bit
 
 

Quote   Quote: Originally Posted by ba5ik View Post
do you have speakers connected to the back of the computer?
No other speaker etc were attached...Looks like the Nvidia beta driver worked! Forceware 195.39 Win 7 | Vista (64-bit )
My System SpecsSystem Spec
.

29 Oct 2009   #24
amzo

Windows 7 64Bit
 
 

It would be interesting to see if this resolves the issue for other people mentioning the same issue with Nvidia and Realtek sound issues over HDMI


Attached Images
No sound from HDMI device Nvidia and Realtek HD Audio-screenhunter_02-oct.-29-17.57.gif 
My System SpecsSystem Spec
29 Oct 2009   #25
ba5ik

Windows 7 Ultimate x64 RTM
 
 

Glad to hear its now working... I have no idea how, but enjoy
My System SpecsSystem Spec
29 Oct 2009   #26
amzo

Windows 7 64Bit
 
 

Actually...Just discovered the only problem is front jack detection does not work and so I have to manually select speaker to hear sound through the headphones...But that is not a big issue for me ;o)
My System SpecsSystem Spec
29 Oct 2009   #27
amzo

Windows 7 64Bit
 
 

Quote   Quote: Originally Posted by ba5ik View Post
Glad to hear its now working... I have no idea how, but enjoy
Neither do I lol! thanks for the help though...

Definately is a driver issue as searching google for "realtek HDMI no sound Nvidia" pulled up alot of threads with others having the same issue...and experienced it since updating nvidia drivers on vista...However reverting to older drivers did not help with windows 7???
My System SpecsSystem Spec
29 Oct 2009   #28
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by ba5ik View Post
Glad to hear its now working... I have no idea how, but enjoy
That makes two of us, but as you said it is working now and that is all that matters.
My System SpecsSystem Spec
05 Nov 2009   #29
patrick

w7 ultimate
 
 
same Problem as amzo

Hi Amzo, Hi all

I have the same computer as you have md8818... installed win7... and now audio over hdmi does not work anymore

... so i tried to install the same nvidea drive as you have installed... but still no audio over hdmi

... what have you ment with "passthrough enabled" ... where can i do that?

(realtek driver v2.36, nvidia 8.17.11.9539, )

do you have any suggestions for me?

thx
My System SpecsSystem Spec
05 Nov 2009   #30
ba5ik

Windows 7 Ultimate x64 RTM
 
 

It would be hard for us to help resolve this issue as we have no idea how Amzo got it working... the fact that you installed the same driver as him and it isn't working brings us back to square one... but we can try
My System SpecsSystem Spec
Reply

 No sound from HDMI device Nvidia and Realtek HD Audio




Thread Tools




Similar help and support threads
Thread Forum
Windows shows an audio device but doesn't play any sound. (Realtek)
The past few days I found that I could no longer hear anything from my earphones when I plugged in my earphones.The problem first started when I started the computer without plugging the ram completely into its socket. After I plugged the ram back in, the bios said it restored itself to the default...
Sound & Audio
Realtek HDMI+NVIDIA = no sound+frezze screen using pc rear audio jack
Hi every one i am new at this i might carry on please forgive me if that happens. i am having this Realtek HDMI+NVIDIA =No Sound issue + if i connect back to my rear audio jack with my speakers its fine to listen music but it freeze the screen during game play and gives out a loud buzz sound than...
Sound & Audio
realtek high definition audio device - no sound
Hi, I just got a new PC and I can't get the sound to work. My PC has the following specs: Microsoft Windows 7 (6.1) Enterprise Edition 64-bit Service Pack 1 (Build 7601) DirectX Version 11.0 CPU Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz Mainboard Model ...
Sound & Audio
HDMI Audio Out, Realtek + Nvidia
Hi Guys, I really need some help with this one. I purchased a new PC, with a Gigabyte GA-H61MA-D2V motherboard that has on board realtek audio, I also purchased a nvidia geforce GT630 graphics card which has a built in audio processor and hdmi connection which is going to my LG 42PL6010 tv. ...
Sound & Audio
5.1 Sound doesnt work at Realtek High Definition Audio Device
Hello, Some time ago i was tried to connect my 5.1 creative speakers to my laptop and when i wass connecting one by one the cables windows 7 asked me what speakers it will play ( Rear, Front, Center) but now i try to connect them again and it does not ask me that ... and only 2 speakers and sub is...
Sound & Audio
Realtek HDMI+NVIDIA vc=No Sound
Hi to all. A lot of people have this problem and I've read everything in tihs forum regarding it (in other forums too) but I still can't get it fixed. When I connect my HDMI with the TV I get picture but no sound.Here's what I've tried so far : -Installing lates Realtek 2.51 and NVIDIA...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App