Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Default Audio Device Problem

04 Feb 2009   #21
NosferatuX

Windows 7 Build 7048 x64
 
 
Realtek HD Audio Properties

For Realtek HD users, this might help;

In Realtek's HD Audio Manager


I find it very useful to not combine inputs and outputs. You can do this by clicking on advanced device properties


Under Playback, select "Make front and rear output devices playback two different audio streams simultaneously" and
Under Recording, select "Separate all input jacks as independent input devices

Clicking "Ok" on this page will separate all output devices and separate all input devices you have on your system. Once on the main GUI, you can then select the default device you want to use as your input/output.

If you've plugged something on your front panel, you might want to click on the "Folder" icon which brings up this control


Then select the appropriate ones for your setup.

These two property windows will let you effectively control your input/output devices properly.

In my experience, combining or tying up input/output devices works well only if you have single input/output devices attached but not so great with multiple input/output devices.
This might work with other audio controllers as well


My System SpecsSystem Spec
.
04 Feb 2009   #22
NosferatuX

Windows 7 Build 7048 x64
 
 

Quote   Quote: Originally Posted by Mr GRiM View Post
Same here it's a bit annoying, has anyone tried going into properties for their USB device and changed the Exclusive mode setting, not sure what it does but I thought I would see if it makes a difference if you disable it, has anyone else tried it?

Attachment 4114
I tried playing with this but honestly, I couldn't tell the difference in sound quality and I consider myself and audio freak
My System SpecsSystem Spec
04 Feb 2009   #23
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Quote   Quote: Originally Posted by NosferatuX View Post
I tried playing with this but honestly, I couldn't tell the difference in sound quality and I consider myself and audio freak
Sorry I was not commenting on audio quality, merely the fact that using a USB sound device and having it always being set back to default on every startup, I have tried a restart after posting and now this device is not being used as default after a restart, so I beleive that may be the fix for that particular problem or I might have just been lucky that time and yes I have Realtek but that does not have anything to do with my USB headphones as they are seperate devices and your previous post will only effect using the front panel.
My System SpecsSystem Spec
.

04 Feb 2009   #24
NosferatuX

Windows 7 Build 7048 x64
 
 

You're absolutely correct. Point taken
Post corrected.
My System SpecsSystem Spec
04 Feb 2009   #25
smokozuna

Windows 7 Build 7000
 
 

Quote   Quote: Originally Posted by NosferatuX View Post
I'd like to see what we can do with this issue. Would you mind filling in your system specs?
System specs updated.
My System SpecsSystem Spec
04 Feb 2009   #26
smokozuna

Windows 7 Build 7000
 
 

Quote   Quote: Originally Posted by Mr GRiM View Post
Same here it's a bit annoying, has anyone tried going into properties for their USB device and changed the Exclusive mode setting, not sure what it does but I thought I would see if it makes a difference if you disable it, has anyone else tried it?

Attachment 4114
I just tried this and after restart Windows 7 has to reinstall the device driver for the Magicjack, which failed to install BTW. LOL
My System SpecsSystem Spec
04 Feb 2009   #27
smokozuna

Windows 7 Build 7000
 
 

Quote   Quote: Originally Posted by NosferatuX View Post
I tried playing with this but honestly, I couldn't tell the difference in sound quality and I consider myself and audio freak
I followed your examples exactly but unfortunately that did not fix the problem.
My System SpecsSystem Spec
04 Feb 2009   #28
smokozuna

Windows 7 Build 7000
 
 

Quote   Quote: Originally Posted by Mr GRiM View Post
Sorry I was not commenting on audio quality, merely the fact that using a USB sound device and having it always being set back to default on every startup, I have tried a restart after posting and now this device is not being used as default after a restart, so I beleive that may be the fix for that particular problem or I might have just been lucky that time and yes I have Realtek but that does not have anything to do with my USB headphones as they are seperate devices and your previous post will only effect using the front panel.
After reading this I tried it again but upon restart Magicjack will not start at all, even if I double click the icon. So I had to unplug Magicjack from the USB in the back of the computer, then replug it and it started but changed my default back to USB, so I manually changed the default back to Realtek.

So if I restart, shut down, or just unplug Magicjack and replug it, it resets the audio default to USB every single time. I gotta say, I am getting used to it though. LOL
My System SpecsSystem Spec
04 Feb 2009   #29
NosferatuX

Windows 7 Build 7048 x64
 
 

Quote   Quote: Originally Posted by smokozuna View Post
After reading this I tried it again but upon restart Magicjack will not start at all, even if I double click the icon. So I had to unplug Magicjack from the USB in the back of the computer, then replug it and it started but changed my default back to USB, so I manually changed the default back to Realtek.

So if I restart, shut down, or just unplug Magicjack and replug it, it resets the audio default to USB every single time. I gotta say, I am getting used to it though. LOL
LOL
Ok... This is a different approach, let's try this one
With MagicJack plugged in and running, open a run command (Win+R) type in msconfig then go to "Boot" and put a check mark on "Make all boot settings permanent"



Click on "Advanced Options" and put a check on "Detect HAL"



Click on "OK" and "OK" again.
It will then prompt for a restart. Restart.
Let it boot normally even if it pauses while detecting your USB devices.

Let us know how it turns out
My System SpecsSystem Spec
04 Feb 2009   #30
smokozuna

Windows 7 Build 7000
 
 

I'll do that in just a second but before I do I want to let you know that on my laptop this problem absolutely does not happen. I can restart, shut down, and Windows 7 saves the default audio device correctly every single time. So, could it be hardware related? My laptop uses Mobile Intel GL960 Express Chipset but my PC uses Intel® G33 and ICH9 chipsets.
My System SpecsSystem Spec
Reply

 Default Audio Device Problem




Thread Tools




Similar help and support threads
Thread Forum
audio device isn't set as default, can't make it default
Hi all, Windows 7 Home Premium x64 on HP-DM1-4050us laptop, disabled a couple of unneeded services, now headphones not working, no idea which service caused this but I didn't touch either of the two required audio services (Windows Audio, Windows Audio Endpoint Builder). Audio now plays fine...
Sound & Audio
Audio Playback (Default Device Realtek) Knocks Out SRS Audio Sandbox
Hi, I finally upgraded from Windows XP to Windows 7 and almost went back shortly after finding out I could no longer organize or manually arrange my own personal files and/or folders but luckily I discovered an application called 'Folder Options X' which has re-enabled that feature for me so I'm...
Sound & Audio
Batch file to change default audio device
Hi all, I have my computer hooked up to a home theater system. Most of the time, my computer audio output is set to my on-board motherboard audio connected to simple speakers, but I frequently switch the default device to digital output through my sound card (HTO Striker 7.1). My goal is to...
Sound & Audio
Problem selecting Default Audio Device
I'm having a problem with my sound devices. I plug my headphones in, my headphones work fine in other devices, but my computer still runs the sound through the inbuilt speakers instead of through the headphones. The only program I can run through the headphones is WIndows Media Player because I...
Sound & Audio
WMP11 Play Audio through different device than Default?
Hi everyone, I got a hard question (well, at least I believe it is). When I plug my usb headset into my computer it automatically becomes the default/standard device - which is fine. When I play music, play games all the sound comes out of my headset. But lets say I want the music to be played...
Sound & Audio
ARGHHH No audio with HDMI (but it is my default device)
Yes, another thread -HDMI to HDMI from PC to TV - no sound- however my default device is my HDMI( under playback devices - I have the green checkmark and when I click on the speaker icon it show the green bars moving) still no sound. I have tryed everything - installed drivers - changed the...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App