Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek HDMI: HDCP in Vista; not in Win7

11 Feb 2009   #11
hallfleming

Windows 7
 
 

I tried uninstalling both and back on in the order. No luck. I'm formatting it. Should I do the realtek HD, then HDMI, and then the catalyst? Or, catalyst before the realteks?

Thanks so much for your help!


My System SpecsSystem Spec
.
11 Feb 2009   #12
Dragonfly

Windows 7 Ultimate 32 & 64 -(Boot Camped Snow Leopard on a Mac Mini)
 
 

Quote   Quote: Originally Posted by hallfleming View Post
I tried uninstalling both and back on in the order. No luck. I'm formatting it. Should I do the realtek HD, then HDMI, and then the catalyst? Or, catalyst before the realteks?

Thanks so much for your help!
Not sure it makes a difference, but I installed the video drivers first, followed by the Realtek HD, and then the HDMI.

Try using the catalyst setup from your Asus install disk and see if that makes a difference.
My System SpecsSystem Spec
11 Feb 2009   #13
hallfleming

Windows 7
 
 

I just tried a fresh install and then the realtek hd, then hdmi. No go. I tried to add the latest catalyst drivers and the thing memory dumps everytime on that install. I'm formatting now and trying the asus vista drivers now.

I would use the CD that came with it but I chunked them the day I got 'em.
My System SpecsSystem Spec
.

11 Feb 2009   #14
Dragonfly

Windows 7 Ultimate 32 & 64 -(Boot Camped Snow Leopard on a Mac Mini)
 
 

Quote   Quote: Originally Posted by hallfleming View Post
I would use the CD that came with it but I chunked them the day I got 'em.
Been there; done that. Now I always backup copy every install CD I get to a "Reinstall" directory.
My System SpecsSystem Spec
11 Feb 2009   #15
hallfleming

Windows 7
 
 

I give up. I've worked on this for hours (again). I got the Asus catalyst vista drivers installed, did the 2.15 Realtek HD, then the 2.13 HDMI drivers. No go. I've tried copying, replacing, turning services on and off, digging through ini's, every version and driver i could get... I can't get the HD audio manager to show up.

It's like audio manager never gets installed. I've got everything working except for my digital out. I tired of seeing "PCM, DSP" on my Onkyo! I'm delirious from this thing!!!!!

I would buy another low profile pci hdmi card tomorrow if I knew it would work...
My System SpecsSystem Spec
12 Feb 2009   #16
Dragonfly

Windows 7 Ultimate 32 & 64 -(Boot Camped Snow Leopard on a Mac Mini)
 
 

RtHDVCpl.exe is the HD Audio Control Panel. It's in the HDA folder under Program Files/Realtek/Audio on my Win7 machine.
My System SpecsSystem Spec
12 Feb 2009   #17
hallfleming

Windows 7
 
 

Mines under program files/realtek/audio/installshield

Somethings not right when I install it...

Quote   Quote: Originally Posted by Dragonfly View Post
RtHDVCpl.exe is the HD Audio Control Panel. It's in the HDA folder under Program Files/Realtek/Audio on my Win7 machine.
My System SpecsSystem Spec
12 Feb 2009   #18
hallfleming

Windows 7
 
 

So I enabled administrator log ons and did the 2.15 install. It memory dumped on the next boot and then ran the repair on the next boot. Whats weird, is after that, I see the install files under the realtek/audio directory. I'm getting closer! What I don't see is any reference to rthdvcpl.exe in the registry or startup items.

Anybody got some info on these? I WILL get this working.
My System SpecsSystem Spec
23 Feb 2009   #19
pratappankaj2001

window7
 
 

Hi,
i installed ATI vista audio driver for win7 ( not realtek ), but in pass thorugh mode it is not working with cyberlink , but using other player i am able to play .
but if i installed realtek driver then i uninstalled realtek and installed ati driver it is working fine ? have u seen this?
My System SpecsSystem Spec
14 Aug 2009   #20
toyo

Windows 7 x64 Ultimate
 
 

Hello,

I confirm this problem - no HDCP on the Realtek ALC1200 from a P5Q, Asus 4850 HDMI connection to 1.3 HDMI monitor - through the usual DVI-HDMI dongle, if it's important. It worked on XP SP3.
There are also problems in the DirectX/EAX support take a look at the screenshots.

EDIT: After some reading (I skipped on Vista, so only now I find out about this...) I understand it's a... natural condition for Vista/Win 7, as it killed EAX and other proprietary formats in favor of OpenAL. As I didn't play any games yet I have no idea how this will affect me.


Attached Thumbnails
Realtek HDMI: HDCP in Vista; not in Win7-nodirectxandeaxsupport.png  
Attached Images
Realtek HDMI: HDCP in Vista; not in Win7-hdcp.png 
My System SpecsSystem Spec
Reply

 Realtek HDMI: HDCP in Vista; not in Win7




Thread Tools




Similar help and support threads
Thread Forum
Dell Inspiron N7010, intel HD: need help sorting driver / HDCP / HDMI
gang I'm having trouble helping someone with this N7010 model Inspiron. what chipset does the non-ATI model have and can you guys direct me to the best Video driver to use for the model? having lots of issues getting Sync'd to HDTV or other external monitors over HDMI... very stubborn about...
Graphic Cards
Realtek HDMI Output ATI HDMI Audio -Not Plugged In-
I'm trying to hook up my TV with my computer, and for the most part it's working. The video goes through and I get how to control it and everything. The only thing not working is the sound. I'm using an HDMI to HDMI cable, and like I said the video is fine. Also, when the cable is plugged into...
Sound & Audio
HDMI Audio Out, Realtek + Nvidia
Hi Guys, I really need some help with this one. I purchased a new PC, with a Gigabyte GA-H61MA-D2V motherboard that has on board realtek audio, I also purchased a nvidia geforce GT630 graphics card which has a built in audio processor and hdmi connection which is going to my LG 42PL6010 tv. ...
Sound & Audio
Realtek:hdmi support
hey everyone.I have a problem:how do i get HDMI options in my REALTEK audio konfiguration.I have my laptop connected to plasma screen via HDMI and i would like some sound effects do anyone know how to proceed.KIND REGARDS ASSER:cry:
Sound & Audio
Realtek HDMI+NVIDIA vc=No Sound
Hi to all. A lot of people have this problem and I've read everything in tihs forum regarding it (in other forums too) but I still can't get it fixed. When I connect my HDMI with the TV I get picture but no sound.Here's what I've tried so far : -Installing lates Realtek 2.51 and NVIDIA...
Sound & Audio
Build 7057 - Realtek HDMI only getting 2.0
Hi, I have Windows 7 build 7057 installed. I just installed Realtek HD Audio Drivers 2.21 and I am finally able to get sound out of my HD 3300 integrated HDMI port. Now the problem is I am only getting 2.0 instead of 5.1. When I click the Configure button on the HDMI jack in Sound...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App