Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: X-Fi SoundBlaster Issue

11 Nov 2009   #11
Arcalimon

Windows 7 Ultimate 64bit
 
 

I've followed your instructions closely, still the sound is dirty and screeches a lot
and with youtube vanishses after 2 seconds.

Also i've installed the programs from the X-Fi Support Pack 2 and it tells me that my device is not supported O.o

I'm desperate, i've tried really everything


My System SpecsSystem Spec
.
11 Nov 2009   #12
hanksta2

Windows 7 Ultimate 64
 
 

Until I figured out my little work around, I had to leave my sound settings on 2 channel stereo.


This sound thing has been very frustrating!
My System SpecsSystem Spec
Reply

 X-Fi SoundBlaster Issue




Thread Tools




Similar help and support threads
Thread Forum
creative soundblaster
If I an internal creative soundblaster soundcard, do I have to uninstall it and pull it from my pc and reenable the realtek sound before changing from windows 7 home premuium to windows 10 ? Thanks
Sound & Audio
Soundblaster Live Value 4.1 Speakers issue
Hi, other day, i instaled Win7 on my pc and i noticed a little big problem, i can't find drivers for my sound card Soundblaster Live Value 4.1. I used the ngocmd.exe but it only capt 2 of my 4.1 speakers. In Vista, the same patch/driver works fine, appears the 4.1 speakers, but in Win7 doesn't...
Sound & Audio
Soundblaster X-FI Issues
As many people know, Creative Labs has virtually zero customer support and makes the shoddiest drivers ever for their products. I wasn't until about a year after Vista was launched that I could use all the features on my X-Fi XtremeMusic and now, as many people are having, there's another whole...
Sound & Audio
Soundblaster NX2
No BASS :(:( in mp3 or in stereo files :( | In 5.1 dvd-s all speaker works.. but in youtube or other non 5.1 files the center and the woofer not works help me pls :\ Windows Seven Rules ! :)
Sound & Audio
Creative SoundBlaster 5.1
got a problem installing with driver, any solution? i check the creative site, they don't seem to have an installer for my soundcard?
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App