Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't find Audiobox ASIO Drivers in any of my DAW's??

19 Jan 2017   #1
Shibetarian

Windows 7 Professional 64-Bit
 
 
Can't find Audiobox ASIO Drivers in any of my DAW's??

Ok so this has been irritating me for the past few weeks. After installing an update for my Presonus Audiobox 22VSL drivers, I lost the "Audiobox ASIO Device" To use in all of my daws. Without it, I can't get down to 64 samples and record and playback audio without a horrible latency that prevents me from recording/playing keys on time. So far Presonus tech support has not been able to help, at all really. The only thing they've asked me to do is to send system reports, and uninstall & reinstall the drivers. I've done that, multiple times, hell i've even done an entire repair install with my windows 7 CD, and I still couldn't get it to work. It doesn't work in safe mode, I have no corrupted files when doing the sfc scannow command in CMD, so I have no clue what caused it to be gone. Basically if I open FL Studio, or Studio One 3, and I go over to the audio device settings, there's the regular ASIO4ALL, and the FL Studio ASIO Driver. But neither of those can go down to 64 samples. Interestingly enough it works on another random laptop, so I don't know why it doesn't work here.


My System SpecsSystem Spec
.
19 Jan 2017   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome Shibetarian yes mate support from some manufacturers pretty ordinary eh?

Now I would if it were me run this as well as the SFC and the others just because they might just pick something up.
Disk Check < if necessary include the /f and /r in the command line as per Option2 (if you are going to use the /r switch there is no need for the /f switch)
Run these in safe mode and the sfc often best run for two to three runs you can leave out the /r switch in ckdsk if you feel it not necessary


if no fix then these

SUPERAntiSpyware | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware!
Malwarebytes | Malwarebytes Premium
AdwCleaner Download
ADW download from bleeping computer delete any rubbish found with the malware scans
(NB If you are running Kaspersky as the main AV then it might need disabling it when trying ADW because it does not like it at times)

Now it may seem odd to say but have you tried disabling the AV while you are installing the drivers for the Audiobox?? Some AV's can produce issues like this.
My System SpecsSystem Spec
20 Jan 2017   #3
Shibetarian

Windows 7 Professional 64-Bit
 
 

Quote   Quote: Originally Posted by ICIT2LOL View Post
Hello and welcome Shibetarian yes mate support from some manufacturers pretty ordinary eh?

Now I would if it were me run this as well as the SFC and the others just because they might just pick something up.
Disk Check < if necessary include the /f and /r in the command line as per Option2 (if you are going to use the /r switch there is no need for the /f switch)
Run these in safe mode and the sfc often best run for two to three runs you can leave out the /r switch in ckdsk if you feel it not necessary


if no fix then these

SUPERAntiSpyware | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware!
Malwarebytes | Malwarebytes Premium
AdwCleaner Download
ADW download from bleeping computer delete any rubbish found with the malware scans
(NB If you are running Kaspersky as the main AV then it might need disabling it when trying ADW because it does not like it at times)

Now it may seem odd to say but have you tried disabling the AV while you are installing the drivers for the Audiobox?? Some AV's can produce issues like this.
Just did all that, sfc scan as well as check disc in safemode, and while the chkdsk did find something and fixed it, upon restart and reinstalling the interface drivers I still don't have the audio device i'm looking for. Already tried disabling AV as well. Virus scans brought up nothing as well. From what I can recall this happened right after I installed a driver update for the box, however it was actually the same version and I had not realized until a restart. But i've already fully uninstalled the drivers and reinstalled them many times, so I don't know what the issue is. I have a feeling it may be something with the registry? But i'm not too sure.
My System SpecsSystem Spec
.

20 Jan 2017   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Now forgive my ignorance but am I right to assume the Audio Box is an external device? I am guessing it is from looking at the product page and are these the drivers for the device you are using?? AudioBox USB Downloads | PreSonus

Now if the drivers from here do not work then I am wondering if the device itself is ok or not? Again assuming it is an external device have you tried changing the hook up cables and if it is USB connect maybe it would be worth updating the USB drivers for the board.
Support For H97 PC Mate | MSI USA | Motherboard - The world leader in motherboard design 64 and even maybe the chipset.
My System SpecsSystem Spec
20 Jan 2017   #5
Shibetarian

Windows 7 Professional 64-Bit
 
 

Quote   Quote: Originally Posted by ICIT2LOL View Post
Now forgive my ignorance but am I right to assume the Audio Box is an external device? I am guessing it is from looking at the product page and are these the drivers for the device you are using?? AudioBox USB Downloads | PreSonus

Now if the drivers from here do not work then I am wondering if the device itself is ok or not? Again assuming it is an external device have you tried changing the hook up cables and if it is USB connect maybe it would be worth updating the USB drivers for the board.
Support For H97 PC Mate | MSI USA | Motherboard - The world leader in motherboard design 64 and even maybe the chipset.
Will definitely try that, I haven't thought of updating any of those drivers yet.
My System SpecsSystem Spec
20 Jan 2017   #6
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok mate keep us updated am really interested to see what the outcome is.
My System SpecsSystem Spec
20 Jan 2017   #7
Shibetarian

Windows 7 Professional 64-Bit
 
 

Sadly it hasn't worked.
My System SpecsSystem Spec
20 Jan 2017   #8
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

That is a blow I was rather hoping the chipset one would come up with something.

Now I read through the first post again and I found out what DAWS actually is and being a semi audiophile myself I can see why it must be so frustrating for you.

Now in that post as well you mention updating the Presonus stuff if you can remember when you did that it might be as well to try a system restore to before then when the system was working. I was wondering too was that update really critical if not just don't use it. Anyway that is assuming that the restore works.
My System SpecsSystem Spec
25 Jan 2017   #9
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

What DAW are you using?

It sounds like you have a corrupted driver caused by either a faulty update, or the disk problem that chkdsk fixed. If the system restore doesn't work, or you can't use the restore point anymore, try uninstalling the ASIO driver with Revo Uninstaller. It does a pretty thorough job of cleaning up when uninstalling, often getting stuff that the regular install program might miss.

You can get it here (just use the freeware version)

Download Revo Uninstaller Freeware - Free and Full Download - Uninstall software, remove programs, solve uninstall problems

The reason that you want to use something like Revo is that if the driver is borked, it may not be uninstalling properly, and thus, when you go to reinstall, the corrupted information remains and the driver will not install and work properly.

I hope that you can use System Restore to fix the problem as it is easier, but Revo is an option.
My System SpecsSystem Spec
Reply

 Can't find Audiobox ASIO Drivers in any of my DAW's??




Thread Tools




Similar help and support threads
Thread Forum
ASIO drivers only available in Windows 7 Safe Mode
Hi, there! I have a Windows 7 Home Premium 64bit Dell XPS17 (L702X) laptop which I have used for the last 2 years for music recording. However, for the last few days, no audio recording software has been able to detect the ASIO drivers for the audio interface I use (MOTU UltraLite mk3 Hybrid),...
Sound & Audio
Drivers - Find and Update Outdated Drivers
How to Find and Update Outdated Drivers in Windows First of all, I want to give the credit to my friend Northernsoul55 who made me aware about this useful tool, NirSoft Driverview. Driver update. Sometimes it is a big question to us. We are sometimes confused about which driver is...
Tutorials
How to determine if your board has ASIO drivers?
Hello to all, I downloaded a program for music recording and it requires an ASIO driver. Not knowing what that is, how would I go about finding out? Thanks for any assistance! Glenn
Sound & Audio
Base System Device drivers error - unable to find drivers
Hi there, I have an HP Pavilion DV7 2185dx laptop running a freshly installed windows 7 upgrade from windows Vista. Ever since the upgrade my CPU is constantly running at 98-100% all the time meaning I cannot do anything on my PC. After researching a bit online it could possibly be the driver...
Drivers
BSOD following ASIO drivers for Gibson RIP Hardware
I recently installed the ASIO drivers for my Gibson RIP. The sound worked at first (tentatively, trying to open programs/the start menu/click on links would cause any sound to freeze) but I was then met with a BSOD citing "DRIVE_IRQL_NOT_LESS_OR_EQUAL". I'm attempting to zip up the appropriate...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App