Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound to my USB headphones gets interrupted

25 Jul 2017   #1
Kinazura

Windows 7 Ultimate x64
 
 
Sound to my USB headphones gets interrupted

So, I use YouTube or play games(specifically PCSX2 currently) and during that activity my sound gets interrupted every 10-20 minutes, sometimes even more often. It's not related to those specific programs, it happens everywhere. When it happens, I have to reconnect my headphones, otherwise it probably won't restart the audio to the headphones. Also, it takes a while for them to get recognized after connecting them. How do I prevent this from happening and speed up the recognizing time?(this might be my imagination but whenever I raise the cable upwards it connects a lot faster. No, it's not a hardware issue, because I had absolutely no issues on Windows 10 or 8 or any of the Linuxes.)
Sound is from onboard on ASUS H81M-K motherboard.
System is a Windows 7 x64 Ultimate, newest updates installed, however only the important ones.


My System SpecsSystem Spec
.
25 Jul 2017   #2
fireberd

Windows 10 64 bit
 
 

First, a USB device such as your headset does not use the internal PC's sound but rather takes the digital audio and converts it to analog for the headphones internally in the headphones.

Because you have to "raise the cable upwards" it suggests a problem with either the headset cable/connector or USB port (if you are only using the same USB port each time). This is the most likely suspect for problems/disconnects.
My System SpecsSystem Spec
25 Jul 2017   #3
Kinazura

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by fireberd View Post
First, a USB device such as your headset does not use the internal PC's sound but rather takes the digital audio and converts it to analog for the headphones internally in the headphones.

Because you have to "raise the cable upwards" it suggests a problem with either the headset cable/connector or USB port (if you are only using the same USB port each time). This is the most likely suspect for problems/disconnects.
I am pretty sure this is not the issue because, as I mentioned, I had absolutely no problems on other operating systems.
My System SpecsSystem Spec
.

25 Jul 2017   #4
fireberd

Windows 10 64 bit
 
 

Run the free Resplendence Latency Mon and see what it reports.
http://www.resplendence.com/latencymon
My System SpecsSystem Spec
26 Jul 2017   #5
Kinazura

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by fireberd View Post
Run the free Resplendence Latency Mon and see what it reports.
http://www.resplendence.com/latencymon
I ran it for 3 minutes, I'll copy the results from the Stats bar to here.
Highest measured interrupt to process latency (s): 25450,705414 (this spiked a lot during the test)
Average measured interrupt to process latency (s): 8,077319

Highest measured interrupt to DPC latency (s): 174,481327
Average measured interrupt to DPC latency (s): 1,683235

Highest ISR routine execution time (s): 103,911623
Driver with highest ISR routine execution time: dxgkrnl.sys - DirectX Graphics Kernel, Microsoft Corporation

Highest reported total ISR routine time (%): 0,232646
Driver with highest ISR total time: dxgkrnl.sys - DirectX Graphics Kernel, Microsoft Corporation

Total time spent in ISRs (%) 0,522988
ISR count (execution time <250 s): 319139 (all 0 after this one)

Highest DPC routine execution time (s): 320,235054
Driver with highest DPC routine execution time: ataport.SYS - ATAPI Driver Extension, Microsoft Corporation

Highest reported total DPC routine time (%): 0,319443
Driver with highest DPC total execution time: iusb3xhc.sys - Intel(R) USB 3.0 eXtensible Host Controller Driver, Intel Corporation

Total time spent in DPCs (%) 1,021576

DPC count (execution time <250 s): 1376926
DPC count (execution time 250-500 s): 0
DPC count (execution time 500-999 s): 7 (0 after this one)

Process with highest pagefault count: compattelrunner.exe

Total number of hard pagefaults 16638
Hard pagefault count of hardest hit process: 15385
Highest hard pagefault resolution time (s): 1164409,333828
Total time spent in hard pagefaults (%): 47,335811
Number of processes hit: 15

If you need more info, I'll gladly put it here.
My System SpecsSystem Spec
26 Jul 2017   #6
fireberd

Windows 10 64 bit
 
 

I assume Latency Mon told you your system would have problems running audio.
Thus, the first step is to clean up the PC and get it to the point Latency Mon is satisfied it can run audio without problems.
My System SpecsSystem Spec
26 Jul 2017   #7
Kinazura

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by fireberd View Post
I assume Latency Mon told you your system would have problems running audio.
Thus, the first step is to clean up the PC and get it to the point Latency Mon is satisfied it can run audio without problems.
Do you have any particular suggestions about what to clean?

Also, if it helps to explain the problem a bit more, it's described much better here: USB PnP device - sound cuts out, makes unplugging sound when not - Microsoft Community

He has pretty much the same problem I have, especially these parts:

"The device manager does not show an exclamation point or question mark next to any sound device and the usb pnp device is listed properly. In the sound options in control panel, there are sound bars next to the usb device that shows that sound is playing, but it isn't actually playing."
(I took a picture of this problem: Imgur: The most awesome images on the Internet)

EDIT: I didn't explain the photo. So, no sound is playing at all(song is off, Opera didn't make any sound, no other sound programs active) and yet the green bars are still there like something is playing.

"It does the same thing in all my usb ports."
"None of the USB devices have exclamation points."
My System SpecsSystem Spec
26 Jul 2017   #8
fireberd

Windows 10 64 bit
 
 

Your PC needs "cleaned" so that Latency Mon does not show any problems. That is the first step.

With a Celeron CPU, that may be a bottleneck and causing some problems. A Celeron CPU is the least desirable. If you want to run multi-tasking, the Ultimate version of Windows and modern apps you need more than a Celeron CPU. You are asking a "Yugo to do the job of a Mercedes".

Start by disabling all unneeded tasks in start up. Only minimum items. No other apps running and then run Latency Mon again to see if it shows better results. Also, with minimum see if USB disconnects.
My System SpecsSystem Spec
Reply

 Sound to my USB headphones gets interrupted




Thread Tools




Similar help and support threads
Thread Forum
Why would on-board speakers sound scratchy but headphones sound OK?
Why would speakers sound scratchy, but headphones and external cabled speakers sound OK? I have a Dell Studio 15 (1555) running windows 7 Professional. 236GB used, 214GB free space Intel P8700 2.53 GHz Processor 64 bit OS 4GB memory The built-in speakers used to sound good but now they are...
Sound & Audio
Can't hear sound through headphones, but it says sound is playing?
It was working and then I hit something in the realtek HD audio manager by accident and it stopped working, I can't figure out how to fix it.
Sound & Audio
No Sound Through Headphones
My laptop suddenly does not recognize my headphones; I only get sound through the speakers. I am unable to set the headphones as a default because this area is greyed out on the playback tab when I go to 'manage audio devices" from the control panel. When I right click on the playback tab, "show...
Sound & Audio
Two headphones different sound for each headphones?
Hello, In my computer i had plugged in two headphones. One is for my brother, and one is for me. So sometimes we used to hear speeches,music etc... at same time. But sometimes i could feel to play football games. And its sounds will be disturbance for him. So any solution for this?
Sound & Audio
No sound from built in speakers, but sound from headphones
I have a Lenovo S10-3 Netbook, running on Win7 starter. It has been running fine unil a few days ago, when the built in speakers no longer play any sound. Works fine with earphones or exernal speakers, but not internal speakers. Drivers are all up to date, and audio/sound settings are all...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App