Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SB Audigy

23 Nov 2009   #1
frogitts

Windows 7
 
 
SB Audigy

I've installed Windows 7 and everything is working great. I've managed to install the drivers for my Creative Sound Blaster Audigy, the device is working properly, and everything seems to be working.

Only one problem: No sound comes out of my speakers. I've already triple-checked, and I know it's not the speakers (tried multiple speakers) or the connection (tried multiple connections), so I know it's a software issue. Any help?


My System SpecsSystem Spec
.
23 Nov 2009   #2
torrentg

7600.20510 x86
 
 

Look on Google for Daniel K. drivers.

Creative is terrible and he made better ones.
My System SpecsSystem Spec
23 Nov 2009   #3
Mitch89

Windows 7
 
 

i had problems with my subwoofer.
Here is what I installed today, restart, Bass redirection on, and hell yeah it works! (so my problem was solved)
I hope for you that your prob will be solved with this!

SB P17X Series Support Pack 2.0 (07/31/2009) - Aud... - Creative Labs
My System SpecsSystem Spec
.

23 Nov 2009   #4
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

frogitts which Audigy do you have? There are two completely different drivers depending on what card it is.
My System SpecsSystem Spec
23 Nov 2009   #5
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by stormy13 View Post
frogitts which Audigy do you have? There are two completely different drivers depending on what card it is.
I was wondering about that myself.
Either this one: SB P17X Series Support Pack 2.0 (07/31/2009) - Aud... - Creative Labs

Or this one: http://forums.creative.com/t5/Sound-...09/td-p/540934

I still like the older made for Vista Daniel K Audigy drivers because they include all the extra's, EQ full console and all that stuff. Of course Creative removed all those useful options in these so called new stripped down Win 7 drivers which do not work nearly as well as the old Vista ones with all the extras.

I think they are the same drivers with all the good stuff removed because both of them work for Windows 7 for me.
My System SpecsSystem Spec
23 Nov 2009   #6
frogitts

Windows 7
 
 

Quote:
frogitts which Audigy do you have? There are two completely different drivers depending on what card it is.
The model number is SB0570, so that's an Audigy SE. I appreciate the pointers to the Daniel K drivers, I had read the sticky but since I had successfully installed Creative's drivers, I wasn't sure that I should install 3rd party drivers.

Interestingly enough, as I was installing the Daniel K drivers, the problem fixed itself (maybe). Here's what I did:

Per the instructions, I restarted in safe mode to delete UDAAPO32.dll, UDAAPO64.dll, and SysWOW64\UDAAPO32.dll. When I entered safe mode, I didn't find any of those drivers. I then allowed the Daniel K drivers to self-extract and tried to run Setup.exe in safe mode. It failed, saying that it couldn't detect my sound card. I figured it was due to safe mode.

I restarted the computer in normal mode, and for the first time since installing Windows 7, I heard the startup sounds! It's worked ever since. It looks like the Daniel K drivers didn't install - I only have the Creative Audio Control Panel, AutoUpdate, and Sound Blaster Properties installed, and my driver is at version 5.12.1.2020.

I hope this information helps someone else out here. Thanks for the quick and thorough response, everyone!
My System SpecsSystem Spec
Reply

 SB Audigy




Thread Tools




Similar help and support threads
Thread Forum
Need EQ software for SB Audigy SE
Hi, I recently hooked-up Logitech Z506 5.1. With MUCH tinkering with the onboard realtek sound I couldn't get sound from the rear speakers, so I purchased an audigy se card from amazon, turned off the onboard sound in the bios, installed the card n drivers and viola...I got the rears working. ...
Sound & Audio
Audigy
I have a Dell XPS 420 with Windows 7 64-bit and an Audigy 2 sound card. All was fine under Windows XP. Under Windows 7 I get random pops/crackles from the speakers every now and again. I don't have to be playing any music, or even touching the computer. It just pops from time to time. There...
Sound & Audio
Audigy SE and Headphones
I've been having an odd problem with my Audigy SE card and my headphones. When I was using on-board sound, there would be a "headphone" device separate from the "speakers" device. With the Audigy SE, there is only a "speakers" device. This is problematic because every program I run thinks I'm...
Sound & Audio
SB Audigy 2 ZS Not Working
The sound card worked fine under XP. Clean install to Win 7 and no audio. Device Manager shows the driver installed - no errors. Status says "this device is working properly". Installed the Win 7 64-bit driver. Driver date Sept. 23, 2009. Driver version 6.0.1.1371. Also tried beta driver and...
Sound & Audio
Need Help Please Audigy
Hey Guys im new to this forum and hopefully can get some help as I have spent the last few days trying to figuer this out and no luck. I have a SB Audigy card and i have resently installed windows 7 and i have installed the drivers for the card from creative and windows update (both seem to be...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App