Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System sounds work and some programs have sound, but others do not

30 Aug 2019   #1
attheedgeof

Windows 7 Home Premium 64bit
 
 
System sounds work and some programs have sound, but others do not

Hello

I would like to ask if anyone has any fixes for this problem. I would've specified in the title which programs do and do not have sound, but I've only really tested four so far.

Recently my speakers broke and last night I installed new ones. This problem has been persistent since then.
Chrome and MusicBee do not have sound (although the mixer shows that they do have sound, the speakers just don't seem to play them specifically for some reason), but Windows Media Player and Audacity do work, as well as system sounds.

Something else which might be of note is that whenever audio is played in Chrome or MusicBee is just opened, any other program which is producing sound stops being audible but still displays as audible in the mixer.

I've tried everything I could find. I've configured the speakers countless times, uninstalled and reinstalled the audio drivers, tried to update them but they were already up to date, disabled and re-enabled speakers, changed exclusivity, and disabled sound effects, to no avail.

Any ideas?

EDIT: I'm suspicious that it might have something to do with audio codecs. I'm not at all savvy with this sort of thing though so I wouldn't know.


My System SpecsSystem Spec
.
30 Aug 2019   #2
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Hello attheedgeof, welcome to the Forum.

I am not entirely familiar with Musicbee, but I shall begin by asking have you ever selected "Analyse volume" in MusicBee? Perhaps selecting "Restore Original Volume" (in MusicBee) may help here.
My System SpecsSystem Spec
30 Aug 2019   #3
attheedgeof

Windows 7 Home Premium 64bit
 
 

Hello, thank you for the reply

I haven't, but I assume that it's unrelated to the problem at hand. MusicBee isn't the only program which is having issues. Google Chrome and, as I have recently discovered, MuseScore 2 remove the sound.
My System SpecsSystem Spec
.

30 Aug 2019   #4
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

For both your new and old speakers, do/did they connect to the computer via jack, USB, TOSLINK, SPDIF or Bluetooth?
My System SpecsSystem Spec
30 Aug 2019   #5
attheedgeof

Windows 7 Home Premium 64bit
 
 

They are connected via jack
My System SpecsSystem Spec
30 Aug 2019   #6
attheedgeof

Windows 7 Home Premium 64bit
 
 

Hello
I found the solution I was looking for on random chance. As it turns out, the audio output on my programs had changed somehow.
Things are okay now. Thank you for your help
My System SpecsSystem Spec
31 Aug 2019   #7
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Glad to hear that you have managed to find a solution. Happy to help.
My System SpecsSystem Spec
.
Reply

 System sounds work and some programs have sound, but others do not




Thread Tools




Similar help and support threads
Thread Forum
1 second sound delay on playing audio or system sounds.
I have recently been having this problem about this sound delay. I recently have replaced my broken AMD Radeon HD7700 to an NVIDIA GeForce GTX 750 TI Superclocked and my soundcard is built into the gpu I think. I know this for BSOD's but here is the diagnostics file if you need it. PS: I...
Sound & Audio
PC sound problems. No system sounds, no audio.
Dell Studio XPS 8100 Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz (4 CPUs), ~2.7GHz 6 GIGs of RAM Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 I here as a last resort before formatting my hard drive. A couple of weeks ago the sound on my PC up and died, for no apparent reason....
Sound & Audio
windows play system sound and all other sounds go quiet
recently reinstalled Windows due to upgrading my PC and now whenever a system sound is played (for example the error sound or exclamation sound) all other sounds, whether they be music files or games or anything else, will have their volume significantly reduced, even for a short time after the...
Sound & Audio
No Sound or System Sounds working
Long story short. Just recently I have not been able to get sound on my computer (All In One Desktop). Neither sound nor system sounds. I believe it started when I started plugging in my earphones into the jack. I can hear sounds (movies, video) and I can also hear the system sounds. When I...
Sound & Audio
No sound from internet, but have system sounds
I'm working on a rebuild of an old Dell. I disabled the onboard sound, and installed several different PCI sound cards. The system is not my main system, but a spare. It's a 32-bit processor, but has Win7 Pro 64 OS. The onboard sound adapter is so old, I could not get 64-bit drivers from Dell,...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:32.
Twitter Facebook