Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to change audio playback device

30 Sep 2019   #1
Bembott

Windows 7 64bit
 
 
Unable to change audio playback device

Hi! First post on this site

I use Virtual Audio Cable (VAC) to stream music via Teamspeak3, however, when using Shadowplay and VAC selected the recorded video does not have sound so I usually switch between VAC and my headset as playback device so the video has sound, including my Teamspeak3 conversation. I recently bought a new GPU, upgraded from my old GTX 660ti to an RTX 2060 and now suddenly i can't change playback device at all. VAC is permanently selected and i can't change. Streaming music works fine but the CS shadowplay videos i save do not have sound, they capture my microphone's audio but not my friends on TS3

Any ideas on how to fix this? I've tried forcefully disabling VAC to no avail, reinstalling headset drivers but nothing has helped. Somehow changing GPU has affected the playback devices

Picture: Imgur: The magic of the Internet
When pressing the "Set Default" button, nothing happens.

Any help is appreciated!


My System SpecsSystem Spec
.
30 Sep 2019   #2
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Welcome to Seven Forums Bembott,

Since the problem only started when changing GPU, had you tried disabling the NVIDIA audio device in Device Manager?
Is the headset connected to the computer when you try to set it as default device? What happens if you choose a different device, can you set that as Default Device?

Other thing to try, is to perform a Clean Boot, and see if the issue still persists.
My System SpecsSystem Spec
30 Sep 2019   #3
Bembott

Windows 7 64bit
 
 

I tried disabling the NVIDIA audio devices, it didnt help. I then tried disabling the VAC via the audio device manager, after restarting the computer the audio playback device had changed to my headset. However, i still can not change the audio playback device. I can press the button, but nothing happens. When i changed GPU i changed from VGA to Display Port, could this be a reason?
My System SpecsSystem Spec
.

30 Sep 2019   #4
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Changing from VGA to Display Port does not normally cause that type of problem. Yet you say that this issue occurred around the time you changed GPU. Is it possible anything else changed around that time, that you might have forgotten about?
My System SpecsSystem Spec
30 Sep 2019   #5
Bembott

Windows 7 64bit
 
 

No, thats it. I changed GPU and monitor cable, nothing else. I installed and updated the GPU drivers thats it.
My System SpecsSystem Spec
30 Sep 2019   #6
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

I would set the computer up to perform a clean boot, as that can reveal problems like this.

Here is tutorial instructions on how to do a clean boot (clean startup): Troubleshoot Application Conflicts by Performing a Clean Startup

Only need to complete Step 1 Parts 1-6 of the tutorial, to see if the problem persists under clean startup conditions.
My System SpecsSystem Spec
01 Oct 2019   #7
Bembott

Windows 7 64bit
 
 

Hello,

After performing a clean boot, the problem still persisted. However, if i disable VAC via device manager the system defaults back to my headset as playback device, i still cant change device though, this is workaround. So i guess its resolved??
My System SpecsSystem Spec
.
01 Oct 2019   #8
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Hi,

That is interesting. You have found a work-around. But I would still be unsatisfied that you cannot select a default audio device following the usual procedure.

There are still other things that you can try. If you are patient enough to go through them, then I would be happy to assist.
1. If the problem had happened recently, then you could try a System Restore , and set the state of the computer back to a time before you installed GPU. That is good, if you have Restore Points going back that far.

2. Another thing you have not already tried, is deleting the VAC device, then seeing if the problem persists.

3. If the above two fail to produce a solution, then you could check the system for file corruption. This is done by performing SFC /SCANNOW from an open Administrators Command Prompt.


If you wish to check your computer for File Corruption, then you can follow step 2 in this tutorial:
SFC /SCANNOW Command - System File Checker
If you want help in understanding the results of SFC /SCANNOW then follow step 2 and step 3 of the same tutorial.
My System SpecsSystem Spec
01 Oct 2019   #9
Bembott

Windows 7 64bit
 
 

Thank you for your suggestions!

1. I bought the GPU a couple of months ago, a "System Restore" is therefore not something i really want to do.

2. Since i don't recall how to install VAC, i installed it years ago, i dont want to uninstall it.

This work-around is enough for me, doesn't bother me that much. Thanks for your help. I will mark this as resolved

Bembott
My System SpecsSystem Spec
Reply

 Unable to change audio playback device




Thread Tools




Similar help and support threads
Thread Forum
Unable to change default audio playback device
I have speakers and a headset set up and previously i was able to switch between which device the audio played out with no problem. However, when i click set default audio device nothing happens. The button is still bold and when i test the device sound still comes out. I have reinstalled their...
Hardware & Devices
HDMI Audio Device No Longer Appears as Playback Device
I was wondering if you could give me some advice on a current computer issue. So, I've got my TV hooked up to my PC as an extra monitor via HDMI. Up until last night I was able to get audio from my PC to be played/heard/whatever through the TV. Earlier in the evening, I saw a bunch of...
Sound & Audio
Audio Playback (Default Device Realtek) Knocks Out SRS Audio Sandbox
Hi, I finally upgraded from Windows XP to Windows 7 and almost went back shortly after finding out I could no longer organize or manually arrange my own personal files and/or folders but luckily I discovered an application called 'Folder Options X' which has re-enabled that feature for me so I'm...
Sound & Audio
Better way to change audio playback device?
Good afternoon, all. Nice to find what looks like a great Windows community. I'm hoping there is a better way to change my audio playback device in Windows 7 (Ultimate, Service Pack 1, 64 bit). As background, I keep my headset plugged in at all times and swap to it when needed, but like to use...
Sound & Audio
How do I change my audio jacks from under one playback device option?
I just got a new computer a few days ago (Acer Aspire X3400) And I have my speakers plugged into the green audio jack in the back and my headphones plugged into the black audio jack in the front but they both come under speakers in my playback devices (as well as rear black port) and if both my...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:54.
Twitter Facebook