Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Installed, Lost All Audio

27 Nov 2009   #1
Zolland

Windows 7 Professional
 
 
Windows 7 Installed, Lost All Audio

Greetings!

I've recently installed Windows 7 Professional on my Dell Latitude D810. After the install, I lost all audio capabilities. My volume controller in the quick launch bar states, "No Audio Output Device is installed." I ran the "Detecting Problems" to try and fix the drivers, but it wasn't able to fix it.

My next step was to check the Dell Drivers and Downloads website and they don't have an audio driver for my computer with Windows 7; however, I've read on other websites that people have had no audio issues with installing Windows 7 on their Latitude D810s. Others have claimed to have had issues, but to have been able to find drivers to fix their audio problems.

Through various websites and downloading, I've tried the following driver executables: D810_A05.exe, R99254.exe, and S1wua01i.exe.

Does anyone else have any other driver recommendations? Or links to other drivers I can at least try?

At this point, anything would be helpful! Much appreciation and thanks in advance....


My System SpecsSystem Spec
.
27 Nov 2009   #2
torrentg

7600.20510 x86
 
 

Install the Vista or XP driver for it using the device manager. Right click it. Update driver software. Browse my computer. Let me pick. Have disk. Browse. Double click on the .inf. Hit ok. Hit next. Reboot if necessary, but shouldn't be.
My System SpecsSystem Spec
27 Nov 2009   #3
fireberd

Windows 10 64 bit
 
 

Just looked at the Dell downloads and Dell does not support Vista or Win 7 on this "older" model PC. Not sure where or if you can get it working since Win 7 requires at a minimum Vista drivers. XP drivers are incompatible as the way some sound functions are handled were changed in Vista. There were major issues posted on the Dell users forum when Vista came out and users wanted to upgrade to Vista but Dell did not support (have drivers) for some models.

Post your question on the Dell users forum, Laptop Audio section of the forum and maybe someone there will have something that will help. DELL COMMUNITY
My System SpecsSystem Spec
.

27 Nov 2009   #4
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by fireberd View Post
XP drivers are incompatible as the way some sound functions are handled were changed in Vista.
Vista itself was completely changed for how audio works. However, I have gotten XP drivers to work for many people across all types of machines. It's worth a shot to try my above method to install XP driver.
My System SpecsSystem Spec
27 Nov 2009   #5
Zolland

Windows 7 Professional
 
 

Quote   Quote: Originally Posted by torrentg View Post
Install the Vista or XP driver for it using the device manager. Right click it. Update driver software. Browse my computer. Let me pick. Have disk. Browse. Double click on the .inf. Hit ok. Hit next. Reboot if necessary, but shouldn't be.
Thanks for the idea! I'll be trying that as soon as I get home from work today. 1 hour and counting...


Quote   Quote: Originally Posted by fireberd View Post
Just looked at the Dell downloads and Dell does not support Vista or Win 7 on this "older" model PC. Not sure where or if you can get it working since Win 7 requires at a minimum Vista drivers. XP drivers are incompatible as the way some sound functions are handled were changed in Vista. There were major issues posted on the Dell users forum when Vista came out and users wanted to upgrade to Vista but Dell did not support (have drivers) for some models.

Post your question on the Dell users forum, Laptop Audio section of the forum and maybe someone there will have something that will help. DELL COMMUNITY

I appreciate the help. I've come across users in other forums who have the same Dell model as me and they've had no problems with sound (or managed to fix it) so I'm sure it can be done somehow.

I'll take your advice about posting in the Dell forums. Thank you.
My System SpecsSystem Spec
27 Nov 2009   #6
torrentg

7600.20510 x86
 
 

Quote   Quote: Originally Posted by Zolland View Post
Thanks for the idea! I'll be trying that as soon as I get home from work today. 1 hour and counting...
If it doesn't work out, right click on it in device manager. Properties. Details tab. Change dropdown to hardware ids. Copy and paste results to a post. I'll make a driver edit so one will install for you.
My System SpecsSystem Spec
27 Nov 2009   #7
Zolland

Windows 7 Professional
 
 

Quote   Quote: Originally Posted by torrentg View Post
Have disk. Browse. Double click on the .inf. Hit ok.
The only .inf on the entire disc is in the folder path R85457 > A02 (I don't know if this information is relevant or not). The .inf itself is called DEL5422K.INF.

When I choose that inf, it gives me the message, "The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for 32-bit systems."

I am running a 32-bit Windows, always have, and it seems to me it should have worked, but didn't.

Quote   Quote: Originally Posted by torrentg View Post
If it doesn't work out, right click on it in device manager. Properties. Details tab. Change dropdown to hardware ids. Copy and paste results to a post. I'll make a driver edit so one will install for you.

I sincerely appreciate your efforts. I certainly don't get this kind of help from Dell. =)
The hardware IDS:
PC\VEN_8086&DEV_266E&SUBSYS_01861028&REV_03
PC\VEN_8086&DEV_266E&SUBSYS_01861028
PC\VEN_8086&DEV_266E&CC_040100
PC\VEN_8086&DEV_266E&cc_0401
Again, thank you. If any other information is needed, please let me know!
My System SpecsSystem Spec
27 Nov 2009   #8
Zolland

Windows 7 Professional
 
 

According to the disc with the drivers, it detected that I require the Sigmatel STAC 975x AC97 WDM Audio Driver.

I'm not sure if this helps or if it's accurate now that I'm running Windows 7 (as this was the suggested driver for Windows XP).

Thanks again.
My System SpecsSystem Spec
27 Nov 2009   #9
torrentg

7600.20510 x86
 
 

That's because Dell wants to sell you a new PC instead.

Extract this download
to a folder.

Right click on the audio device in device manager. Update driver software. Browse my computer. Let me pick. Have disk. Browse. Now navigate to where you extracted to and double click on Alcxau6.inf.

Hit ok. Hit next and let it install. Reboot if necessary but it shouldn't be.

Enjoy - and keep this rar file in a safe place so you don't lose it. It's a one of a kind I just made for you. Make a backup someplace too, like to cd, dvd or usb key.
My System SpecsSystem Spec
27 Nov 2009   #10
Zolland

Windows 7 Professional
 
 

I feel like this might be a stupid question, but where's the download? I don't see a link and I have no private messages...?

Edit: nevermind, it just appeared! Trying now...
My System SpecsSystem Spec
Reply

 Windows 7 Installed, Lost All Audio




Thread Tools




Similar help and support threads
Thread Forum
Lost HD Audio on Assassin HTPC! Was it the recent Windows Update?
Lost HD Audio on Assassin HTPC! Was it the recent Windows Update? All of the sudden I have lost my HD audio output on my Assassin HTPC with ASUS Graphics Card and AMD chipset. I can see audio on the level meter but nothing comes from the speakers. I know if is not the TV or the Onkyo Tuner. Once...
Sound & Audio
Installed Windows 7 and I lost about 350GB hard disk space.
Hi guys, So a few months ago I went into disk management in Windows Xp Pro and marked the HP Recovery partation as active and rebooted the laptop. It then started saying no operating system and so I downloaded Linux with a USB stick and was up and running again. I tried fixing it in there but...
General Discussion
Installed Windows 7 64 Bit Lastnight but lost some of my hard drive
Before the clean install my 250g hard drive was split into C, D and F drive. During the install i told Windows to install 7 onto the C drive. Then i decided to delete the F drive using the delete option in the belief that it would merge to C However once the install had completed im...
Installation & Setup
I lost one of my hard drive when i installed windows 7
I've got almost the same problem, My Partition got lost when i installed windows 7, i can see it though at disk management and it dosen't have a letter, but i cant give it a letter eighter, i get a message saying "The operation failed to complete because the Disk management console view is not...
Hardware & Devices
Lost HDMI Audio in Windows 7 on Laptop
Hello, I have a Sony VAIO VGN-AR390E laptop. It has a SigmaTel High Definition Audio device and an Nvidia 7600 GT. My HDMI audio doesn't work and I have tried for hours today to get it working again. It previously worked just fine in Windows Vista. I am connecting it to an Integra 7.8 receiver...
Sound & Audio
Installed DirectX on Windows 7 and all files been lost
Hi Guys, I apologise if I have placed this in the wrong thread. I've had Windows 7 for three weeks now (as a student, Microsoft gave me access to the MSDN Academic Alliance which had Windows 7 available to download). So far so good overall, however I was going to install a game but it...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App