Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SB X-Fi Xtreme Audio driver problem with windown 7

29 Dec 2009   #1
Smopot75

windows 7 home pro
 
 
SB X-Fi Xtreme Audio driver problem with windown 7

Hey all,

I recently installed windows 7 on my computer and everything worked well accept my sound didn't work.
I put in my Creative SB X-Fi Xtreme Audio driver CD and tried to install them but I ended up with a BLUE SCREEN! about 70% into the installation
I reaserched that many people have almost the same problem with SB X-Fi xtreme audio drivers and windows 7.
Can any one give me any suggestions of what could be the problem.

Thanks

Smopot


My System SpecsSystem Spec
.
29 Dec 2009   #2
DaveHMCFC

Windows 7
 
 

I'm having a very similar problem!

I have the same card, but mp3's play fine. Even some videos in Youtube play ok. It's all other videos on other websites that aren't playing sound for me.

I get a horrible, barely audible noise, or sometimes a scratchy whiney noise.

It's been doing my head in now for two days... help please!!
My System SpecsSystem Spec
29 Dec 2009   #3
fireberd

Windows 10 64 bit
 
 

From posts on the Dell users forum, the SoundBlaster needs Windows 7 drivers. It seems the Vista drivers will not work (and the XP drivers definately will not work). There is a Beta driver on the Creative downloads and many have reported this works in Win 7 and it also corrects a noise problem on some systems with more than 3GB of RAM.
My System SpecsSystem Spec
.

29 Dec 2009   #4
Smopot75

windows 7 home pro
 
 

well i the only problem i have is that the drivers will not get installed every time i do try to install it, IT WONT LET ME! errors and s!@#
My System SpecsSystem Spec
29 Dec 2009   #5
DaveHMCFC

Windows 7
 
 

Right... i've finally managed to sort it!! (you've no idea how good this feels!)

The problem was simple in the end. In the "Audio Control Panel" Creative put in with the driver download, there is a setting where you state what type of speaker set up you have... ie 2.1, 3.1, 5.1 etc. It was set to 7.1, so i changed it to 2.1, and bloody bingo!!

Now i've never seen one of these bloody control panels before so didn't even know it was there until just a minute ago.
My System SpecsSystem Spec
29 Dec 2009   #6
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

The Creative site will see two updates one for the audio consolde launcher while the other is for the driver set. You will likely want the console since that also controls other things like the mixer, EAX effects, equalizer, etc. there.

The software disk that comes along with the card is outdated even for Vista there. It's the same as with many video cards. Which model XtremeAudio are you using there? The PCI or PCIe? For the pci model good for both 32bit and 64bit 7 and Vista 64, Creative Worldwide Support

For the PCIe model good for XP as well as Vista and 7, Creative Worldwide Support

Remember to click the "Show Details" link to the right to read the information on the card you go for there.
My System SpecsSystem Spec
30 Dec 2009   #7
DaveHMCFC

Windows 7
 
 

It's all sorted now cheers.
My System SpecsSystem Spec
30 Dec 2009   #8
Smopot75

windows 7 home pro
 
 

ok well i played around with windows 7 and dled over 10 different drivers for X-Fi Xtreme Audio
AND FINEALY GOT SOUND TO WORK
ALL IT TOOK WAS 10 WINDOWS UPDATES! w00t!
My System SpecsSystem Spec
30 Dec 2009   #9
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

Just in time for the New Year!
My System SpecsSystem Spec
31 Dec 2009   #10
DaveHMCFC

Windows 7
 
 

Quote   Quote: Originally Posted by Smopot75 View Post
ok well i played around with windows 7 and dled over 10 different drivers for X-Fi Xtreme Audio
AND FINEALY GOT SOUND TO WORK
ALL IT TOOK WAS 10 WINDOWS UPDATES! w00t!
Nice one.

Lol.... always check Windows updates first though!

My System SpecsSystem Spec
Reply

 SB X-Fi Xtreme Audio driver problem with windown 7




Thread Tools




Similar help and support threads
Thread Forum
Creative X-fi Xtreme Audio
Bought this card today. Because it said support for vista, I thought it would work in Windows 7 as well. Installed the card and I had immediately sound. Then I went to the creative site to install the drivers because I had only control over the volume. There was no EAX, no bass control, nothing....
Sound & Audio
Creative Sound Blaster X-Fi Xtreme Audio PCI - microphone problem
Hello there. Yesterday i've installed this sound card and everything works fine but no microphone. I can see it in control panel but it doesn't work. Mic is fine as i was using it before. I have Win 7 64bit. If you have any idea what can cause the issue please help, if nothing will work i will...
Sound & Audio
Creative SB x fi xtreme audio delay problem!
Hi, I've recently bought a creative SB x-fi xtreme audio, and no matter what update i do, I keep having delay problems( 0.5 to 1sec) when connecting my guitar through the mic/line entry....... To make things worse, the driver even crashes and all sounds get delayed, i mean even in windows media...
Sound & Audio
X-Fi Xtreme Audio PCI
hello, i posted few days ago request for help in one thread from xfi but no help, so im starting new thread. so : i have SB X-Fi Xtreme Audio PCI OEM. can someone help me step by step what to do to enable the mic ? have following problems : cant find any useful drivers cause during...
Sound & Audio
Creative X-Fi Xtreme Audio Driver Problems
I recently installed Windows 7 on my computer and downloaded the new .90 driver for my "Creative Sound Blaster X-Fi Xtreme Audio" PCI. I can't seem to switch between the recording device "Microphone"(front Jack) and "Line-In"(Back). Also I tried downloading the driver package that includes the...
Sound & Audio
Creative X-Fi Xtreme Audio
Does anyone know where i can download drivers for this card for the Windows 7 RC1? ive tried the Beta drivers off Creative and had no joy, the ones that came out when the "leaked" RC1 was out and im gettin majorly cheesed off.... ive got everythig else set up how i want except the fact ive no sound...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App