Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Sound

18 Mar 2010   #11
solarpower

 
 

thanks guys. could it be that i need to replace my sound card?


My System SpecsSystem Spec
.
19 Mar 2010   #12
solarpower

 
 

could it be that I need an updated sound card?
My System SpecsSystem Spec
19 Mar 2010   #13
nekkidtruth

Windows 7
 
 

I don't think you need a new sound card no. You just need to determine the manufacturer of the board so you can get the latest drivers. We have the model number of your motherboard, but no manufacturer. Sadly, that model number was used across a few different manufacturers. If you can, take a look at the motherboard itself. It should say who manufactured it on there. EliteGroup, BioStar etc. If you can find that, we should be able to direct you to their page to see if there are drivers. A manufacturer will also help with locating other users who are using Windows 7 with that motherboard and possibly a place to get the correct audio drivers
My System SpecsSystem Spec
.

19 Mar 2010   #14
Product FRED

Windows 7 Enterprise 64-bit
 
 

Just install the default Realtek '97 audio drivers. They work on most machines, and I've fixed audio issues on many machines using these (I myself use the HD Audio drivers on my new machine): Download Realtek AC 97 Audio Driver for Windows 7 Driver for Windows 7 - Softpedia
My System SpecsSystem Spec
19 Mar 2010   #15
Aphelion

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by solarpower View Post
could it be that I need an updated sound card?
Could it be a C-Media audio device, does that sound familiar?

Ap
My System SpecsSystem Spec
28 Mar 2010   #16
solarpower

 
 

Quote   Quote: Originally Posted by Product FRED View Post
Just install the default Realtek '97 audio drivers. They work on most machines, and I've fixed audio issues on many machines using these (I myself use the HD Audio drivers on my new machine): Download Realtek AC 97 Audio Driver for Windows 7 Driver for Windows 7 - Softpedia

so if i download this then my sound should work?
My System SpecsSystem Spec
29 Mar 2010   #17
Product FRED

Windows 7 Enterprise 64-bit
 
 

Quote   Quote: Originally Posted by solarpower View Post
Quote   Quote: Originally Posted by Product FRED View Post
Just install the default Realtek '97 audio drivers. They work on most machines, and I've fixed audio issues on many machines using these (I myself use the HD Audio drivers on my new machine): Download Realtek AC 97 Audio Driver for Windows 7 Driver for Windows 7 - Softpedia

so if i download this then my sound should work?
Probably. These work on just about all computers. If not, it's as easy as right click -> Uninstall to get rid of them.
My System SpecsSystem Spec
30 Mar 2010   #18
spddemun

Windows 7 Pro x64 (Upgrade, Clean Install)
 
 

I was willing to give that driver a try, but showed it was no longer available? Anyone have another TRUSTED source?

I have 5 YO laptop w/ATI card, same thing, no sound. Tried updating drivers online and from Dell's site/CDs to no avail.

Odd as sound was fine running RC7 for all those mos., but guess that had something to do with XP Pro being underneath?

Open to other suggestions I might try. Thx!

...forgot to mention this was a clean install of 7 Pro on a new HDD.
My System SpecsSystem Spec
31 Mar 2010   #19
spddemun

Windows 7 Pro x64 (Upgrade, Clean Install)
 
 

First, my apologies for mentioning ATI sound card INSTEAD of graphics card! Late nights can fry my brain, LOL!

I kept trying different drivers from Dell's site and finally found one that worked.

It was a SigmaTel driver for an integrated sound card.

Just wanted to update that I solved my problem.

Thanks!

Am enjoying this Forum and all the info!
My System SpecsSystem Spec
31 Mar 2010   #20
Aphelion

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by Product FRED View Post
Probably. These work on just about all computers. If not, it's as easy as right click -> Uninstall to get rid of them.
The motherboard has to have a Realtek chipset, they don't work with any audio chip.

Ap
My System SpecsSystem Spec
Reply

 No Sound




Thread Tools




Similar help and support threads
Thread Forum
Custom Sound Scheme: Close Window Sound Plays Instead of Chosen Sound
Cheers all, Problem is as stated in the thread; I downloaded, untar'd and set the theme up today. I know it's specifically the "Close Window" sound since it's unique from the others. I'm referring to the following actions in particular (there may be more things I could do to proc it, but I...
Sound & Audio
Distortion sound using onboard realtek sound card on windows 7ultimate
Hello,i recently upgrade my system from xp to windows7,i use the same realtek driver and get distortions!I try severall drivers,disable all enhancements/levels on speakers properties with no result(2.1speakers-),i configure them in stereo mode,i reduce the default format to 44100 16bits(cd...
Sound & Audio
Sound Control panel takes 2 minutes to open; HDMI sound inconsistent
Brand new Windows 7 Home Premium (6 bit) computer. When I click on the Sound control panel item, sometimes it takes 1-2 minutes to open. But that's kind of minor (although I'd like to know how to fix it), because sometimes the HDMI sound to my HDTV works fine, and sometimes it doesn't work at all....
Sound & Audio
narrator no sound - and sound vbs file no sound
I tried this file on my other win 7 and it works fine , but I have no sound with this file . and narrator has no sound also .. system sounds and mp3 's / movies sound good ... Ideas . thanks
Sound & Audio
Missing Sound Video & Game Controller in Device Manager, no sound
Hi Its bit complicated.:D I have 5 year old Compaq Pressario V3611AU notebook with AMD Atholon X2 TK-55 processor. Was using Windows XP and everything working fine. Recently I upgraded RAM to 2GB & processor was changed to AMD Turion(tm) X2 TL-60 2.00Ghz. I installed windows 7 and everything...
Sound & Audio
System Event - Changing sound makes a sound, how to mute it?
Did my searching and couldn't find this one... When I modify the speaker volume using the "Volume Mixer" icon, it generates a sound. When I adjust using the "Speakers/Headphones" icon, it does not make a sound. I would like to mute the Windows 7 sound that happens when I adjust the sound,...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App