Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Soundblaster Live 24 External ticking (and Traktor pro)

24 Mar 2010   #1
karelo

Windows 7 Ultimate x64
 
 
Soundblaster Live 24 External ticking (and Traktor pro)

Hy!
I have the Creative Soundblaster live 24 external audio card.
So my first problem is that the sound starts ticking randomly from time to time. Primarily if 2 programs are running at the same time, e.g. , firefox with youtube playing and winamp or bsplayer etc. This stops when i close one of them or restart the program. This is not a huge problem but just extremely annoying.
The second problem... well more of a question is that could anyone tell me if XP is louder by audio level than Windows 7? I'm using Traktor DJ Pro 1.2.4 (the latest version) and an external mixer. Seems that i have to gain the levels by far more than when i used XP and the same setup. Even the setings are the same in Traktor and i did not miss disableing the master limit etc. Also looks like that with Win7, Traktor uses more audio latency than in XP. It freezes when i load a track to a deck and when it's analyzing the audio file.
I know that Traktor Pro has nothing to do with the sevenforum, but maybe someone has the same problem and can help me out.
Well here are my specs:
Fresh OS install (thought this would help but it didn't)
OS Windos 7 Ultimate 32 bit, build 7600 updated to newest drivers
CPU P4 3GHz (XP setup had P4 2,4GHz with different mobo)
2.5GB of RAM (XP setup had 1GB of RAM)
Creative SB live24! external soundcard updated to newest drivers from homepage v1.01.0099 (full not beta)
Video 6600GT updated to newest drivers from homepage
Power options are set to "High performance"

I think that everybody will agree that going back to XP would not be a solution

EDIT: Should i try following any Win7 tuning tutorial to get it running better? What is this ACPI? Can this be the couse of my troubles? Were can i check if it's installed or not?


My System SpecsSystem Spec
.
25 Mar 2010   #2
electrotune1200

Windows 8 Pro
 
 

Have you tried increasing the sampling rate from 44,100Hz to 96,000Hz in your sound card settings?

I do find that XP was definitely louder. In the sound mixer settings XP had the Db boost option, which I would love to see included again in Windows Seven's mixer settings.
My System SpecsSystem Spec
25 Mar 2010   #3
Aphelion

Windows 7 Home Premium
 
 

Agreed, XP's audio system definitely produced more gain.
From my limited time with Vista, it also produced more gain than Win-7.

Ap
My System SpecsSystem Spec
.

25 Mar 2010   #4
karelo

Windows 7 Ultimate x64
 
 

Tryed 96, 000Hz but then it crackled couse of the latency on every beat with Traktor. Tryed to change it but nothing helped.
I installed XP pro SP3 32 bit on my friends empty harddrive and using the same PC.
The difference is like night and day. I can abuse Traktor in any way i like. Loading tracks like crazy and even with reloading to the same deck nothing happens. I simply can not bring it to freezing.
Now should i consider on dual booting?! I don't have any clue on how that works. Quess i will be doing re search on that now. Maybe someone will drop a link here?
What about that ticking thing? Anyone having similar problems?
My System SpecsSystem Spec
25 Mar 2010   #5
electrotune1200

Windows 8 Pro
 
 

You can look into dual booting if that works for you.

I've had problems with on-board sound since Windows Vista. My solution to the problem was getting an external sound card. But I know what you mean, there is a problem with audio management with Windows at the moment. They seriously need to address it.
My System SpecsSystem Spec
25 Mar 2010   #6
electrotune1200

Windows 8 Pro
 
 

This should help you with dual booting.

Dual Boot Installation with Windows 7 and XP[2]=General%20Tips
My System SpecsSystem Spec
25 Mar 2010   #7
karelo

Windows 7 Ultimate x64
 
 

Atleast i don't feel alone in this boat. Thanks guys!
What about that ticking thing? Anyone having similar problems?
The funny thing is that i allready have an external audio card I realize though that the SB live24 is an old card and it had troubles with ASIO support from the first day on etc but it's a good card.
Oh and XPs audio system DOES produce more audio gain! About 2/3 times more if not even 2 times more. Just acordingly on how much gain i had to add on my external mixer to get the leds to 0dB.
My System SpecsSystem Spec
26 Mar 2010   #8
karelo

Windows 7 Ultimate x64
 
 

For those who seek help with the same exact problem and will end up at this page. I found out that it was the SBs win7 driver what was causing the problem. I have had troubles with the soundblaster soundcard since day one.
Shame on you Creative! I will never look at a Creative product ever again.
My System SpecsSystem Spec
27 Mar 2010   #9
JazzSus

Windows 7 x64
 
 

Quote   Quote: Originally Posted by karelo View Post
For those who seek help with the same exact problem and will end up at this page. I found out that it was the SBs win7 driver what was causing the problem. I have had troubles with the soundblaster soundcard since day one.
Shame on you Creative! I will never look at a Creative product ever again.
Karelo for sure Creative have to make up their mind and do fast improovement of their W7 drivers. Not just for their brand new products so they have to do for older too. Otherwise they will loosing the market for sure. I'm hoby PC musician and since W7 came out I try hard to get all necessary drivers....and knowing manufacturer as Creative, M Audio, E-MU and many others they are way too slow in driver development!!...it's tough to set it right. The only XFi Fatalty Champion works for me right now in W7. I have also SB Live MP3+ which I care have instald in W7 on other PC but hope they will improove drivers otherwise I'll loose a lot of my compositions which are using SF2 features [BTW there were Creative best feature...non other pro or semi-pro sound card use these features!! as I know]
I might still stick with XPro on other puter just to keep my setup working
My System SpecsSystem Spec
01 Apr 2010   #10
karelo

Windows 7 Ultimate x64
 
 

Exactly! Win7 was released over a year ago now and they still haven't managed to make proper drivers. I consider the one out now as a beta version not as a full working driver. I know lots of Creative sound card users who have turned theyr back on it for now.
The SB live 24 external is a proper semi pro card by itself and now in win7 it finally had full ASIO4ALL support. Unfortunately now it can't communicate to win7 as it should.
I also was hoping that they would make the remote function with the win7 drivers but that was another disappointment! Still only the volume up/down and mute works.
I would be really happy if they would make the driver fully functional for bigger latency hogging softwares like Traktor Pro and Fruity Loops etc and not just for small players like Winamp BSplayer etc. Ofcourse full remote support for global hotkeys! We should contact creative and let them know about it but i'm afraid they won't mess around with old cards anymore.
What a tool.
My System SpecsSystem Spec
Reply

 Soundblaster Live 24 External ticking (and Traktor pro)




Thread Tools




Similar help and support threads
Thread Forum
Soundblaster Live! 5.1 Win7 Compatibility
I know that Creative has stopped supporting the SB Live! 5.1 way back in the day, but I was hoping anyone would know of a way to force it to function in some way. I've heard a lot about this Daniel_K guy, who's been making drivers for old Creative cards, but I can't really find anything for my...
Sound & Audio
Soundblaster Live SB0200 Drivers Win 7 x86
I wasn't able to get the onboard drivers to install so that I could get audio to the 1/8" jack, my Intel 945 PVS MOBO, so I picked up a SoundBlaster Live SB0200 board at a thrift shop and now I've been having trouble finding drivers on Creative Worldwide Support site or elsewhere. When I click on...
Sound & Audio
I have a SoundBlaster Live! and a GeForce GTX 550 Ti
At the moment I use the SoundBlaster for sound. Would using the graphics card instead be better or worse?
Sound & Audio
Creative Soundblaster Live 5.1
Good Afternoon, I've recently installed the above card (SB Live 5.1) on my system which is running Win 7 ultimate 32-bit. Prior to installation, I checked with the Microsoft Windows7 compatability website and it states completely compatable. Unfortunately, I get the red "x" in the taskbar...
Sound & Audio
SoundBlaster Live! Value, please!
Hi dears Could anyone help me to find the correct driver for my soundcard?, it is a Creative SB Live! Value (CT4670). It was working fine on WinXP, but since I changed the OS to W7 its sounds is terrible. I have tried to install many of those mod drivers of Daniel_K, but everytime the...
Sound & Audio
Soundblaster Live! 5.1 on windows 7
Hi, ive just upgraded my system from xp straight to windows 7 ultimate 64-bit... and installed all the drivers needed for my motherboard... but i had a creative soundblaster live! 5.1 audio card which windows 7 is not detecting on my system (uknown device, multimedia audio controller). i have...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App