Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Why Can't I Get 5.1 Sound On My Win 7 System! HELP!

05 Apr 2010   #11
Lee Dizzle

Windows 7 Home Premium
 
 

Yup it seems we have the exact same problem Simon and it's probably one of the most annoying problems I've ever encountered with my comp! Like you I've near enough tried everything and every time had no luck. I even went to the lengths of contacting Microsoft (by email) and explaining my problem in great detail, In which I got a generic pass the buck style answer which (to me anyway) pretty much came across like this "it's not our problem, we can't help, contact your hardware manufacturer" which I found rude considering how much I've spent on Micrsoft software/products over the years. I've now even sent a few emails to Realtek and I'm waiting to hear if they reply (will let you and everyone know what they say if they do)

My friend also tried his soundcard on my system (running Win 7) just before I upgraded the spec to the spec I have now (which I done because of the problem!) And we got the same headache, I cant remember which soundcard it was to be honest with you but I do remember it never solved the problem, although that was a while ago and like you I think I've seen people (recently) who have had success when buying new sound cards to put in their system.

So I think I will try this option shortly and let you know how it goes asap.

Thanks Simon


My System SpecsSystem Spec
.
05 Apr 2010   #12
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

down load the vista or xp drivers from here DFI LANParty:The Best OC Platform! Overclock, Motherboard, Intel, AMD and install them in compatibility mode Compatibility Mode let us know if this worked for you
My System SpecsSystem Spec
05 Apr 2010   #13
Lee Dizzle

Windows 7 Home Premium
 
 

thanks pebbly I've downloaded and installed the DFI drivers for my motherboard but will try them in xp compatibilty mode too
My System SpecsSystem Spec
.

05 Apr 2010   #14
CommonTater

XP Pro SP3 X86 / Win7 Pro X86
 
 

Quote   Quote: Originally Posted by Lee Dizzle View Post
thanks pebbly I've downloaded and installed the DFI drivers for my motherboard but will try them in xp compatibilty mode too
Guys... I don't know how much help this might be, but...

Have you tried installing the AC3 filter?

AC3Filter | AC3Filter

I'm using this on my HTPC (XP based) and it's a real blessing... The optical cable works, I get both fake and real 5.1 and can even limit dynamic range to prevent movies from blasting my neighbors....

No promises... but, if it tests out in the demo applet, it might be worth a try....
My System SpecsSystem Spec
05 Apr 2010   #15
The Cube

windows 7 home premium
 
 

For myself, to get 5.1 or 7.1 surround sound I just hook up to the external system through my HDMI port and the system automatically changes settings, just like when you put a cable in the headphone jack on a Notebook and it mutes the built in speakers. sometime it does not however work when I am viewing a movie or video that I KNOW has surround sound: so I am guessing the problem branches from 7. I also occasionally have the problem with not recognizing the connection of sub-woofers. But when running applications that externally monitor devices and include advanced audio options it works fine, supporting the judgment of failed Win 7 audio. Just the same, I have never encountered a problem that appears as catastrophic as yours.
My System SpecsSystem Spec
06 Apr 2010   #16
Lee Dizzle

Windows 7 Home Premium
 
 

Hi CommonTater I've tried the AC3 filter and no joy either but is was worth trying though, thanks.

Hi The Cube I've tried with HDMI also and the same problem occurs too, so I think I may just have to buy a sound card and try and see if I have any luck that way that way?
My System SpecsSystem Spec
06 Apr 2010   #17
CommonTater

XP Pro SP3 X86 / Win7 Pro X86
 
 

Quote   Quote: Originally Posted by Lee Dizzle View Post
Hi CommonTater I've tried the AC3 filter and no joy either but is was worth trying though, thanks.
Hmmm... too bad. That's a real handy piece of software. The only after-comment on that is that straight out of the box, it does absolutely nothing. The presets are for "passthrough" mode, used to decode AC3 from AVI files. You do have to manually configure it before it does it's thing...

Anyway, I hope you get this fixed.
My System SpecsSystem Spec
06 Apr 2010   #18
philhu

win 7 enterprise and Ultimate
 
 

I never got my realtek embedded sound to do ANY reliable sound.

I ended up disabling it and using a usb creative Audigy NX box. It worked fine.

I just completely switched to a new system, and the onboard 7.1 sound is fine (Not realtek!)
My System SpecsSystem Spec
07 Apr 2010   #19
X796

Win7
 
 

Problem:
HI I have the same problem but in XP when I was watching movie or listening to music, it was playing thru all the speakers (5.1)not true 5.1 . But in Win 7 only the front 2 speakers (Stereo 2.1).

It is Right that in Win 7 it plays thru the front speakers (Stereo 2.1) WHY Because mp3`s are only Stereo 2.1 and about all 700MB movies.

True 5.1 is for 5 channels Front 2 ,Rear 2 and Front Center . The Movie or Music HAS to HAVE IT

and to enable the matrix is BS it sounds like CRAP (ticking the room option)


Solution:

On Win7 I Listen to music and watch movies on Media player Classic. WHY because it Can enable the channels I need, this is the only player that I could fine that can do this.

Here is what to do in it to Get sound thru all 5 speakers NOT TRUE 5.1 Sound also works with more speakers All the same sound thru all the speakers and doesn`t sound like Crap



a 5.1 Movie that has 5.1 will win 7 automatically get it This is The only player that Plays SPDIF (Optical) The right way. But you have to Check the SPDIF in your Sound Manager and in the player (This is not for music)





Because Win 7 don`t do it Self when trying to play a Dolby Surround 5.1 DTS .....

This is the only way that I can get all my speakers to play if I am listening to music or watching a 2.1 stereo movie

All this is working on my Z-5450 speakers and SupremeFX II sound card but is will work with all. I be leave that buying a sound card is not going to fix this the right way.

Hope this helps you guys ....
My System SpecsSystem Spec
07 Apr 2010   #20
Lee Dizzle

Windows 7 Home Premium
 
 

Thanks for the information Philhu and X796, was trying different stuff with the setup yesterday, seems to me like Realtek has no chance of working and those who made Win 7 didn't focus at all on sound capabilities or just didn't think people was really into sound or something because its just terrible.

I got 7.1 to play (remember my sound goes straight to my amp from the comp) with HDMI BUT only when I played a blue ray movie, also got sound to play with music BUT with no subwoofer at all, I can only guess windows 7 is not friendly to programs or drivers which try to make it play with 5.1 or more (well like X796 said sound through all 5 speakers NOT TRUE 5.1 but All the same sound through all the speakers and doesn`t sound like crap, like XP did and sounded great wether true 5.1 or otherwise)

I'm seriousley considering going back to XP and asking for some sort of compensation for windows 7 because for a globally dominant company it just shouldn't be this much trouble for them to get right in the first place or at least not make you have to fork out more money on buying stuff to fix problems (sound cards etc) it shouldn't have in the first place, surely I'm not on my own with these views here?? And then to top it off you get next to no help from microsoft themselves when you contact them.

Well sorry for the rant guys!! LOL

But I'm sure you can understand I'm slightly upset with this long headache I've had for the duration of this saga.

Thanks again for everybody's input and im going to try what you done X796, I'll let you know how it goes

peace
My System SpecsSystem Spec
Reply

 Why Can't I Get 5.1 Sound On My Win 7 System! HELP!




Thread Tools




Similar help and support threads
Thread Forum
Only sound from system, No oher software seem to trigger the sound
Hello again A new problem with my PC Win 7 64 pro No sound is heard from software like Excel. Sound issued by the system will be played I did open the sound Mixer and a click on the system icon will play a sound. A click on the 3 others will have no sound play.
Sound & Audio
changed sound card - now no system sound??
Greetings. Used onboard sound until today where I remounted my Auzentech X-Fi Forte. I have uninstalled the realtek sounddrivers and deactivated the onboard sound in BIOS. Everything is playing with the default analog speakers (5.1 setup) through the Forte, except systemsound (logon sound,...
Sound & Audio
Stuttering sound + Sound mixer "System Settings" flashing in and out
This is a weird issue I'm having. I did a restart and when I came back BF3 wasnt playing any sounds, which is weird because it was just working. I went to make sure it wasnt muted in the mixer, and I see the weirdest thing. The application "System Sound" is disapearing in and out very...
Sound & Audio
Audiophile 2.1 sound system for Xonar D2X sound card.
I have given up on getting a good 5.1 or 7.1 sound system for my pc since it requires a receiver and all. What I am looking for right now is a 2.1 sound system that can be directly plugged in to my Asus Xonar D2X sound card. The system should have a really decent subwoofer with tight and deep...
Sound & Audio
System Event - Changing sound makes a sound, how to mute it?
Did my searching and couldn't find this one... When I modify the speaker volume using the "Volume Mixer" icon, it generates a sound. When I adjust using the "Speakers/Headphones" icon, it does not make a sound. I would like to mute the Windows 7 sound that happens when I adjust the sound,...
Sound & Audio
No digital sound out of external sound system
I have a GA-EX58-UD3R Rev 1.6 mobo in a PC connected to a Samsung PS63C7000 3D TV via HDMI and by Stereo Analogue, Coax and Optical to a Yamaha RX-V567 receiver/amplifier. The mobo runs the Realtek audio system supplied with the mobo, which has 5.1 Analogue outputs, coax and Optical out. On...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App