Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: High Definition audio only stereo after Win 7 install

17 Apr 2010   #1
ickata

Windows 7 Professional
 
 
High Definition audio only stereo after Win 7 install

Hi All,


This forum is my last hope for solving my problem.


I have HP Pavilion dv7 1270us , which came with Windows Vista x64. I've managed to watch DVD Movies and Blu-ray discs through the HDMI-output, having multichannel audio as well (5.1)


I thought that it was time for a Windows upgrade. 2 weeks ago I've purchased a copy of Windows 7 Professional, formatted my hard drive and installed my new Windows. After that I browsed HP's driver page to download my missing drivers.
Everything looked good, except the fact that I cannot output multichannel audio to my amplifier now.

Firstly, I thought that this could be a codec issue, but it wasn't. This is what I've found in my Sound settings - Windows says that my High Definition audio supports only 2 channels:





As you can see from the screen the HD driver is from Microsoft, which is strange (I think it should be signed by HP?). Somewhere I read that Windows 7 supports only 2 channels for HDMI by default, because the driver is a generic one. When trying to update the driver, the system says that it is the best one.





I've been searching Google for days for a solution. I found that a lot of people are having similar problems (though on different configurations) but I never read a proper solution to this problem.


Please help!


My System SpecsSystem Spec
.
17 Apr 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by ickata View Post
Hi All,


This forum is my last hope for solving my problem.


I have HP Pavilion dv7 1270us , which came with Windows Vista x64. I've managed to watch DVD Movies and Blu-ray discs through the HDMI-output, having multichannel audio as well (5.1)


I thought that it was time for a Windows upgrade. 2 weeks ago I've purchased a copy of Windows 7 Professional, formatted my hard drive and installed my new Windows. After that I browsed HP's driver page to download my missing drivers.
Everything looked good, except the fact that I cannot output multichannel audio to my amplifier now.

Firstly, I thought that this could be a codec issue, but it wasn't. This is what I've found in my Sound settings - Windows says that my High Definition audio supports only 2 channels:





As you can see from the screen the HD driver is from Microsoft, which is strange (I think it should be signed by HP?). Somewhere I read that Windows 7 supports only 2 channels for HDMI by default, because the driver is a generic one. When trying to update the driver, the system says that it is the best one.





I've been searching Google for days for a solution. I found that a lot of people are having similar problems (though on different configurations) but I never read a proper solution to this problem.


Please help!
Whatever driver worked in vista, will work in win 7 in installed in "compatibility mode"

Let us know if you need help

Ken
\
My System SpecsSystem Spec
17 Apr 2010   #3
not so gray matter

W7 Ult. x64 | OS X
 
 

Go to the HP website and download their latest driver:
First try this set: Win7 x64 Audio Drivers
IDT High-Definition Audio CODEC Driver HP Pavilion dv7-1270us Entertainment Notebook PC - HP Customer Care (United States - English)

If that doesn't work, use this set in compatibility mode for Vista x64:
IDT High-Definition Audio CODEC Driver HP Pavilion dv7-1270us Entertainment Notebook PC - HP Customer Care (United States - English)

You may need to uninstall your old microsoft drivers before you install either of those. To do that, go to that properties page where you tried to update your drivers before and uninstall the driver.
My System SpecsSystem Spec
.

18 Apr 2010   #4
ickata

Windows 7 Professional
 
 

Hi All,

I tried both with latest sound driver for Win 7 and Vista, but got no success.

However, I reinstalled the nVidia graphics driver and guess what - it did the trick! During the installation process I saw that both nVidia Graphic Driver and nVidia HD Audio will be installed. After that I restarted, set some settings and my 5.1 works like a charm now!
My System SpecsSystem Spec
Reply

 High Definition audio only stereo after Win 7 install




Thread Tools




Similar help and support threads
Thread Forum
Microsoft High Definition Driver vs Realtek high definition audio driv
Microsoft High Definition Driver vs Realtek high definition audio driver?
Drivers
realtek high definition audio and high definition audio device problem
Hi everyone, I would be very grateful for some help please! My laptop recently installed a BIOS update - I don't know what this was but since it happened I have been having sound problems with my laptop. After the update I had no sound. I read around and found how to get the sound back on - I...
Sound & Audio
Stereo Mix Via High Definition not picking up sound.
Using an analog stereo connection cable, a main USB connector and (Headphone) via high definition as default playback device, I want to use Stereo mix (Which is enabled and supposedly working, not muted and up to date) to play sounds in Skype calls. I checked out the recording devices and the green...
Sound & Audio
conexant high definition audio and intel(R) High Definition Audio HDMI
i have a gateway computer and i want to record some audio from my computer. i looked online how to do this and stereo mixer kept coming up. i looked in my sound and show disabled and disconnected devices are both selected and i do not see stereo mixer in the list of recording devices. can someone...
Sound & Audio
Clean install - High Definition Audio Device listed twice!?
I am running a clean install of Windows 7 Pro x64 SP1 on a Asus P8Z68 Deluxe. When I first installed Windows, first thing I did was install Intel's chipset drivers and IRST drivers, then all other mobo drivers. Checked Device Manager and everything is detected. Here's where it gets weird, I had...
Drivers
CANT INSTALL High Definition Audio Codecs
No AUDIO OUTPUT DEVICE IS INSTALLED, this is the message l got on sound icone since l installed windows 7 l have downloaded it several time the latest one it shows on control panel but not on device manager, l guess this is not really installed but l keep installing it and restat the laptop...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App