Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No audio through HDMI - W7 RC x64

02 May 2009   #1
churin

W7 Ult x64 and W8 Pro x64
 
 
No audio through HDMI - W7 RC x64

I noticed that there was no audio through the HDMI interface. Is there anyone who saw it working?


My System SpecsSystem Spec
.
19 May 2009   #2
DaleyKD

Windows 7 RC (Build 7100) 64-bit
 
 

Mine seems to work just fine.
My System SpecsSystem Spec
24 May 2009   #3
Blue05R1

Windows 7 RC
 
 

Mine works fine make sure you have the HDMI audio driver as well as the standard audio driver installed and updated to latest version from vendors site.
My System SpecsSystem Spec
.

24 May 2009   #4
7Heaven

Windows 7 7260 X86
 
 

Works fine for me.

Make sure if you have two audio devices the HDMI is selected as default.
My System SpecsSystem Spec
24 May 2009   #5
churin

W7 Ult x64 and W8 Pro x64
 
 

Thanks everyone responding.
The machine(laptop) came with Vista x64 preinstalled which does not have this problem. I added W7 RC to make a dual-boot system. I used a driver DVD which came with the machine to install drivers after installing W7. The device manager is not showing anything wrong. Anyway the two responses indicating no audio problem with HDMI appear to indicate that W7 is not the culprit.
My System SpecsSystem Spec
25 May 2009   #6
churin

W7 Ult x64 and W8 Pro x64
 
 

Quote   Quote: Originally Posted by nohelmets View Post
You probably already checked this, but if not: Try right-clicking the volume icon and open Playback Devices. Then, try setting the HDMI as the default output and see if that changes anything.
No, I have not tried that. I will be able to get to the machine by this week end and will post back.
My System SpecsSystem Spec
26 May 2009   #7
Deemo

Multi
 
 

I am just guessing that you will have the same issue that I have had.

The HDMI shows up as a greyed out option but when you right click it the option to set as default is greyed out.

Are you using Realtek audio?

For those who had success, are you using Realtek as well?

I have seen several posts and no solutions as yet for people having issues.
My System SpecsSystem Spec
26 May 2009   #8
churin

W7 Ult x64 and W8 Pro x64
 
 

Quote   Quote: Originally Posted by Deemo View Post
Are you using Realtek audio?
Yes, it's Realtek audio. I will post back when I get access to the machine in a couple of days.
My System SpecsSystem Spec
27 May 2009   #9
Deemo

Multi
 
 

OK....I have fixed my issue by reading the manual for my mobo.

I am using a Gigabyte 780g chipset with on board video and audio only.

If you can see the HDMI in the playback devices but it is greyed out when you try to enable it....try this:

(In mine it was as follows so yours may be different)

1.Enter your BIOS (Delete in my case)

2. Go to Advanced BIOS Features

3. Go to Onboard VGA Output Connect and change D-SUB/DVI (the default in this case) to D-SUB/HDMI

4. Save and Exit.

When you reboot the HDMI is no longer greyed out and you can set it as default.

I hope that works in your case.

I was blaming Realtek.

I haven't checked on 5.1....that is next.

BTW. If anyone knows how to output audio through HDMI and the rear audio output at the same time I would appreciate it as I am hookedup to a whole house audio amp and I have to keep setting the defaul udio playback device.

Thanks
My System SpecsSystem Spec
01 Nov 2009   #10
Byoung1447

Windows 7 ultimate 64-bit
 
 

Ok, after trying everything I could think of with my Dell I finally got sound through the hdmi. Here's how. When I right click the
desktop and then the category display options and then output to and chose digital television the video goes through the hdmi just fine no sound though. No choice for hdmi in sound playback devices. However, if I go
to display options output to and choose extender and then digitial tv + notebook the video is now on my tv and notebook. And now in sound playback devices I have the option for hdmi audio device and I set as default and it works flawlessly. My new question is how can I get the picture and sound to come from the tv while the notebook screen is dark. It's not a big deal as is, but would be nice. Hope this helps somebody out there.
My System SpecsSystem Spec
Reply

 No audio through HDMI - W7 RC x64




Thread Tools




Similar help and support threads
Thread Forum
Realtek HDMI Output ATI HDMI Audio -Not Plugged In-
I'm trying to hook up my TV with my computer, and for the most part it's working. The video goes through and I get how to control it and everything. The only thing not working is the sound. I'm using an HDMI to HDMI cable, and like I said the video is fine. Also, when the cable is plugged into...
Sound & Audio
No HDMI audio after running Win 7 audio trouble shooter
I have an Acer Aspire Laptop 57362-4790 running Win 7 with all the latest updates. Audio is an Intel(R) High Definition Audio HDMI, and Realteck HDMI. Because I had no headphone output with the computer connected to my TV via the HDMI out I ran the Windows audio trouble shooter. I got a...
Sound & Audio
No Audio, HDMI (unplugged), No Audio device listed
Hi, I just got a new (cascaded) computer with seemingly no standard audio. The audio icon is a speaker with and X through it and the only audio device that populates the Playback Devices list is the HDMI digital audio. I have audio on the motherboard (think I can find it?? nope) and...
Sound & Audio
HDMI audio problem when connecting LCD TV to PC via HDMI
hi all, I have my media center PC connected to a Sansung LCD TV through an HDMI cable. Everything works fine; the PC detects TV and both audio and video travel through the HDMI cable from PC to TV The problem happens when I turn the TV OFF and ON. In this case, the video is back but not the...
Sound & Audio
No audio from rear jack & no hdmi audio
hi guys pretty new here so take it easy plz (lol) i have 2 problems regarding audio. 1. when i upgraded my pc i added a okish motherboard but i wanted sound from my front panel so i took the jumper cap off the prongs for audio but now i have added some desktop speakers and want to plug them...
Graphic Cards
Windows 7 - HDMI out no audio - Intel HDMI audio
Hey everyone, I recently upgraded to Windows 7 (Build 7100) from Vista (32 bit) and am having trouble getting audio from my HDMI out port. I am using the Mobile Intel 965 Express Chipset and have upgraded to the latest available driver but still no luck. I have attached a screen shot of my...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App