Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative X-Fi Xtreme Audio

08 May 2009   #11
Delta1Zulu

Windows 7 RC1 Build 7100
 
 

ive bitten the bullet and installed the x64 version of the RC1.... and all works perfectly now... i find it kinds odd the x64 drivers work for me when the x86 drivers didnt.....


My System SpecsSystem Spec
.
11 May 2009   #12
hekermeker

Windows 7 x64
 
 
try this

My System SpecsSystem Spec
13 May 2009   #13
Richard B

Win 7
 
 

I downloaded these drivers for my SoundBlaster X-Fi on Win 7 RC1... it said no compatible device was detected... Am I missing something here??
My System SpecsSystem Spec
.

13 May 2009   #14
hekermeker

Windows 7 x64
 
 
are the drivers compatible?

What kind of Xfi You have?Read that forum and search for your card to be supported.
My System SpecsSystem Spec
20 Aug 2009   #15
costa69

windows 7
 
 

Many thanks for the PAX PCI XFI Windows 7 V1.20.7z,they did the job,but there is a problem.I have 3 speakers,and all sounds come from all of them at the same time.There doesn't seem to be a different chanel for left,right and centre speakers.Any ideas?
My System SpecsSystem Spec
20 Aug 2009   #16
YSAliens

Vista x64, Win 7 x64
 
 

SB P17X Series Support Pack 2.0 (07/31/2009) - Aud... - Creative Labs

These are based on the LATEST official drivers. They have ALL features working under Windows 7. Enjoy.
My System SpecsSystem Spec
21 Aug 2009   #17
Azrafael

Windows 7 RC x86 Ultimate
 
 

For those using PCI-E ver of X-Fi Extreme Audio for 5.1
Creative Worldwide Support > PCI Express X-Fi Xtreme Audio

Filename: XFXA_PCDRV_LB_1_04_0000.exe


Current issue I'm having is not having the mic detected as a mic as it's being detected as a Line-In. I'll try to figure this out (and yes its in the correct jack)
My System SpecsSystem Spec
21 Aug 2009   #18
costa69

windows 7
 
 

Many thanks,will try them later on today,hope that will fix the problem.
My System SpecsSystem Spec
21 Aug 2009   #19
miky

Windows 7 Ultimate x64 SP1
 
 

I have SB x-fi extreme gamer(PCI) and for w7 64b i use SB X-Fi Series Support Pack 2.0 but XP version,its realy amazing taht vista/w7 drivers dont work. I can install only XP version but works good and in this drivers is THX enabled.

http://forums.creative.com/t5/Sound-...009/m-p/527485
My System SpecsSystem Spec
21 Aug 2009   #20
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by miky View Post
I have SB x-fi extreme gamer(PCI) and for w7 64b i use SB X-Fi Series Support Pack 2.0 but XP version,its realy amazing taht vista/w7 drivers dont work. I can install only XP version but works good and in this drivers is THX enabled.

SB X-Fi Series Support Pack 2.0 (05/15/2009) - Creative Labs
And won't work with the Xtreme Audio, before anyone in this thread decides to try this driver.
My System SpecsSystem Spec
Reply

 Creative X-Fi Xtreme Audio




Thread Tools




Similar help and support threads
Thread Forum
Creative X-Fi Xtreme Audio plays no sound
Hi, I installed my soundcard, everything works perfect. I installed drivers and i get no trouble at device manager. After I plug my headphones in and try to play music, i get no sound. At the sound options in windows i see the soundcard and it looks like it works, because the green bar goes up...
Sound & Audio
Creative X-fi Xtreme Audio
Bought this card today. Because it said support for vista, I thought it would work in Windows 7 as well. Installed the card and I had immediately sound. Then I went to the creative site to install the drivers because I had only control over the volume. There was no EAX, no bass control, nothing....
Sound & Audio
Sound Blaster X-Fi Xtreme Audio / Creative.com
Ok, so I read the stickied topic about the X-Fi Xtreme Audio driver, as I think this maybe a part of my computers less-than stable condition after recent Fresh Installs of Windows 7 Home Premium 64bit. I got 2 things... 1) When I install Drivers off my CD, I get a SpiRunE.dll error about a...
Sound & Audio
Creative X-Fi Xtreme Audio Driver Problems
I recently installed Windows 7 on my computer and downloaded the new .90 driver for my "Creative Sound Blaster X-Fi Xtreme Audio" PCI. I can't seem to switch between the recording device "Microphone"(front Jack) and "Line-In"(Back). Also I tried downloading the driver package that includes the...
Sound & Audio
Creative Soundblaster X-Fi Xtreme Audio
Hello. I'm running Windows 7 build 7600, and seem to have a sound card driver issue. Sound is successfully comming out, but it is screwed up, it fades in and out and has terrible quality (driver from clean install). I am using this sound card, have looked around the forum and have come across a...
Drivers
Creative X-Fi Xtreme Audio x64
Hello, my Windows 7 x64 (7100) found after a clean install new optional updates which included drivers for my soundblaster X-Fi Xtreme Audio. I also used the drivers I got with the cd and installed them on my system. Everything is working now except a few options. I get sound in 5.1, but when I...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App