Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Audio only works for certain applications

19 Jul 2010   #1
Munnin

Windows 7 Pro 32 bit
 
 
Audio only works for certain applications

Hi everyone, first time stumbling across a Windows problem I couldn't solve myself. The issue I am having is that audio will only play through specific applications. It will work in WMP and at certain times in video games (in the main game itself but not the intro movies or voice chat, can hear but not talk), both speakers and usb headset work in skype both sending and receiving audio. However nothing comes up in Firefox as well as windows login/system sounds do not play.

I've tried uninstalling the devices and reinstalling via Device Manager -> Sound, video and game controllers. I've added a second sound card which also has the same problem. I've downloaded and installed device drivers manually. I of course started by playing with the audio settings via Playback Devices/Volume Control Options. Audio per application is not muted as Firefox is never even shown in the volume mixer even with youtube open with a video with sound (have tried multiple other sites as well, none work). I've also gone so far as to re-seat the connections on my mother board but have as of yet found nothing, hardware, software or configuration wise that solves this problem. Any assistance would be greatly appreciated.


My System SpecsSystem Spec
.
20 Jul 2010   #2
Xisuma

MS Windows 7 Home Premium 64-bit
 
 

Would i be correct in assuming that its only video files that are currently inaudible?

If so re install video codecs and maybe graphics card drivers?
My System SpecsSystem Spec
20 Jul 2010   #3
Munnin

Windows 7 Pro 32 bit
 
 

Well no its not only videos. Its also in game voice chat. I've tried uninstalling and reinstalling flash but this does not fix the problem. Graphics drivers deal with video not audio but I went ahead and did it anyways, no change.
My System SpecsSystem Spec
.

21 Jul 2010   #4
Munnin

Windows 7 Pro 32 bit
 
 

Reinstalled Windows. Problem solved.
My System SpecsSystem Spec
Reply

 Audio only works for certain applications




Thread Tools




Similar help and support threads
Thread Forum
No front Panel audio detected but Rear Audio works on Asus P8H 61-M LX
My front USB slots work and every connector on the rear works fine yet when i plug headphones into the front audio jack and nothing is detected. My Bios are updated to the latest version, i have also tried switching to AC97 but makes no difference. Swapping between HDMI and s/pdif doesn't also...
Sound & Audio
Internet Connection works but web applications are not. Needs help.
Hi there. Let me start by saying that I have a background in computer programming and so I understand most jargon, however I don't have much experience with computer hardware problems and networking, so I may not have tried some very simple things. I believe I've tried everything and I have thus...
Network & Sharing
No audio when starting some applications first
Hi, Running Window 7 x64 ultimate. If I start my computer and I start certain software such as the second life viewer, then there is no audio. And after that, all other applications also produce no audio, even though the volume control shows sounds etc. And the audio is not muted or disabled,...
Sound & Audio
Screen Saver works while other applications are gone and locked
I'm using Windows 7 and I got problem on my desktop. Screen Saver is the only thing that is functioning while all other programs are not available even the start menu. Could this be due to a virus or just a little mistake on its setting? I tried to check problem on desktop properties but when I...
General Discussion
RealTek HD Audio - sounds in applications issue
Hello: I know less about hardware than I do about everything else, so please indulge. And I have found so many threads re: RealTek HD Audio, but they don't seem to apply to me. Mods, please feel free to merge this to another thread as needed. Problem: Sounds/sound effects for SOME (but not...
Sound & Audio
Audio works, then stops then works again
Hi all Quick question if i may, this is really baffling me. I have onboard sound on my xfx 750i mobo. ( realtek, i believe) i have installed the latest drivers and for some reason i have this strange problem. If i have my speakers plugged in the back of the PC. the sound is really good. Good...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App