Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Consent.exe and exe problems

05 Aug 2010   #1

Windows 7 Ultimate 32bit
Consent.exe and exe problems

I regularly hibernate my Windows 7 Ultimate Laptop to increase my boot speed. All of a suddent, my .exe files won't open. .REG files wont open and other executable files (except .com) won't open. I normally use firefox but that wouldn't open up anymire, even my Microsoft Office 2010 setup (original cd) wouldn't run. When trying to troubleshoot with my friend I showed him my task manager and it has approximately 28 consent.exe processes, when attempting to kill the process the following error appears: Operation Could not be completed, access is denied.
If i reboot my laptop I am afraid that the explorer.exe file would not run. I am like, AARGHHH! The UAC fails to load, I try to run regedit but it doesnt work. I copy it to d drive (along with the en-us file), it doesnt get past UAC. I change name to (en-us - STILL FAILS AT MUI. I cannot close the folder in which i have run the executable.exe. VLC and WinRAR runs absolutely fine. I think the problem is mainly with the C:/ Drive
I have gone mad with this problem!
Please help me and thanks in advance

My System SpecsSystem Spec
05 Aug 2010   #2

Windows 10 Pro x64, Arch Linux

Your problem could be malware related. Try scanning for malware using malwarebytes:Malwarebytes Anti-Malware - Reviews and free Malwarebytes Anti-Malware downloads at

Or do a repair install:Repair Install
My System SpecsSystem Spec
05 Aug 2010   #3

Windows 7 & Windows Vista Ultimate

Hi, qaisjp.

It does indeed sound like malware. Please download rkill from one of the following links and save to your Desktop:

One, Two,Three or Four
  • Double-click rkill to run.
  • A command window will open then disappear upon completion, this is normal.
  • Please leave rkill on the Desktop until otherwise advised.
  • Do NOT restart your computer after running rkill as the malware program(s) will start again.


If you you receive security warnings about rkill, please ignore and allow the download to continue.

You should now be able to run MBAM. Please download Malwarebytes' Anti-Malware to your desktop.

  • Double-click mbam-setup.exe and follow the prompts to install the program.
  • At the end, be sure a checkmark is placed next to Update Malwarebytes' Anti-Malware and Launch Malwarebytes' Anti-Malware, then click Finish.
  • If an update is found, it will download and install the latest version.
  • Once the program has loaded, be sure Quick scan is selected, then click Scan.
  • When the scan is complete, click OK, then Show Results to view the results.
  • Be sure that everything is checked, EXCEPT items in System Restore as shown in this sample:
  • Click Remove Selected.
  • When disinfection is completed, a log will open in Notepad and you may be prompted to Restart. (See the Note below)
  • The log is automatically saved by MBAM and can be viewed by clicking the Logs tab in MBAM.
  • If you are still having problems, please post contents of that file in your next reply.

** Note **

If MBAM encounters a file that is difficult to remove, you will be presented with 1 of 2 prompts. Click OK to either and let MBAM proceed with the disinfection process. If asked to restart the computer, please do so immediately.
My System SpecsSystem Spec

06 Aug 2010   #4

Windows 7 Ultimate 32bit

Thankyou for helping me, but I took a chance and rebooted, PROBLEM FIXED!!!
Thanks for the help anyway! It turns out that abusing the hibernate feature of Win7 results in this. (Hibernating with Office14 and DreamweaverCS5 running)
My System SpecsSystem Spec
06 Aug 2010   #5

Windows 7 & Windows Vista Ultimate

Glad to hear the restart solved the problem! Thank you for letting us know.
My System SpecsSystem Spec
25 Sep 2011   #6

win7 64

I have the exact same problem, but slightly worse :P
  • i have like 12 consent.exe's in my task manager (i think one extra comes everytime i try to open any .exe)
  • i cannot load any .exe's, just nothing happens.
  • i cannot turn off or restart the computer (nothing happens when i tell it to turn off)
  • ALT CTRL DEL doesnt work
so yea, i feel kind of screwed
i tried downloading the malawarebites and rkill, but nothing happens when i try to run the .exes :S
please help! :P
My System SpecsSystem Spec
25 Sep 2011   #7
Microsoft MVP

Windows 7 Ultimate 32bit SP1

JazzyOne, you latched onto an old post ... start a new topic in this forum so that we can help you with your "individual" problem :)

Give us as much detail as you can.
My System SpecsSystem Spec

 Consent.exe and exe problems

Thread Tools

Similar help and support threads
Thread Forum
Something might be going on with Windows 7 UAC. (consent.exe)
My problem started about 2-3 months ago on my Gaming PC when i noticed that certain programs won't open. When i try running them nothing happens. After looking through my PC, i noticed in the task manager there was this process called "consent.exe" just sitting there. This would stop if i...
System Security
There was another thread, from last year, that went like this: - I have 10 consent.exe in my task manager ( I think one extra comes up everytime i try to run an exe file ) - When I try to end the process (consent.exe) in task manager, It shows up with the message " THE OPERATION COULD NOT BE...
Performance & Maintenance
Consent.exe popping up
I have comodo firewall installed and I have now received an alert for the second time wanting to grant access to 'consent.exe'. It seems consent.exe is related to UAC but when I opened the taskmgr and right clicked to go to file location it wouldn't open it. Usually it takes me to the exe location...
General Discussion
How does consent.exe function in Win 7
Hi, I noticed that on Win 7 a process called consent.exe runs when i try to install any application. From the consent.exe description i understood that it is the consent UI for administrative apps and i believe it is related to the UAC since when UAC is disabled, this process does not run....
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:15.
Twitter Facebook Google+