Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Firewall prevents "network connection" at boot time

11 Nov 2010   #1

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
Windows Firewall prevents "network connection" at boot time

This is very strange.

About two weeks ago I reinstalled Win7 Pro x64 from scratch in order to properly support my new Ceton TV tuner card. All of my application software is now just about fully reinstalled as well, and everything's working fine. The new Win7 is very much "cleaner, leaner, and meaner" than the previous installed version which I'd used kind of like a "training bicycle" over the past 11 months. Much closer to "pure Microsoft" with no "foreign codec packs".

Ok, my current problem seems to be totally related to Win7's Windows Firewall. For some reason 4 out of 5 boots on this machine do NOT establish a network connection (the desktop PC is "wired" connected to the router). And then, almost randomly, maybe 1 time out of 5 I will get a network successfully established. No way of really predicting success or failure, but each failure causes me to re-boot and try again.

Obviously there are several programs that start up with Windows and that need to get out to the Internet, including my Sophos anti-virus (looking for updates), DynDNS (to maintain my hostname/IP address on the DynDNS site), and in particular a program named CLOCKWISE (which goes out to the Navy's web site to get an accurate time-of-day to set my PC's clock).

Now CLOCKWISE also puts out a "Big Ben" chime sound when it sets the clock, so I know if this program is working by whether or not I hear Big Ben. And of course, on those 4 out of 5 boots where network access is not established I hear no Big Ben, and know something is wrong. I then am forced to shut down and try it again... and eventually, usually, it finally works. Of course the next boot may again fail, but I try not to re-boot if I can.

Ok, yesterday I decided to look closer at Windows Firewall and its settings. I noticed that there was no entry defined for the CLOCKWISE program. I experimented by disabling Windows Firewall (both home/private and public) and shut down and re-booted, and this time CLOCKWISE had no problem getting out to the Internet at boot time and my machine had its network connection established flawlessly.

So, I added the CLOCKWISE program to Windows Firewall, and close examination revealed that it only set up an INBOUND rule. Didn't make a lot of sense to me, since I was really trying to let CLOCKWISE get out to the Internet and I thought that's what "add program" to Windows Firewall was for.

Anyway, I then also created a new OUTBOUND rule, allowing CLOCKWISE to get out. Shut down and re-boot, and magically CLOCKWISE starts perfectly and I have a network. So I thought I'd solved the problem.

Then, a while later when I had to re-boot again because of some other software I'd just installed, this time the re-boot hung again with no network established and no Big Ben from CLOCKWISE. On just the previous re-boot it worked just fine, but now on the second re-boot it failed again.

So I again turned off Windows Firewall, shut down and re-booted, and once again network comes up and Big Ben sounds from CLOCKWISE. I then turned on Windows Firewall, because I feel better with it on than off (even though I have an external router to also "protect me").

I've been playing with this, including turning Firewall off and then on again before shutting down, and then re-booting, and startup then works. But if I then just shut down and re-boot, almost always it will fail again.

I don't think this is tied to CLOCKWISE, but rather this program's audible indication that it worked or not just tips me off that Win7 and Windows Firewall itself has somehow prevented network access from starting correctly.

And, if I have Windows Firewall turned off at shutdown, then the re-boot will always work fine and network is established. This points directly at Windows Firewall as the likely culprit here.

Now, what makes this machine unusual, from the way Win7 and Windows Firewall previously worked? Well, there's lots more of TV tuner stuff now with the Ceton card, and there are lots of entries for TV stuff in Windows Firewall. I don't know that this is relevant, but it's certainly different than the way things were two weeks ago... when I NEVER had this boot/network problem.

Any thoughts or suggestions? Anything I should look at or change, or investigate as another likely culprit?

I really do want to fix this. I should be able to have Windows Firewall active and still be compatible with all of my application programs. And I don't want to always have to remember to first turn off Windows Firewall at shutdown/re-boot time, and then turn back on Windows Firewall after startup with the network already established.


My System SpecsSystem Spec
13 Nov 2010   #2

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Well, either nobody has experienced something like this or there's nothing inherently wrong with Win7 or Windows Firewall or my setup that I haven't already done or tried.

Anyway, as luck would have it, all of the re-boots I've done on this machine (as now configured, with the full-enabled newly added inbound and outbound entries in Windows Firewall for Clockwise) over the past few days have NOT seen the symptom at all! Each boot has immediately resulted in the "Big Ben" chime from Clockwise, indicating it had successfully gotten to the Internet and set the PC clock.

Of course I have no explanation for why this is now working 100% normally again (as it used to, though intermittently, even before I added the new entries to Windows Firewall for Clockwise!). Nothing else in the environment has changed.

Anyway, it still does look like Windows Firewall did at least have something to do with the intermittent boot-time failure to establish my network connection (i.e. wired connection through my Netgear router and out through the cable modem). Turn off Firewall, and boot occurs normally. Turn Firewall back on, and boot occurs intermittently normal.

And yet, last few days, Firewall is on and 100% boots have been normal!

Go figure.
My System SpecsSystem Spec
13 Nov 2010   #3


Actually, you're not the only one who has a problem with the windows firewall. I don't like it much either because it won't block the instant phone home feature that seems to be written into almost everything that can be downloaded. Even when you disable the firewall, it's still running as a hidden process. If you disable the firewall service, you lose all network connectivity after a few reboots. The problem is network location awareness, which works with the firewall, has to be running in order to get a network connection, and there doesn't seem to be any way to get rid of the entire set of processes that blocks internet connections until they're "identified".. even if you have a desktop or workstation that is never connected to any other network
My System SpecsSystem Spec

17 Nov 2010   #4

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Well, naturally I'd had several consecutive days of no problem whatsoever establishing my Internet connection at boot time, even with Windows Firewall active. False hope... apparently.

Today, I rebooted three consecutive times (with Window Firewall active) and failed all three times to get connected.

Turned off Windows Firewall, rebooted... and VOILA! Instant connection.

Turned Windows Firewall back on, and still have Internet access with no problem.

It's just something about boot-time timing of various processes all initiating at one time, I guess.

Oh well...
My System SpecsSystem Spec

 Windows Firewall prevents "network connection" at boot time

Thread Tools

Similar help and support threads
Thread Forum
"the drive or network connection that the short cut "lnk" unavail"....
Hi, so currently i have a problem, every time i click on a launcher this message appears "The drive or network connection that the shortcut 'Planetside 2.lnk' refers to is unavailable. Make sure that the disk is properly inserted or the network resource is available, and then try again". (please...
"Preparing to configure windows" Message EVERY time I boot up
Hi all. Every time I boot up my computer (Win7 home premium 64-bit), I get the message that says "Preparing to configure windows", right after this, I get the "Configuring windows updates" message where it shows the progress from 0-100% before it loads windows 7. This has been happening all...
Windows Updates & Activation
How do I fix "security or firewall blocking the connection?"
After installing a Firefox update I cannot connect to the internet on my desktop. I am online because I can get Livemail. I have also tried using IE and still cannot connect I've run the diagnostic..."Security or Firewall blocking the connection..." I use Norton 360 which could be the problem,...
Browsers & Mail
"No Network Access" and "Limited Connection/Connectivity" ?
Hey, I am really hoping someone can help me solve this problem, it's driving me up the wall! When I started using my computer this morning everything was fine, and then "no network access" kept appearing, along with "limited connection/connectivity". I would troubleshoot the problem, but then at...
Network & Sharing
Windows 7 Ultimate 64 bit "limited access" Wireless Network Connection
I just did a clean install on my windows 7 ultimate 32 bit computer to 64 bit. At first, my wireless internet was working fine, but it suddenly dropped to "limited access". I'm using a Linksys WUSB100 ver. 2 wireless network USB adapter. I've already tried downloading the latest driver for windows...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:50.
Twitter Facebook Google+