Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: You need permission to perform this action

18 Jan 2011   #1

Windows 7 Home Premium 64bit
You need permission to perform this action

Hi all, sorry if this has been addressed before, but I couldn't find anything that fit this exactly.

I'm trying to drag and drop a file from one place to another, and get this error
"You need permission to perform this action

You require permission from Harmon-PC/Harmon to make changes to this file."

The part that's annoying me is that I AM Harmon. I've got ownership of the file, and as far as I know I've got permissions as far as I know. and yet, I still can't move the file. Is there a way to fix this problem?

My System SpecsSystem Spec
18 Jan 2011   #2

Windows 7 Ultimate SP1

Simply going to the file>right click>properties>security>choose your user name
See the option "full control" tick,oherwise you need to modify the permission correspond to your account.

You might try the following first:
My System SpecsSystem Spec
18 Jan 2011   #3

Windows 7 Home Premium 64bit

I thank you for the quick reply, the problem is, I HAVE Ownership of the file and I'm still getting told that I require permission from me to move it.
My System SpecsSystem Spec

18 Jan 2011   #4

Windows 7 Ultimate SP1

DId you check All the users in Security(You,SYSTEM,ADMINISTRATORS) are given full control?
Did you open UAC?Any program is using in the files?
My System SpecsSystem Spec
23 Jan 2011   #5

Windows 7 Pro (x64)

Did you check to see that you have ownership and full control of the location you are attempting to move the file to?
My System SpecsSystem Spec
17 Oct 2012   #6

Windowds 7 Professional - 64 bit

I found the solution based on the solution on the Persian forum of AsanDownload (Here)
1- Download and install "Right Click Enhancer"
2- Run the program and go to "Right Click Tweaker". Then select "Take Ownership"
3- Right-click on the file/folder and select "Take Ownership"
Now, you should automatically have all permissions to copy/rename/move and etc
To make sure your account has all the permissions, go to "Properties > Security > Permission"
and see if you have "Full Control" for your account. If not, edit it and put a check mark for full control.

My System SpecsSystem Spec

 You need permission to perform this action

Thread Tools

Similar help and support threads
Thread Forum
You need permission to perform this action System32
I need to replace some system32 files with other ones. I am trying to put a skin on 7 and unable to replace browseui Backup.dll and browseui.dll I've tried unlocking the admin account and taking permission of the folder with no success. Perhaps I've missed something, any suggestions? ...
General Discussion
you need permission to perform this action with access denied at share
All three users, Barb, Bob, Brian, in the advertising department received 'denied access' and 'you need permission to perform this action' while attempting to access the share folder-files 'srv-adv' on the domain server 2008 r2. In the share security I gave Barb, Bob, Brian and the...
Network & Sharing
You Need Permission to Perform This Action
I'm sure there are other threads about this topic, but most of them are while a user is trying to delete a file or folder. I am simply trying to move two files. Back story: I'm having trouble running a Steam game, so I decided to re-install Steam. I moved 'steamapps' to the desktop so I...
System Security
You need permission to perform this action?
I just installed Windows 7 and it doesn't seem so great right now. This is getting really annoying. The message... "You need permission to perform this action. You require permission from administrators to make changes to this folder" keeps popping up. I've tried everything and it's...
General Discussion
Permission to perform this action: RC1 Upgrade problem
Hi guys. Trying to upgrade from 7022 to 7100 RC1 using THIS guide right here, but when I try and copy the installation files from the virtual drive to a folder on my computer, It won't copy setup.exe stating that it needs permission to perform this action, and that it needs permission from Everyone...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:05.
Twitter Facebook Google+