Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Am I really in "Run as administrator" mode?

27 Jan 2011   #1

Window 7 enterprise 64-bit
Am I really in "Run as administrator" mode?

I) I have a machine with Windows 7 Enterprise 64-bit. When I run my applications as administrator, I do not see that "shield" sign on their icons as I see on my other machine (Win7 Ultimate 32bit) showing that the application is running in administrator mode. How can I tell whether my application is actually running in this mode? Why doesn't that sign appear on opened applications icons?

II) The main problem behind the above issue that I have is that I use "Altap Salamander" which is a file navigator. It runs perfectly on my Win7 32 machine. It has a weird problem on this 64-bit machine. For example, when I go to Windows\System32\drivers sub-directory, I cannot see the "etc" folder and some files in 'drivers' directory! while I can do that in windows explorer. That's why I suspected that this application could not be running in administrator mode as I expect. I'm not sure whether it could be related to running it on a 64-bit machine, but it sounds strange as it works quite fine upto 'drivers' directory.

One note: my 64-bit machine is part of a domain and my 32-bit one is not!


My System SpecsSystem Spec
27 Jan 2011   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Try running from regular user account. If it is being run as adminitrator either it will not run or the UAC will pop up and tell you that you must run as administrator.
Make sure UAC is turned on.
User Account Control - UAC - Change Notification Settings
My System SpecsSystem Spec
27 Jan 2011   #3

Window 7 enterprise 64-bit

The program works in both modes. In run as administrator mode, the popup shows up. So far no problems. However, when the program is open, the "shield" sign on its icon which shows it is in administrator mode does not appear! I am doubting whether the program is actually in admin mode! And this I suspect could be the root problem that I mentioned above in number II. I need to make sure that this problem is for sure in administrator mode.
My System SpecsSystem Spec

27 Jan 2011   #4

Windows 7 x86/x64, Server 2008r2, Web Server 2008

On way to test this is sign on as a standard use and try the run as and use the administrative credentials.
My System SpecsSystem Spec
28 Jan 2011   #5

Window 7 enterprise 64-bit

After some searchers, I guess the problem is with the compatibility of the application on 64-bit platforms. As stated in The magic of the SysNative Folder The RDP Files it seems some apps will have problems accessing system folders in 64-bit environments. So, the 'run as admin' should be working fine, I guess.
My System SpecsSystem Spec
28 Jan 2011   #6

Windows 7 x86/x64, Server 2008r2, Web Server 2008

Very interesting.
My System SpecsSystem Spec
28 Jan 2011   #7
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Look at this and follow instructions Learning About Your Own Account with Whoami in Windows 7

Who are you? :)
My System SpecsSystem Spec
29 Jan 2011   #8

Window 7 enterprise 64-bit

Thanks Jacee. I guess I now know the root cause of my problem which is incompatibility of that app on 64-bit platforms.

Regarding the "whoami" command, it actually shows info for the users. What I wanted to know was to see the privilege levels of processes, to ensure if a process is running in admin mode or not. Thanks anyway.

In task manager, there is custom column called "UAC Virtualization" for processes that can be added. It just shows Enabled and Disable values, so I am not sure how it can help to know if a process is running in admin mode or not.

However, I still wonder why the "run as admin" shield sign(picture) does not appear on the icon of those apps that are run as admin. I see this sign on my other machine when I run programs in "run as admin" mode.
My System SpecsSystem Spec
29 Jan 2011   #9

win 7 X64 Ultimate SP1
Not Much Help

I am not quite sure what your problem is from the description. I can confirm that Salamander 2.54 runs on a X64 system. Check my specs. I have it on two rigs.

From the Readme.txt file with Salamaner:

To obtain a copy of Altap Salamander, download the self-extracting
executable file into a temporary directory. To start the installation
process, execute the self-extracting file.
This version of Altap Salamander requires Windows 2000, Windows XP, Windows Vista,
Windows 7 (including 64-bit editions) or later. Some optional features
(some archivers) requires external programs.
My System SpecsSystem Spec

 Am I really in "Run as administrator" mode?

Thread Tools

Similar help and support threads
Thread Forum
Can't change advanced settings from "802.11d" to "wireless mode"
It seems to keep rolling back to 802.11d after I click okay. If you need more information from me I would be happy to fill you in a bit more there. Some basic specs: - 32-bit Service Pack 2 - Acer - AM5620-E1204A - Intel Core 2 Any additional help to further assist would be...
Network & Sharing
Run "cmd.exe" as a given user and "as administrator" in command line
Hello and thank you for reading my post. If I'm logged in Windows as user "u1", I can execute "cmd.exe" "as administrator" by choosing "Start" -> "cmd.exe" and right-click "Run as administrator".I would like to start another "cmd.exe" console as "u2" and "as administrator". (So, "u2" is not...
General Discussion
Going from "bios mode" to "UEFI mode" with windows7
I have an asus m5a99fx mobo with windows 7 64 bit (retail version) installed in bios mode. Is there any way I can change the mode to UEFI without reinstalling windows?
Installation & Setup
BSOD "Bad Pool Header" and "Page In Nonpage Area" Runs in Safe Mode
Hi, I am having a problem with my newer computer, I just got this rig a few months ago and never had a problem until last Thursday. It Blue Screened on me while I was installing ARC GIS 10.1. From then on it randomly crashes. (I have previously installed ARC GIS 10 and never had a problem.) I...
BSOD Help and Support
Professional's "XP" mode vs Premium's "compatability"
Quick question: Is Win 7 Professional's "XP" mode any different than Win 7 Premium's "Compatability" mode?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:07.
Twitter Facebook Google+