Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Getting permission error when installing HP C310 Printer

17 Jul 2011   #1

Getting permission error when installing HP C310 Printer

When I attempt to install the software for my new HP C310 printer I get "fatal errors" due to permissions in the new folders.
I heave used the "built-in-admin" tutorial that Brink wrote.
I have taken ownership of the folders in Program Files and Progam Data. This is where the error occurs.
I have added "user everyone" with full privileges to the above folders.
Nothing seems to work.
The HP support website is so general that it is useless.
What must I do?

My System SpecsSystem Spec
19 Jul 2011   #2

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

I just installed a B210a eAIO and all went okay.

I agree, the instructions are vague. A question that needs asked, Did you follow them precisely?

On ours it was confusing, going between the computer and the touchscreen it would be easy to make a slip.

You might have to re-install after gutting this in-stall.
Uninstalling the Printer Software HP Photosmart Premium e-All-in-One Printer - C310a - HP Customer Care (United States - English)

Have you seen this?
A 'Fatal Error' (MSI error) Displays on the Computer During HP Software Installation in Windows
Source: HP Solve a Problem
Scroll down a bit to:
"Step two: Get troubleshooting for the specific error message"
My System SpecsSystem Spec

 Getting permission error when installing HP C310 Printer

Thread Tools

Similar help and support threads
Thread Forum
Installing a Brother printer, error 0x00000704
Hi, i have installed the Brother printer MFC 8910DW on my windows 7 laptop using USB port with no problem , when i tried to connect it by wireless however,i got this problem : all the steps are ok according to the guide , i fnd the printer and i find the wireless network. In the last step of...
General Discussion
Error in installing a printer 0x000006f7
I cannot install my Laserjet 5000 series printer because I get the above error. I have tried to download drivers from HP and reinstall that way but I then get the following message. It is very frustrating. Can anyone help? Thanks, Dan. ...
Hardware & Devices
Installing a Brother printer, error 0x00000704
Hello, I spoke with the technical support of Brother and he told me that (error 0x00000704) was a mistake of window registe. Can you help me fix this error? Thank you, Gabriel
Hardware & Devices
I'm installing TCP/IP Printer... no communication but error printing..
I am attempting to add a TCP/IP printer to a desktop. I used the set of instructions using, add a printer, create a port, TCP/IP, enter in the IP address of the printer, and the system never finds the printer. It just says, 'device is not found on the network'. Is there another step? My...
Hardware & Devices
Error installing acrobat printer
Hi, i've installed the Acrobat printer without problems in Windows Xp but i keep getting this error when installing it in windows 7 sp1 64. I install it from Start- devices & printes- add printer -> add local printer-> create a new port-> local port-> give name->...
Error message when installing wireless printer
I am trying to install my printer to my wireless network, but I keep getting an error message that I am not the administrator on this computer. This is my personal computer, so don't know why I would not be the administrator. I did set up a homegroup and add my printer and all my documents, but...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:30.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App