Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Remote Desktop (TCP-In) Properties Protocols and Ports tab grayed out

25 Aug 2011   #1

Windows Embedded Standard 7
Remote Desktop (TCP-In) Properties Protocols and Ports tab grayed out

I want to change the Remote Desktop port (RDP) from the default (3389) to something else. Unfortunately, the entire Protocol and Ports tab is grayed out (see attachment) so I can't change it from there. Searching the web I found a registry entry, HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber, that can be used to change the port. When I use the registry entry, I see that my Windows 7 Pro SP1 (and also Windows Embedded Standard 7 SP1) begin listening on the new port, but the remote desktop client cannot connect using <ip address>:<new port> syntax. Is there a way to change the RDP port from the default 3389 to something else that really works? Thanks for your help.

Attached Images
Remote Desktop (TCP-In) Properties Protocols and Ports tab grayed out-rdp-protocols-ports-tab.jpg 
My System SpecsSystem Spec
26 Aug 2011   #2

Windows 7 Ultimate x64

Hi Kris,

Predefined rules are always greyed out you could delete the rule and create a custom rule set I would imagine. You could also use remote desktop software like teamviewer or logmein which are free and are much easier to use and more versatile.

Hope this helps,

My System SpecsSystem Spec
14 Sep 2011   #3

Windows Embedded Standard 7

How might one go about creating a "custom rule set" for RDP?
My System SpecsSystem Spec

15 Sep 2011   #4

Windows Embedded Standard 7

Okay, I found my own answer. I created a custom rule for RDP using a different port. One cannot simply copy the existing rule and change it because the copy of the built-in rule cannot be edited just like the original built-in rule. So, I created a brand new rule that looked identical to the built-in rule except it just uses a different port. Then, and this was the key for me, I changed the RDP port number in the registry at ...


Finally, I rebooted the machine. Now, I can Remote Desktop to <IP-address>:<new-port-number>.
My System SpecsSystem Spec

 Remote Desktop (TCP-In) Properties Protocols and Ports tab grayed out

Thread Tools

Similar help and support threads
Thread Forum
remote desktop properties is empty
hi every one . i'm trying to active my remote desktop but it's settings windows is empty . i have win7 ultimate 32bit service pack 1. this is how it looks
Network & Sharing
Recycle Bin Properties Grayed Out
a friend installed a custom windows seven ultimate and it runs great. i run it through its paces for him and i'm pretty impressed. the only two things that irked are when you rightclick the recycle bin and select properties everything is grayed ou, and when you delete something it is out and out...
General Discussion
Recent places not available, properties check box grayed out?
Greetings. When I go the the recent places option while saving I don't see recent folders listed. I've searched on this and the prevailing solution seems to be to go to Taskbar and Start menu properties>>Start Menu and then check both of the Privacy boxes. However, the second box is greyed out....
General Discussion
I Properties/Advanced Use SSL's grayed out windows 7
I am not a novice and I have tried everything I've learned since 1990 to repair this with a Repair Install (got to much to lose). I have a couple of text copies of my registry and even swapped Internet Settings, Internet Explorer hives etc. Ad nauseam from those registry texts and still get this...
Browsers & Mail
Remote Desktop Properties file missing
I'm trying to access the remote system properties by using the path Start>Right click-Computer> Properties> Remote Settings. But when I do it gives me the error of "Windows cannot find 'C:\Windows\system32\systempropertiesremote.exe'. Make sure you typed the name correctly, and then try again." ...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:37.
Twitter Facebook Google+