Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: You Need Permission to Perform This Action

26 Oct 2011   #1

Windows 7 Professional x64
You Need Permission to Perform This Action

I'm sure there are other threads about this topic, but most of them are while a user is trying to delete a file or folder. I am simply trying to move two files.

Back story:
I'm having trouble running a Steam game, so I decided to re-install Steam. I moved 'steamapps' to the desktop so I wouldn't have to reinstall my games, and uninstalled and reinstalled it.

Now I'm trying to move 'steamapps' back into the correct place. All of the files moved successfully except for 'sourceinit.gcf' and 'winui.gcf'. It gave me the 'You Need Permission to Perform This Action' pop-up. I am the Administrator, there are no other users.

I've looked up how to fix this problem and most commonly it is suggested that I should give myself ownership of the files through command prompt, which I did. I also looked under the Security tab for both files and the 'steamapps' folder, and I have full permissions.

My System SpecsSystem Spec
26 Oct 2011   #2

Windows 7 Professional SP1 32-bit

It might not be that you need ownership of the two files you're trying to move, but rather ownership of (and full permissions to) the folder you're trying to move them into. Have you checked that?
My System SpecsSystem Spec
27 Oct 2011   #3

Windows 10 Pro x64

As Corazon said try with Taking Ownership.Take Ownership Shortcut
My System SpecsSystem Spec

27 Oct 2011   #4

MS Windows 7 Ultimate 64-bit SP1

A move command is in fact two commands together.

First it will copy the files from source to target folder. After the successful completion of copy files, it will delete the source files.

You have to find out where you are getting the problem, during copying or during the delete after copy.

Instead of moving the files, try to copy the files first. After successful copying you can delete them later.

Check the ownership permissions of the target folder. If the ownership permissions are with another user like System, take ownership and after copying the files, revert the permissions back to the default owner.
My System SpecsSystem Spec

 You Need Permission to Perform This Action

Thread Tools

Similar help and support threads
Thread Forum
You need permission to perform this action System32
I need to replace some system32 files with other ones. I am trying to put a skin on 7 and unable to replace browseui Backup.dll and browseui.dll I've tried unlocking the admin account and taking permission of the folder with no success. Perhaps I've missed something, any suggestions? ...
General Discussion
you need permission to perform this action with access denied at share
All three users, Barb, Bob, Brian, in the advertising department received 'denied access' and 'you need permission to perform this action' while attempting to access the share folder-files 'srv-adv' on the domain server 2008 r2. In the share security I gave Barb, Bob, Brian and the...
Network & Sharing
You need permission to perform this action
Hi all, sorry if this has been addressed before, but I couldn't find anything that fit this exactly. I'm trying to drag and drop a file from one place to another, and get this error "You need permission to perform this action You require permission from Harmon-PC/Harmon to make changes to...
System Security
You need permission to perform this action?
I just installed Windows 7 and it doesn't seem so great right now. This is getting really annoying. The message... "You need permission to perform this action. You require permission from administrators to make changes to this folder" keeps popping up. I've tried everything and it's...
General Discussion
Permission to perform this action: RC1 Upgrade problem
Hi guys. Trying to upgrade from 7022 to 7100 RC1 using THIS guide right here, but when I try and copy the installation files from the virtual drive to a folder on my computer, It won't copy setup.exe stating that it needs permission to perform this action, and that it needs permission from Everyone...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App