Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to boot windows even in safe mode due to Blaster32 worm

25 Nov 2011   #1

Windows 7 Home Basic
Unable to boot windows even in safe mode due to Blaster32 worm

Hello everyone,

This is my 1st post in this forum so please bear with me.

I'm a novice and need urgent help please

My Laptop :
Dell Inspiron N4010
OS : Windows 7 SP1
Dual Boot ( Ubuntu )

My problem :
1) Gave my laptop to one of my friends and got infected with Blaster32 worm or some malware.
2) Tried to remove the worm/malware using msert.exe d/led from microsoft website in safe mode.
3) It identified around 18 infected files and I guess removed them too.
4) Restarted the PC and started browsing the internet, but it again popped up and said you are
infected with Blaster32.worm n so on.
5) After this my laptop has stopped booting into normal, safe, safe with command prompt, etc.
6) Then I tried to restore windows using the Startup recovery ( Advanced Option ) to one of the earlier restore points but I'm unable to do so coz it says "Failed to restore successfully...could not extract AGM.dll file".
7) Now I'm unable to boot windows in any mode!
8) I don't even have a recovery CD ( from Dell or any other )
9) However I since my laptop is dual boot ( Ubuntu ), I can d/l and read all my files of windows if needed.

Waiting for help desperately.


My System SpecsSystem Spec
25 Nov 2011   #2

Windows 7 & Windows Vista Ultimate

Hi, rbisawa. You don't have the Blaster Worm. Rather, it is a rogue (fake) called "Spyware Protection".

Please see this tutorial for the Microsoft Standalone System Sweeper.
This will show you how to update and use the Microsoft Standalone System Sweeper Tool to create a 32-bit or 64-bit Standalone System Sweeper bootable CD/DVD, USB flash drive, or ISO file to help you start an infected PC and perform an offline scan to help identify and remove rootkits and other advanced malware. In addition, Microsoft Standalone System Sweeper can be used if you cannot install or start an antivirus solution on your PC, or if the installed solution can’t detect or remove malware on your PC.
Next, I suggest the following additional steps:

If you cannot start the computer in Safe Mode with Networking, try downloading the following files to another computer and transferring them to your machine.

1. Please download rkill from one of the following links and transfer to your Desktop:

One, Two,Three or Four
  • Double-click rkill to run.
  • A command window will open then disappear upon completion, this is normal.
  • Please leave rkill on the Desktop until otherwise advised.
  • Do NOT restart your computer after running rkill as the malware program(s) will start again.

Note: If you you receive security warnings about rkill, please ignore and allow the download to continue.

2. Please transfer Malwarebytes' Anti-Malware to your desktop.

  • Double-click mbam-setup.exe and follow the prompts to install the program.
  • At the end, be sure a checkmark is placed next to Update Malwarebytes' Anti-Malware and Launch Malwarebytes' Anti-Malware, then click Finish.
  • If an update is found, it will download and install the latest version.
  • Once the program has loaded, be sure Quick scan is selected, then click Scan.
  • When the scan is complete, click OK, then Show Results to view the results.
  • Be sure that everything is checked, EXCEPT items in System Restore as shown in this sample:
  • Click Remove Selected.
  • When disinfection is completed, a log will open in Notepad and you may be prompted to Restart. (See the Note below)
  • The log is automatically saved by MBAM and can be viewed by clicking the Logs tab in MBAM.
** Note **

If MBAM encounters a file that is difficult to remove, you will be presented with 1 of 2 prompts. Click OK to either and let MBAM proceed with the disinfection process. If asked to restart the computer, please do so immediately.

Let us know how you make out.
My System SpecsSystem Spec
27 Nov 2011   #3

Windows 7 Home Basic
Update on my problem - "%hs is missing" error!


Thankyou for replying.

Sorry for the delayed reply was busy with some other work.

Tried the steps mentioned by you as follows :

1) D/led the Microsoft Standalone System Sweeper and ran it on my laptop.
2) It found a trojan known as "Win32/Karagany.G" and removed it.
3) I exited from the sweeper and removed my USB drive and tried to start in safe mode with
networking to complete the remaining steps, but it threw the following error with a blue
screen :

"c0000135 The program can't start because %hs is missing from your computer. Try
reinstalling the program to fix this problem."

And let me tell you I definitely DO NOT have AVG installed on my laptop.

4) So again safe mode boot is NOT going through.

Please suggest me the next step of action.

Waiting anxiously for the reply!

My System SpecsSystem Spec

27 Nov 2011   #4

Windows 7 Ultimate x64

Download and burn ANY of the following bootable rescue CDs from a clean computer to remove the virus since you are not able to boot into the infected computer's safe mode.

Rescue CDs:
Related Articles:
My System SpecsSystem Spec
30 Nov 2011   #5

Windows 7 Home Basic
Update on my problem - Still unable to boot in safe mode


Thankyou Francis93 for your reply.

Tried the steps mentioned by you as follows :

1) D/led the Kaspersky rescue disk and ran it on my laptop.
2) It detected 6 trojans!! and I told it to remove all.
3) Hopefully after removing the trojans I tried to boot my laptop
in normal mode but in vain.
4) Then I tried booting it in Safe mode with Networking but again got the same
error as mentioned in 3rd post.

"c0000135 The program can't start because %hs is missing from your computer. Try reinstalling the program to fix this problem."

Now i'm trying to repair start-up using startup repair, but i don't think it'll work either.

Please let me know the next plan of action.

I'm losing hope now!

p.s. : Is it that the trojan removal tools which I hv used must hv also deleted some important system files??

Still cheers!
My System SpecsSystem Spec
01 Dec 2011   #6
Microsoft MVP

Windows 7 Ultimate 32bit SP1

"Failed to restore successfully...could not extract AGM.dll file".
See this
Agm.dll - Agm.dll Not Found Error - Missing Agm.dll - Fix Agm.dll

Are you running AVG anti-virus? If so, see this page for error "c0000135 The program can't start because %hs is missing from your computer"
STOP: C0000135 The program can't start because %hs is - Microsoft Answers
My System SpecsSystem Spec
02 Dec 2011   #7

Windows 7 Home Basic
My problem got resolved!!

Hi all,

Thankyou all for your inputs.

I was able to solve my problem.

Solution :
1) Firstly I restored my windows 7 using the Dell Datasafe facility available through the Advanced Boot Options.

But since there was no bootloader for windows I had to install Ubuntu once again ( and which I also wanted to have )

2) D/led Ubuntu 10.04 and re-installed in on my laptop using USB drive.

3) Since earlier also I had Ubuntu + Windows 7, I didn't have to partition the disk n

4) Ubuntu installation went about smoothly and it detected the presence of
windows too.

5) Thus I am now able to boot both windows as well as Ubuntu just like before.

And the first thing I did after resolving the issue was to d/l an antivirus s/w and all the microsoft updates.

Now I have d/led the Microsoft Security Essentials antivirus and I hope it will protect my laptop from future attacks.

Can someone please tell me if this is a good tool to have or is there anything better which you would like to suggest.

My System SpecsSystem Spec

 Unable to boot windows even in safe mode due to Blaster32 worm

Thread Tools

Similar help and support threads
Thread Forum
Newly installed 980, unable to boot (safe mode freezes at classpnp.sys
Just got a GTX 980 (Asus reference) and when I've got it installed it freezes at "Starting Windows" and I have to hold the power button it to restart it. When trying to boot to safe mode, the computer hangs on classpnp.sys I know it's not the graphics card as it boots on my friend's computer...
General Discussion
Unable to Run Windows Normally and cannot invoke Safe Mode
After 2 years, my PC won't boot up. Windows 7 x64. ASUS P8H67-I. System always reports that it needs to repair. I've run Startup Repair perhaps 10 times, and it never finds anything wrong. SAFE MODE I can't get into safe mode when booting from disk. F8 is ignored. But I can get into safe...
General Discussion
Persisant BSOD BAD POOL HEADER 0x19 unable to boot to safe mode
hi hope someone can help me. am looking at a friends samsung dp-u200 all-in-one touchscreen desktop pc. It keeps getting BSod whilst trying to load the desktop. The same happens if i try to boot into safe mode. I currently have the hdd linked up to my computer so i could access the bsod...
BSOD Help and Support
Unable to boot off safe mode and the machine shuts down abruptly.
I own a gateway notebook as my secondary machine but since I sold my workhorse it should be my main machine this week before I buy a couple new macs and transfer this buddy to my mom, as of this morning I tried to wipe off the ATI HD3200 driver and update it as the scaling options were not showing...
General Discussion
Windows 7 unable to boot in normal or safe mode
Hello guys, I've been attempting to fix my laptop for the past 4 hours and nothing seems to be working so I thought I would try my luck in this forum. Here's what's going on: When I turn it on, it loads the compaq screen, then says "windows is loading files". It then attempts to take me to...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App