Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to start Windows Firewall

01 Feb 2012   #61

Windows 7 Home Premium 64bit

Quote   Quote: Originally Posted by Lighty View Post

I have the same problem as other people with being unable to activate their Windows 7 Firewall. I have completely removed all viruses through Hitman Pro and Malwarebytes. The only problem is that I can add the bfe.reg and firewall.reg files (or at least it appears to be added; a popup says that they have been added), but when I go to regedit, it just says HKEY_LOCAL_MACHINE instead of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\BFE.

At first, I just kept going, restarting, right clicking HKEY_LOCAL_MACHINE, adding Everyone, and then granting full permission. However, I still received an error message when I went to services.msc and tried to Start BFE and Windows Firewall. When I went back to HKEY_LOCAL_MACHINE after restarting, Everyone was still there, but it did not have full permission even though I allowed it earlier.

I suppose this is because the bfe.reg and firewall.reg files aren't being properly added to the registry, but I approved every popup and it said, "The keys and values contained in C:\Users\NAME\Downloads\bfe.reg have been successfully added to the registry."

Help would be very much appreciated. I am flipping out without Windows Firewall.
Also got error messages when startting BFE and Windows Firewall through services.msc. Instead of adding "everyone" to BFE in regedit, try adding "NT Service\BFE" without "" ofc. This should create an user called BFE. Give it full permission and now try to start BFE and windows firewall in services.msc. Worked for me and I have finally gotten my firewall back

A big thanks to Balon for posting the solution!!

My System SpecsSystem Spec
04 Feb 2012   #62

Windows 7 Home Premium (x64) Service Pack 1 (build 7601)

Balon, Thank you very much for this excellent fix which solved the problem for our user HERE when all else had failed.
My System SpecsSystem Spec
07 Feb 2012   #63

win7 home premium 64

This fix worked where everything else I have tried failed. Amazing work.
My System SpecsSystem Spec

19 Feb 2012   #64

Windows Vista Home Premium
Windows Vista / WMP Sharing not working - SOLVED


My WMP sharing / Media sharing was working fine and one day it simply stopped working - I only really noticed when I saw that my PC wasn't showing in my PS3 Media network (is that how it's called?) and when I tried to manually start Media sharing I got error messages.

No virus, I didn't do any registry changes myself nor installed any fancy software, maybe it was a Windows Update thing?

Anyway, I tried a couple of things off the internet related to WMP (netsh winsock reset and others) but none worked. A few people mentioned possible problems with the Windows Firewall... THIS SOLUTION DID THE TRICK!

Thank you so much!

Quote   Quote: Originally Posted by Balon View Post
Hi there, my name is Balon and I am pretty sure I have the way to fix your problem.


Backing Up Your Registry
  1. Go Here and download ERUNT
    (ERUNT (Emergency Recovery Utility NT) is a free program that allows you to keep a complete backup of your registry and restore it when needed.)
  2. Install ERUNT by following the prompts
    (use the default install settings but say no to the portion that asks you to add ERUNT to the start-up folder, if you like you can enable this option later)
  3. Start ERUNT
    (either by double clicking on the desktop icon or choosing to start the program at the end of the setup)
  4. Choose a location for the backup
    (the default location is C:\WINDOWS\ERDNT which is acceptable).
  5. Make sure that at least the first two check boxes are ticked
  6. Press OK
  7. Press YES to create the folder.
Registry Modifications

Download both the registry files



Launch and import them to registry

Restart your PC

Now,open RUN and type

regedit and click ok

go to


Right click on it-permissions

Click on ADD and type

Everyone and click ok

Now Click on Everyone

Below you have permission for users

Select full control and click ok

Now,open RUN and type

services.msc and click ok

start base filtering engine service and then windows firewall service

For further assistance contact me here, I will be checking this thread every few hours, this worked for me and it should work for you too.
My System SpecsSystem Spec
26 Feb 2012   #65

Win7 Ultimate 64-bit
Fix worked, virus details

My wife's laptop was just infected, she recalled an Adobe update pop-up (obviously fake now). The instructions provided by Balon worked. I thought I'd post the viruses that were detected so others may find this link. Also I'll describe my variant fix approach that worked.

Variant fix approach: Microsoft Security Essentials detected several viruses and quarantined them. I then began observing Google Chrome links were all being redirected when trying to get to Malwarebytes. Opened in IE9, was able to download malwarebytes, ran, and it immediately detected 4 items in memory. Ran full scan on MSSE and MB, and no other items were found. Rebooted after, believed system was clean at that point, but found firewall inoperable as per other users on this thread. Followed Balon's repair instructions as described in first post only and worked without any issues. Thanks!

The viruses detected by MS Sec Essentials were, in order of detection (first detection on 24-Feb-2012, 0900 GMT-7):

Items from Log of Malwarebytes run:

2/25/2012 9:24:10 PM
mbam-log-2012-02-25 (21-24-10).txt

Scan type: Full scan
Scan options enabled: Memory | Startup | Registry | File System | Heuristics/Extra | Heuristics/Shuriken | PUP | PUM
Scan options disabled: P2P
Objects scanned: 46501
Time elapsed: 10 minute(s), 22 second(s) [aborted]

Memory Processes Detected: 1
C:\Users\Cheryl\AppData\Local\dplaysvr.exe (Spyware.Password) -> 4996 -> Delete on reboot.

Memory Modules Detected: 1
C:\Users\Cheryl\AppData\Local\dplayx.dll (Trojan.Downloader) -> Delete on reboot.

Registry Keys Detected: 0
(No malicious items detected)

Registry Values Detected: 0
(No malicious items detected)

Registry Data Items Detected: 0
(No malicious items detected)

Folders Detected: 0
(No malicious items detected)

Files Detected: 2
C:\Users\Cheryl\AppData\Local\dplayx.dll (Trojan.Downloader) -> Delete on reboot.
C:\Users\Cheryl\AppData\Local\dplaysvr.exe (Spyware.Password) -> Delete on reboot.


Thanks again to Balon, and I hope the text I've added here helps others find the thread.
My System SpecsSystem Spec
01 Mar 2012   #66

win 7 home prem 64 bit
firewall more issues

Hi,moving this to new thread
My System SpecsSystem Spec
07 Mar 2012   #67

win 7 64

Hi evryone, excuse my english, but I am from Spain.
Want to follow your prompts but dont know how to import those files (bfe, firewall) to register. Could you help me??
Thanks thanks thanks

My System SpecsSystem Spec
07 Mar 2012   #68

win 7 64

Nor do I understand the following: "start base filtering engine service and then windows firewall service" Should I install them on my computer??? or are they already installed?

Thanks again!!!!!
My System SpecsSystem Spec
11 Mar 2012   #69

Windows 7 Professional
Balon - thank you

Hi Balon
I have had this issue for months and was unable to find a solution until your message. Thanks so much for your help.
My System SpecsSystem Spec
11 Mar 2012   #70

win 7 64

GREAT!!!! Thanks a lot!!!!!

I got it!!! I translated your prompts and learnt to import files to the register.
Easier than i thought

Thanks thanks thanks
My System SpecsSystem Spec

 Unable to start Windows Firewall

Thread Tools

Similar help and support threads
Thread Forum
Unable to start windows firewall
I am using windows 7 – 64 bit ultimate. My firewall has not been running for a long while. I am using Kaspersky internet security 2016. I tried uninstalling it. But still my firewall doesn’t run. I went to services.msc using the Run command and tried to start my firewall but I got this error. ...
System Security
Unable to open ports in Windows 7 Firewall
I am trying to set up a minecraft server on my PC. It is connected wirelessly to a broadband router, and I have set up port-forwarding on the router. I am testing using Shields Up to scan the relevant port, 25565, while the server is running, and if I turn off the PC firewall, it successfully...
Network & Sharing
Services disabled and unable to start, no internet, no firewall, etc.
Hello sevenforums After having absolutely no issues when I shut the computer down, to the computer acting strange and having several issues at the next startup. The issues are mainly related to the network, but not limited to it, so I decided to post it here, but unsure if it is the correct...
General Discussion
Windows Firewall Service unable to activate, SFC scan unable to work
Well I got a big problem. A couple days ago I noticed network connectivity issues. Random connection drops, overall bad connection, etc. I recently had some really bad malware and I removed it, so I suspected leftover malware from the start. I went to check Windows Update to see if I missed a...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:44.
Twitter Facebook Google+