Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to edit a file

15 Jan 2012   #1

Not Applicable
Unable to edit a file


I facing a strange problem in windows 7. I am running PHP and Apache web-server on my windows 7 platform. I have the php.ini file in my C:/ drive <Windows> folder. I tried to edit and save the file. After editing when I tried to save the file it tells me that this file is being used by some other program and I can't save the changes. I closed all possible programs which may be using this file. Still I am facing the same problem. Now I have no idea which program is using this. Please let me know how can I know that which programs are using this specific file php.ini? Is there any windows tool to see it? Or what is the procedure to solve this problem. Please help me in solving this problem.

My System SpecsSystem Spec
15 Jan 2012   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Perhaps not your ultimate answer, but something to try until another suggestion comes along. D/L and install LockHunter. Right click on the file, and choose What is locking this file? It should show you what is locking the file. And you also have the option of closing the locking process. A Guy
My System SpecsSystem Spec

 Unable to edit a file

Thread Tools

Similar help and support threads
Thread Forum
Unable to edit hosts file
Hello, I have a laptop that it doesn't allow me to edit hosts file. I tried many ways first I tried to give myself permissions in properties - edit but it gave me 'access denied' when trying to apply.. And I tried a method I found on google is to open a notepad with administration then open the...
General Discussion
Unable to edit music files in Media Player transfered from old laptop
Hi All I had an ageing Vista laptop that developed a hard drive problem so I now have this great new 7 one. I am fortunate in that I work for a local computer company so I was able to salvage music etc. My issue is that I am unable to edit anything that was recovered from my old laptop in...
Music, Pictures & Video
Unable to edit files in ZIP folders
Win7 has this neat feature where I can navigate into a compressed (zip) file from Windows Explorer. The icon appears like a folder with a zipper through it & I can just navitage where I please. However, I can't edit a file in the zip folder directly. I have to first copy it out of the zip, edit...
General Discussion
Unable to delete EDIT item in context menu
Running 64 bit Windows 7 SP1 with all updates I've been cleaning up my context menu and I have it right where I want it except for one item which I have been unable to find out how to delete regarding text (.txt) files. I use UltraEdit as my text editor and have set it as the default...
Unable to edit/run a .bat file win7 sp1
Hi, this my first thread here, i have read some of the other threads regarding .Bat files and running them ,but none of the suggestions have so far worked for me, Here is the situation, i installed an old game R6Vegas2 to c:/games instead of the protected programe files(default install...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:27.
Twitter Facebook Google+