Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Disable forever. "Special permissions"

22 Dec 2010   #61

Windows 7 Ultimate x32


I think I have found a fix to this. I apologize if someone else posted this already, but by page 3 I had an idea and jumped to the end.

I was having a Horrendous time trying to manage my files. Too many "Administrator permissions needed" messages. Driving me nuts. On top of that, I was having trouble making sense of UAC and Security settings, but I have managed to figure out how to make those darned permissions requests go away!!! Hope this works for you too.

1) Right click on your chosen drive in "My Computer"
2) Click Properties
3) Click Security Tab
4) Check to see if the "Authenticated Users" group has Full Control permissions. If not:
5) Click Advanced
6) Click Change Permissions
7) Select Authenticated Users
8) Click Edit...
9) Select "Full Control"
10) Click OK 4 times
11) Test
It will take quite a long time depending on how much is on that drive, to change the child permissions on every single file and folder on the whole drive. BUT: Hasn't asked me since!!

Please let me know if this works for you all as well

FYI just in case: (I also have SYSTEM and Adminsitrators (Name\Administrators) set to full control too, don't know if that makes a difference as well)

My System SpecsSystem Spec
23 Dec 2010   #62

WIN7 ENT x64, Windows Server 2008 ENT x64, Windows Server 2008 R2 ENT x64, CentOS 5.5 x64
Uhm, unsure what to say...

SID: S-1-5-11
Name: Authenticated Users
Description: A group that includes all users whose identities were authenticated when they logged on. Membership is controlled by the operating system.

Now, I am running a WORKING (Win 7 x64) system currently with no permission issues, if you delve any deeper than the quote above and truly know what the Authenticated Users' Group is for, while you may have found something that fixes the problem, what you mention is NOT what is the cause of the "Permissions Issue" referred to in this thread, nor anything I would want to change the permissions for ---> ESPECIALLY ON FOR INSTANCE A WS08/R2 domain or web controller... (Though oddly I have never seen the issue crop up in either of the Server flavors of Windows 6.1/["7"]...) Please look carefully below at the pictures and settings I have on a system with no issues, then think about the possible security vulnerabilities caused by making the change(s) you suggest...

Also of interest, notice how the "REAL" permissions differ in screenshot #4, #5 and subsequently #6 (another permission container for Auth. Users...) over screenshot #2 and #3...

OK, this is a "working system" with no permission issues noted. While I will not argue that what you posted did, or did not work with your particular problem, please realize that I am pretty certain off the top of my head that ACL never has granted the Authenticated User "FULL CONTROL"

It would be of more use for you to have used the ACL tools and others to capture permission levels FIRST, as well as compare on a working system with similar installations; I think you might be surprised... Have you looked to insure all is correct in gpedit.msc??? (Local Group Policy Editor...)

I think you need get back with us on this. As you can see, here is an example of ONE system, working fine and as intended, that the Authenticated User indeed IS NOT granted Full Control; and that is by design I do believe. Can you show us the permission levels as I have here on a system with the permissions bug for the Authenticated User; and show that it differs from above???
My System SpecsSystem Spec
23 Jan 2011   #63

windows 7 starter
A possible solution

I found a cheap -actually free- solution. Erase W7 and install Ubuntu.
My System SpecsSystem Spec

24 Jan 2011   #64

WIN7 ENT x64, Windows Server 2008 ENT x64, Windows Server 2008 R2 ENT x64, CentOS 5.5 x64
More solutions (for idiots only...)

Quote   Quote: Originally Posted by mosco011 View Post
I found a cheap -actually free- solution. Erase W7 and install Ubuntu.
This is as useful as the following solution: DESTROY YOUR COMPUTER WITH A SLEDGE-HAMMER AND NEVER USE ONE AGAIN. Come on man, you're wasting server space with this crap.
My System SpecsSystem Spec
24 Jan 2011   #65

Windows 7 x64 Ultimate

Quote   Quote: Originally Posted by mosco011 View Post
I found a cheap -actually free- solution. Erase W7 and install Ubuntu.
Pray tell how you got rid of the "permissions problem" on Linux where every system setting change or program install requires you to type in your root password. Or copying files from one user to another or to and from root owned space doesn't cause the EXACT same issues?

Run as root all the time? Set the global permissions on the entire root space to your user account?

Learning how to USE the permission system will get us all a lot further than constantly trying to thwart it. (And that's exactly the same on Linux)
My System SpecsSystem Spec
24 Jan 2011   #66

windows 7 ultimate x64

Ok seriously, tell someone to go use XP over 7 again I'll gladly send you a virtual slap.
Getting sick of hearing people say that. It's not happening get over it. Besides that somethings aren't even support in xp that people need 7 for. Like directx 11 or GPU drivers for example. Sure theres "bootleg" versions, they also come with bootleg coding.....
I can't even change details/descriptions on one file that has nothing to do with windows, no uac, hidden admin acct, has ownership the works and for something so stupid as changing the description of the file?

Computer: You need permission from..... username....oh you!
Me: Well ok ask me for permission....hey win7, retard, ask me...
Computer: (Hmm)No, not going to ask you, but would you like to retry anyway?
Me: "What the f?"
Computer: Click retry, it'll work I promise
Me: ........ (click)
Computer: HAH totally kidding, retry again?
Me: Are you going to ask me this time? ......
Computer: I don't speak english
Me: What about 1's and 0's
Computer: Hmm? I'm windows 7 and I was built using 8's and 9's.
Me: Bl** me.
My System SpecsSystem Spec
27 Mar 2011   #67

win7 x64 home premium

There are many different reasons(settings) why you cant access files or folder. But my problem was simple. i mistakenly changed ownership of a folder. I changed Ownership back to administrator, but it didnt help.tried it again but this time i noticed a checkbox that said (replace owner on sub containers and objects).
I checked this and it worked. i now have access to this folder and all files init.
Duh!, whats my name?

Apparently, If you dont check this box,ownership of any files or sub folders in that folder. wont be changed.
Hope this may help someone else.
My System SpecsSystem Spec
27 Mar 2011   #68

Microsoft Community Contributor Award Recipient


Hello fret4you and welcome to Seven Forums.

You might find this previous thread an interesting read:

Take / Assign Ownership of file / folder
My System SpecsSystem Spec
24 Dec 2011   #69

Windows 7 Professional x64
Win 7 permission problems

Hi guys, I think I have found the solution :)

Problem pt1:
I reinstalled Windows, but some data like photos, music, etc. on my EXTERNAL HDD couldn't be changed (renamed, moved, deleted), because new system thought, that I am not the real owner.

Problem pt.2:
If I opened Properieties->Security on my file, I noticed that there is some another unknown (and non-existing) user from the last last copy of Windows, who owned this file and all other folders and subfolders inherited rights from it. Name of this user was rly long number. I tried to change ownership manualy to "new me", but system still wanted permissions from "new me" and somehow wasn't able to identify me. Also, there was a priblem with deleting this "old me" - I think this caused most of the problems.

Notice: It is good to do this on the very first level of inherited hierarchy, otherwise it may not work properly.

1. Download this script from Add "Take Ownership" to Explorer Right-Click Menu in Win 7 or Vista - How-To Geek .
2. Right-click on the folder and select Take Ownership. This (this may take a while)
3. Only NOW you can delete that old user, who has all the rights (Preferences->Security->Edit->Remove) - and actually get back your privileges to files.
My System SpecsSystem Spec
26 Dec 2011   #70

Windows 7 x64 Ultimate

This is the correct thing to do with personal files that are on seperate drives or that you manually copied into your windows 7 user folder or in folders on the rrot drive that you created.

One thing to NOT do is run take ownership on the root of your OS drive or on the program files or windows folders. That can mes things up prety bad. But running it on your own personal files is exactlly the right thing to do in this situation :)
My System SpecsSystem Spec

 Disable forever. "Special permissions"

Thread Tools

Similar help and support threads
Thread Forum
Disable forever ""Word hyphenation feature is not avai"
When I open some documents then always a warning popup appears in Word 2007: "Word hyphenation feature is not available. RUn the MS Office Setup program..." How can I permanently and forever disable this popup (without saving the document and without re-install some other parts of MS...
Microsoft Office
"User profile service failed the logon" special case access denied
Hello SevenForums! A friend of mine brought a Windows 7 Ultimate x86 laptop saying that he can't log in with his account. When he tries to log in it shows this message: "The User Profile Service failed the logon. User profile cannot be loaded." Now I've searched the internet and found a few...
General Discussion
Permissions for non-system, "user" drives; not "c:"
Would like to not have UAC pop-up for files & folders on non-C: drives, so expect they need to have "full control". Default is Special Permissions. Is there a way to default to "full control" when new folders are created, or do I need to mod permissions for each one? Note that I am NOT talking...
General Discussion
LAN File Sharing "7" to "XP" Permissions issue
Hello Everyone I'm really hoping there is someone here who can help me with what should be an easy issue. This might be something related to workgroup vs home group but I think I have that understood. I have a windows 7 machine with the same workgroup set as my two XP machines. I then...
Network & Sharing
Bypass "Ownership" and "permissions" to files altogether!
Hello all! I don't understand what the issue is but I am logged on as administrator on my computer and only a few of my files I can access. the window will pop up stating that i don't have permission to view the file! if I am the adminitrator i should have full access to any file, right? this...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:13.
Twitter Facebook Google+