Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: icacls to reset everything(sec/owner/premision) to admin.

16 Dec 2012   #1

Win7 64 Home(HP Icore5 HP touchsmart) and Ultimate 64 desktop.
icacls to reset everything(sec/owner/premision) to admin.

icacls C:\ /grant administrators:F /T /C

So would this set folders permissions and junk so the wandering folders permissions,ect get fixed.

Is there anyway you can just turn off security/permissions,ect so you will not get owner/permissions issues anymore?

Yes I did turned off UAC since it dose not let me load programs at start up in admin mode.

My System SpecsSystem Spec
16 Dec 2012   #2

Windows 7 Ultimate x64

The easiest way is to just grant "everyone" full control over the whole hard disk, so bye bye security and anyone/anything will never get an "access denied" error.
However, I think It's a VERY bad idea. That does the trick, but I would suggest AGAINST using it.

There is also a trick that lets you run elevated programs at startup, even with UAC enabled. First you can use this tutorial to create a shortcut to the program: Elevated Program Shortcut - Create for Standard User
Then place that shortcut under the startup folder of start menu.
My System SpecsSystem Spec
16 Dec 2012   #3

Win7 64 Home(HP Icore5 HP touchsmart) and Ultimate 64 desktop.

Tried ACT did run as invoker, runasadmin and elevated , no matter the combo my programs would not start after windose boots up. Thus why I am playing in no mans land.

I do not really need to let everybody as admins I just need admin thats always admin that is never forgotten that its admin, Hell I have no other users and this has been an on and off problem since Vister 0_o


Since vista I can not recall when I made Utorrent start up at boot. Now on my Laptop thats normal Win7 home works fine..... teh fck? 0-o I don't like messing with the lappy much for some strange reason ><

Strange thing is its not set on admin and UAC is default.

Uhg time to dance the format,reinstall somba LOL oh well, got any ideas how I can trick it into behaving on Win7U 64?
My System SpecsSystem Spec


 icacls to reset everything(sec/owner/premision) to admin.

Thread Tools

Similar help and support threads
Thread Forum
Owner of PC but no admin access Windows 7
Hi, I am the owner of my pc and the user I am logged into is only able to read/execute. I've tried several ways of regaining back Admin but have always been prompt with the message 'Access denied'. I've noticed the box is ticked for 'Account is disabled' for admin account but I can't untick it...
General Discussion
I need admin permission to delete/move file (but I'm both admin/owner)
Hi, I'm new to Windows 7. I'm still trying to master the file permissions.. I need some help and I'd appreciate it if someone could help me out. I have a folder with mp3s (created with my old Windows XP system). I've included this mp3s folder in the "my music" library and then I inspected...
System Security
!!UAC!! "File Access Denied" Even with admin, as owner, and permission
First off, I wasn't sure where the best place to post this would be, since UAC is supposed to be a security feature of windows 7 I figured the security section would be best. My apologies if I posted this in the wrong section. OK to the problem... Trying to simply copy/paste a game dll file...
System Security
Single user PC why do I need Admin + Owner + Users ?
Have just migrated (sic. "down graded") from XP to Win7 I am on Win7 training wheels and I still fall of ! As a single user PC the new "Administrator" + "Owner" etc is driving me insane. In the process of trying to get a grasp on Win7 and its foibles I am getting more frstrated with Win7. My...
General Discussion
Cannot Replace Owner with icacls!
I am trying to access/move files on a drive pulled from an old XP machine that failed. The drive is connected to a W7 machine via an external USB case. When I use explorer to access the properties for A SINGLE FILE, the owner is shown as an unknown GUID (I expect this). Using this interface,...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:55.
Twitter Facebook Google+