Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Error" Access Permession for Kaspersky

30 Dec 2012   #1

Windows 7 Ultimate 32-bit (6.1, Build 7600)
"Error" Access Permession for Kaspersky


I have a little problem with Kaspersky antivirus, I had Avast antivirus for the past year, but I uninstalled it because I think I have some viruses and it doesn't help protecting my computer, I installed Kaspersky antivirus instead, but after installation it didn't run automatically, so I tried to open it by myself, and when I open it, this message pops up:
"windows cannot access the specified device, path, or file. you may not have the appropriate permission to access the item.".

Is there anything I can do about it? maybe a firewall settings or something with users permission?

Thanks in advance.

Attached Images
"Error" Access Permession for Kaspersky-kaspersky-error.png 
My System SpecsSystem Spec
01 Jan 2013   #2

Windows 7 Ultimate x64

Maybe it's due to the self-defense module that prevents anything to tamper with the Kaspersky files. Try disabling it. Or if you can't try completely uninstalling it and then reinstall it again from scratch.
My System SpecsSystem Spec
02 Jan 2013   #3

Windows 7 Ultimate 32-bit (6.1, Build 7600)

I tried re-installing it, but it didn't work, I tried to install Kaspersky antivirus, and later the Internet security, but none of them worked, about the self-defense module, I am not sure what am I supposed to do, or how to disable it, if you have any ideas, please let me know.

Thank you in advance
My System SpecsSystem Spec

02 Jan 2013   #4
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Are you running as Administrator? Is this the 'paid' for version or online scan?
My System SpecsSystem Spec

 "Error" Access Permession for Kaspersky

Thread Tools

Similar help and support threads
Thread Forum
"access denied" when using "assoc" and "ftype" from cmdline?
I tried to associate the file extension .txt to a new editor program with the well known cmdline programs ASSOC and FTYPE. No, assigning them through WinExplorer menu does not work. But this is another problem which should not discussed here. When I type now one of the following...
General Discussion
Import Pictures to NAS "Access Denied" Error Though User Has Access
Hi, All. I've got an interesting situation that I'm hoping can be resolved. I built a server using FreeNAS 8.2 to store family pictures, videos, music, and Windows backups. In my home we have Windows 7 Home Premium 64bit and Windows 7 Professional 64bit. The server is setup with 3 Windows (CIFS)...
Network & Sharing
Error assigning ownership "Unable to set new owner on.. Access denied"
Hi, I've a question about assigning ownership. I'm logged in as user "Steph". As Steph, I made a new folder "Documents_Steph". Because she made the folder, she's owner of this folder. Then I tried as Steph to assign ownership to a different user "User01". But then I got the message...
Network & Sharing
"Access is denied" - "Unable to display current owner"
Hi, I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder. When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied". The same happens when logged in with the system...
Network & Sharing
uninstalled google docs now win search error "cant access device"
I installed google desktop for a while. Didnt like it. Unistalled thru google uninstall. Now search won't function. Get this error. Help fixing appreciated.
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App