Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Run As Administrator function for CMD.exe giving Access Denied

30 Jan 2013   #1

Win 7 64Bit
Run As Administrator function for CMD.exe giving Access Denied

Hey everyone, I have an odd one. So this is slightly different from my last post for I have figured out half of my issue from the last time.

How come if I right-click a BAT file as a standard user and select Run As Admin, the script runs but says Access Denied in the CMD window?

CMD.exe and BAT file has Everyone with Full Control and ownership. I have tried doing the shortcut method and checking Run As Administrator option and that gives the same error. I went into the registry and disabled the UAC just in case with no luck.

Is there a security setting that I have overlooked that would cause that BAT file to not run? Any help you guys can give is appreciated greatly!

**EDIT** - As a test, I logged in as an administrator on the machine and the script launches fine without elevation or prompting as well if I tell it to Run As Admin. So now I am

My System SpecsSystem Spec
30 Jan 2013   #2

Windows 8.1 Pro RTM x64

What is the batch file?
My System SpecsSystem Spec
30 Jan 2013   #3

Win 7 64Bit

Its just a simple map a network drive script. I would love to get rid of it and map persistent the standard way but the program that gave me this machine is how they conduct their drives and don't want to change it so I am stuck trying to figure it out.

I just tried using the runas in the script with the /savecred option and that didnt like it either.
My System SpecsSystem Spec


 Run As Administrator function for CMD.exe giving Access Denied

Thread Tools

Similar help and support threads
Thread Forum
Administrator access denied
Hope this is the right Thread. Having a serious “access” problem. Uninstalled VGA, and am now unclear on what is going on with my administrator permissions. I continue to get "access denied". unable to access event logs or change any settings, even using my administrator account. I am unable to get...
General Discussion
Windows 7 Pane Customizer will not function - Registry access denied I'm running as an Administrator and never typically get these sorts of problems. Each time I go into the registry and set the permissions for it, the same error pops up with a new registry lines denying access. I've now set permissions for about 8-10 registry lines...
Access Denied on Administrator
Hello! Many times I have seen the "Access Denied" error while using an administrator account. Especially in disk management utility when I tried to edit disk partitions but couldn't even with administrator privileges. This is not a specific case - I just want to know how, even with...
General Discussion
Administrator ? denied access
My son recently purchased a new laptop pre-loaded with Win 7 from Office Depot and installed Quickbooks for his business. He is the only user on this laptop and Quickbooks. When he double clicks Quickbooks to get in he gets the message that he doesn't have admininstrator rights and yet his name is...
General Discussion
Access Denied as administrator??
hello, Today I tried looking into some folders, one of which was Documents and Settings, but couldn't get access. I tried to change the permissions on the folder and had a problem with that to. What can I do to allow myself to run my own computer??
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App