Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Programs not inheriting the credentials of the owner

20 Oct 2009   #1

Windows 7 Ultimate Edition
Programs not inheriting the credentials of the owner


I tried running a program or bot on my Windows 7 Installation a few days ago. I assumed that the program would actually own the credentials of me since I was running it, but sadly that was not right as the program proceeded to tell me that it couldn't write to files. Which I found odd as I myself could both open then, read, add and then save with the changes remaining.

I had to actually add myself to the folder with "Full Control" before the program could run without any error. Now is it I ask, Why is that even required?. I thought it was implied that if I can access the folder, read and write to and from it, that any programs I run can do the same.

At least thats how it worked under XP, but yes I am aware that security has been tightened in both Vista and Windows 7. But seems rather useless having to assign myself to a folder I got access to already, before a program I run can access it.

My System SpecsSystem Spec
20 Oct 2009   #2


That would depend upon a couple of things:
  1. The folder tree you were attempting to write to
  2. The existence of the tree *prior* to your current Windows 7 install
  3. What context the program was actually running under....

IOW - we need a bit more information. This type of thing can happen for different reasons, and it cannot be determined from the info we have why it was occurring....
My System SpecsSystem Spec
21 Oct 2009   #3

Windows 7 Ultimate Edition

1: Not sure what you mean by this particular question

2: The folder existed prior to my Windows 7 installation as I was running the program perfect under Windows XP SP3

3: The "program" is a perl script aimed at running as a Game on an IRC server. Said "game" launches a Perl procecss, run by me as the user but could not write to the files where in it saved the game data. The only way I got it to work was to add myself as a Full Control to the folder. And I thought such access was "implied", since I could access, read and write to any files in that folder.
My System SpecsSystem Spec


 Programs not inheriting the credentials of the owner

Thread Tools

Similar help and support threads
Thread Forum
New owner but cannot remove previous owner as administrator
I recently bought an Acer AX3810 with Vista 7 Home Premium 64 bit from the widow of my neighbor. I had transferred all his personal files and copied all the photographs to an external hard drive for her then deleted all the files using "Eraser". I cannot seem to be able to delete the previous...
General Discussion
hp slate 2 new owner
hey just picked up a new slate 2 tablet for a super good price and I've always wanted a seven tab, but I find there is no forums regarding slate 2 owners! does anyone know of any good forums regarding the hp slate 2 or even the slate 500? anyone?
Chillout Room
owner tab
Where is the owner tab in properties? I have none.
General Discussion
I was looking on my computer and found the credentials folder. I'm a novice so i'm not familiar with what this is..but there was however listed under generic credentials an email address that my husband and I used to share. It's still open but we rarely use it. Why would that email address be...
General Discussion
Adding files to network share not inheriting security
Hey guys, I have a network share set up with everything working. My roommates can see, read, and download files from me, and my WDTV Live can play back music, videos, etc. These folders that are shared have Security settings with the user "Everyone" with Read & execute, List folder contents, and...
Network & Sharing
cant change owner
i cant change the owner of c: drive because it says i dont have permissions i need .... HELP!!
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App