Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't delete folder - access denied (despite attempts to fix)

03 Dec 2013   #11

Windows 7

Wild stab in the dark but have you tried removing it via the command line in Safe Mode using the Administrators account?

My System SpecsSystem Spec
03 Dec 2013   #12

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I tried just now from the "Administrator:Command Prompt" in normal mode and got "Access is denied". I'll try again in Safe mode next time I reboot.
My System SpecsSystem Spec
05 Dec 2013   #13

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Safe mode command line delete didn't work either. It went through all the files saying "Delete", but at the end said "Access denied" and the directory & its files are still there.
My System SpecsSystem Spec

05 Dec 2013   #14

Windows 7 Home Premium 64Bit

Pulled this from one of the microsoft sites

Step 1: Take ownership of the root drive:
Method 1: Take ownership of the drive from user interface.

1. Right click on drive and select “Properties” from Context Menu.

2. Click on "Security" tab.

3. Click on “Advanced” button.

4. Now click on "Owner" tab in Advanced Security Settings for User windows.
5. Click on Edit Button and select user from given Change Owner to list if user or group is not in given list.
6. Click on other users or groups. Enter name of user/group and click ok.
7. Now select User/group and click apply and ok. Check “Replace owner on subcontainers and objects” if you have files and folder within selected folder.
8. Click ok when Windows Security Prompt is displayed.
9. Now Owner name must have changed.
10. Now click Ok to exist from Properties windows.

11. Once you have taken the ownership of file or folder next part comes is granting permissions to that file/folder or object.
If the above method doesn’t work, you could try taking ownership from the command line.
Method 2: Taking ownership of a folder from command line
Open an elevated Command Prompt window.
To do so:

1. Go to > Start > All Programs > Accessories
2. Right-click on Command Prompt, and then click Run as Administrator.
3. Type the following command and press ENTER:

takeown /f <foldername> /r /d y

4. To assign the Administrators group Full Control Permissions for the folder, use this syntax:

icacls <foldername> /grant administrators:F /T

The /T parameter is added so that the operation is carried out through all the sub-directories and files within that folder.

5. To know more information about the above commands, run these commands from a Command Prompt window.
takeown /?
icacls /?

Once you take ownership, you can grant permissions on those folders.
Step 2: How to Grant Permissions in Windows
1. Locate the drive on which you want to take ownership in windows explorer
2. Right click on drive and select “Properties” from Context Menu
3. Click on Edit button in Properties windows Click ok to confirm the prompt.
4. Select user/group from permission windows or click “add” to add other user or group.
2. Now under Permission section check the rights which you want to grant i.e check “Full
3. Control” under the “Allow” column to assign full access rights control permissions to Administrators group.
4. Click Ok for changes to take effect and click ok to exit from Properties window.
For more information, refer:

What are permissions?
This should help you in copying the file in System32 folder.
My System SpecsSystem Spec
06 Dec 2013   #15

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I'd actually tried this before (see my first post), and whenever I clicked "Replace all child object permissions with inheritable permissions from this object" the check mark would disappear when I checked drive Properties again. This time - for reasons I have no idea about - it didn't disappear and instead Windows Security went through a *long* procedure of setting security information for apparently every file on the disk. When I again tried to delete the directory, I got a screen saying "Preparing to recycle" and "Calculating". This went on for several minutes, at which point I clicked "Cancel". "Canceling" went on for several more minutes until I uncovered a dialog box saying the recycle bin was corrupted. I chose to delete the recycle bin at which point the Canceling finished. Finally I used FileMenu Tools to delete the directory bypassing the recycle bin. This time it worked!

So thanks for the information. The problem is solved, though I must say I'm no more enlightened as to why it occurred than I was before.

Thanks again.
My System SpecsSystem Spec
07 Dec 2013   #16

Windows 7 Home Premium 64Bit

Glad to hear mate
My System SpecsSystem Spec

 Can't delete folder - access denied (despite attempts to fix)

Thread Tools

Similar help and support threads
Thread Forum
Delete folder/files - access denied
My PC originally came with a normal SATA HD with Windows 7 installed. Then I got an SSD and did a fresh installation of Windows 7 on the SSD. The SSD is labeled C: while SATA HD is D:\ Now I am trying to delete the SATA's folders:
General Discussion
Folder access denied, cannot rename or delete
Win 7 Premium 64, updated, logged in as Admin. Currently: C:\Users\Public Documents.........I have taken ownership Public Documents\Properties shows: General- Public Documents Sharing- Public Network Path:...
General Discussion
Unable to Delete Folder from Desktop: Access Is Denied?
I had a folder on my Desktop that just won't delete. It was apparently being shared with my Xbox360. I right-clicked it, pressed Delete, and it said it was being shared and if I was sure I wanted to do it anyways. So, of course, I said Yes. It deleted everything within the folder, yet the folder...
Can't delete folder - access denied
Hello! I have a small issue concerning deleting folder. Here's situation: I had a folder that I wanted to delete. I used shift+del combo for instant deletion, but than issue occured. Basicly, folder stayed, yet files deleted themselves. And when I try to delete the folder, it says I need...
General Discussion
I cannot delete a particular file Access Denied
I am tryiong to save, delete or overwrite the file "Clear Print Spooler.bat" in C;\windows\system32 and in each case get "ACCESS Denied" error. I have tried the above in the command window with admin. priviledge. Same error. I had added a line that contained the word "Runas". Now I try to remove...
Security Basics

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:54.
Twitter Facebook Google+