Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Virus Deletion Now Makes Internet Access Impossible

20 Dec 2013   #81
Florida Rene

Windows 7 64

Quote   Quote: Originally Posted by Kaktussoft View Post
netsh int ip reset : did do the trick? If so... I don't know what was wrong.

YES, with every idea from this thread, I followed guru instructions as closely as I could, then rebooted, then tested IE, FF, & Chrome.

It was your last concept (quoted herein) that did the trick. But, it may have been an accumulation of fixes that you & Golden & Indiana posed that led to your final idea working. I don't know because I'm not an expert. But I certainly am delighted by the help I received from you and the others.

I don't want to mark it as solved as yet. I have to move copy temporary files into my email client, merge and purge them, then run a full test. Tomorrow. I'll report further. Good job and thank you.

Also, it should be noted that in answer to this thread, JMScreator has raised a valid issue which merits some attention. Your thoughts on that, Kaktus, Indiana, Golden?

My System SpecsSystem Spec
20 Dec 2013   #82

Windows 7 64bit Home Premium

OKAY I just found a solution (THANK YOU VERY MUCH, Kaktussoft and Indiacarnie)

Here's what I discovered, and is why it is now working for Florida Rene.
I deleted EVERY AdpeekProxy.dll and Don't forget the AdpeekProxy64.dll in the system32 folder! AVG doesn't detect that! So find everything that is related to Adpeek and delete it. Then the browsers will stop working after doing the AVG scan and deleting Adpeek completely.

Run this bat file that Indiacarnie mentioned:

@Echo off
netsh winsock reset all
netsh int ip reset all
shutdown -r -t 0
del %0
(Run as administrator... otherwise it doesn't work)

This will fix it. Thank you! And remember! It was a team effort! I have been working on this for 2 days straight in a row! However, as I own a business in Computer Repair, I do have the tools and such. I have literally been imaging the client's hard-drive back and forth between working internet and non-working internet, and finally that AdpeekProxy.dll was the very thing that caused this problem. The "netsh winsock reset all" command fixes the Proxy Reference. So it no longer is looking for Adpeek virus.
Check this link out. It tells you what winsock reset does netsh winsock reset
This command in cmd should show you a list of all/any changes made to the winsock catalog!
netsh winsock audit trail
(If anyone found something else regarding this issue... please do share! and also if someone could post a list of file locations for Adpeek that AVG does NOT detect, such as the AdpeekProxy DLL in system32. Thank you!)

I am glad to say that this terrible and extremely painful annoyance has been solved.

So remember... Don't get Scorpion Saver or Adpeek.. they're really bad.

Computer Smith, MA
My System SpecsSystem Spec
21 Dec 2013   #83

Windows 10x64 Build 1709

My apologies to jmscreator but I'm a little leery of self proclaimed "experts" in any field. I WOULD NOT personally replace that .dll file. The .bat file I gave you in post #16 should have done the trick as it contained all the commands that eventually led to your net being restored. In my haste I may have forgotten/neglected to mention that any .bat file should be run as an administrator (Elevated Command Prompt). And for this I deeply apologize for wasting your time and that of the other members helping you.

The .bat file I suggested, and what it does is available on the net without too much searching. I know because that's where I got it and I've had it saved for over a year now in my "tools" folder. Its worked before in similar situations and dumbfounded me when it didn't work for you. Again, my apologies for neglecting something so basic as running it as an elevated command. (I've since made a note to myself in my tools folder so this doesn't happen again)

Yes, its becoming increasingly more common for malware to change/rewrite system files. That's why I suggested a repair install/clean install when my original posting of the "fix" didn't "fix" the problem.

I'm just happy that your machine is up and running. (I'll catch heat for this, but maybe you should consider a different anti-virus also. AVG is not like it used to be and there are many other free alternatives that perform better and faster.) Also, when downloading anything pay extra attention as you install, unchecking any and all things you don't want. Everybody, it seems, wants to install the little extra's that lead to this kind of thing. Save any programs/things you download and scan them first before installing. I know this advice is very basic, but after my slip-up earlier vis-a -vis the command prompt, I'd rather err on the side of caution.
My System SpecsSystem Spec

21 Dec 2013   #84

Windows 7 64bit Home Premium

Quote   Quote: Originally Posted by indianacarnie View Post
My apologies to jmscreator but I'm a little leery of self proclaimed "experts" in any field. I WOULD NOT personally replace that .dll file.
I understand what you are saying here, but the AdpeekProxy DLL is a virus. Go look up online, and you will clearly see that everyone has detected it as a virus. This Proxy DLL is used in replace of the system DLL
(mswsock.dll to be exact) What it does is acts like the mswsock.dll, but also tracks information and such. This DLL should be removed, as AVG knows it's a virus too. However, when you reset the winsock catalog, it puts the OS proxy settings to refer back to the mswsock.dll. So it will work again, but remember to get rid of those bad Adpeek DLLs.
As far as my self proclaimed expertise, I am not an "Expert" at computer technology, however with my many years of advanced experience, I can figure out how to repair computers. This is why I am now running a business. As far as running it as Admin, it's no trouble at all. I always run it as admin, I was just throwing that out there so other's wouldn't get confused.
My website is still under construction, so it's just a contact form.

My System SpecsSystem Spec
21 Dec 2013   #85

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

netsh winsock reset : That has solved it I think.
Although the poster posted that didn't solve it (even after reboot). He did "netsh int ip reset" as well. tcp/ip was running fine... no reason to reset actually.

There wasn't a generic http proxy in the tcp/ip stack Netsh Commands for Windows Hypertext Transfer Protocol (WINHTTP)
Neither was there a proxyserver defined in internet explorer (and most likey not in other browsers).

Only common tcp/ip stuff which could cause these http errors is winsock Winsock - Wikipedia, the free encyclopedia

It supports Layered Service Providers. a Layered Service Provider can intercept and modify inbound and outbound Internet traffic. It allows processing of all the TCP/IP traffic taking place between the Internet and the applications that are accessing the Internet (such as a web browser, the email client, etc.). For example, it could be used by malware to redirect web browers to rogue websites, or to block access to sites like Windows Update. Alternatively, a computer security program could scan network traffic for viruses or other threats.
Layered Service Provider - Wikipedia, the free encyclopedia

There can be more Layered Service Providers (LSP) chained together. You deleted the DLL (the LSP)... the cause of the problem.

netsh winsock reset : that resetted the LSP chain to default standard order. Maybe virusscanner isn't working corectly now (maybe we deleted that LSP as well[?]). Uninstall and install AVG again
My System SpecsSystem Spec
21 Dec 2013   #86
Florida Rene

Windows 7 64

Quote   Quote: Originally Posted by Kaktussoft View Post
netsh winsock reset : That has solved it I think.

Maybe virusscanner isn't working corectly now (maybe we deleted that LSP as well[?]). Uninstall and install AVG again
Another good suggestion from Kaktussoft. So, I have removed AVG from the previously-infected computer and after it reboots, I'll install it from a fresh download I've already made and report on my tests later, hopefully today.

Thank you all once again.

BTW, is AVG the best free anti-virus program today?
My System SpecsSystem Spec
21 Dec 2013   #87
Florida Rene

Windows 7 64

All is NOT well...yet.

Removed AVG per Kaktussoft recommendation. Restart did NOT work. Hung up forever.
Tried "normally" reboot. Would NOT work.
Tried "Last Good" reboot. Would NOT work.
Tried "Safe with Networking." Worked. Updated MalwareBytes.
Ran MalwareBytes. Found and removed 51 threats, mostly with Adpeak in their file names.
Removed them all. (see attached .txt file)
Ran Agent Ransack. Found "Peak Files.jpg.lnk" shortcut under \Users\Rene\AppData\Roaming\Microsoft\Windows\Recent
Deleted that file via Ransack

Most of the files found at 11:02 a.m. EST today included this verbiage:

Your comments would be appreciated on this listing found by MalwareBytes and how to permanently end this fracas (THANK YOU):

Attached Files
File Type: txt mbam-log-2013-12-21 (11-02-06).txt (15.9 KB, 4 views)
My System SpecsSystem Spec
21 Dec 2013   #88
Florida Rene

Windows 7 64

More lurking problems.

After the above post, ran MalwareBytes and AVG again. Both said no threats.

Did a restart and again updated MalwareBytes. Ran it again.
It found 30 new threats (see attached txt file). Removed them all.

Went to Add/Remove and found Scorpion Saver again. Tried to delete it. Attached screen print shows what happened. Used Agent Ransack to search for missing file t.msi. Not found on C:\ or any other partition.

Went to Piriform and downloaded/installed updated version of CCleaner. Ran new CCleaner. Took forever compared with previous version. Found and deleted only normal internet histories etc.

Went to Start Folder to see if something is strange there. Found nothing weird that I can determine.

I will restart and again run scans.

Attached Thumbnails
Virus Deletion Now Makes Internet Access Impossible-scorpion-delete.jpg  
Attached Files
File Type: txt mbam-log-2013-12-21 (14-58-05).txt (10.0 KB, 2 views)
My System SpecsSystem Spec
21 Dec 2013   #89

Windows 10x64 Build 1709

My apologies Kattussoft.

Run your A/V in safe mode and Malwarbytes too for that matter just to be safe. PUP = Potentially Unwanted Program. (NO you don't want any of these.) It looks like Malwarebytes successfully got them. You can also run Superantispyware (which I highly recommend) (Full scan)

There is no "best" Anti-Virus as its a matter of taste. There ARE leaders in the field (we have multiple threads pertaining to this subject so I will not recommend one. I used Avast until this morning when I changed to Bit Defender. Avast is near the top at detection rates but I personally don't care for the new UI and its increasing amounts of nag balloons.)
My System SpecsSystem Spec
21 Dec 2013   #90
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Just a suggestion from a NON EXPERT. (ME)
Something I use often and it does help me. Using Microsoft I.E. works best for me with the download.

Free Virus Scan | Online Virus Scanner from ESET
My System SpecsSystem Spec

 Virus Deletion Now Makes Internet Access Impossible

Thread Tools

Similar help and support threads
Thread Forum
I added a password, now it's impossible to access my PC
A few months ago, I bought a PC from a company that didn't need it. I know the company and nothing was dodgy or unusual. I changed the user account from the girl that used to use it to my name and didn't set a password. Yesterday I set up a password as I needed to connect to my PC via...
General Discussion
Windows 7 File Access Impossible without system crash!
I have an Acer laptop with only 1gb memory and I am a frequent downloader of large files, be it music, video or picture. I am conservative with my use of memory, and I still possess over half of it free. However, ever since I downloaded a collection of videos a month or so ago, each time I...
Performance & Maintenance
Virus prevents internet access, block antivirus.
Microsoft Security Essentials has been blocked by the virus inducing the firewall. Even if I type virus security into chrome the virus crashes the browser. It gives warnings about the danger hardware damage.
System Security
Can't Access file for deletion with Admin Privileges
Hello, I am currently running W7 Ultimate 64 Bit with Norton 2011 and Comodo 5.????. I noticed I didn't have a site advisor on FF. So I installed McAfee. It seems to react after a file is downloaded and everything even Windows Gadgets are unsafe and must be blocked. I downloaded Norton Safe Web...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:00.
Twitter Facebook Google+