Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't edit and resave a .txt file??

26 Oct 2009   #1

Win 10 Pro
Can't edit and resave a .txt file??

I'm obviously not used to all this new permission stuff.

I have files on external drives that I need to access and update. So I opened a 'txt' file I had created with Notepad (with XP or Vista64), made a small change and then I was not allowed to re-save to the same folder with the same name. Ctrl+S popped up a 'file save' dialogue box and when I navigated to the folder on the external drive and tried to overwrite the original I got Permission Denied.

What's going on?

I will also access this same drive with other computers running XP or Vista64 so I don't want to do anything that will make it impossible to share the data.

This is not a public computer, I'm the only user, I have a hardware firewall, I have never ever had a single virus in 20 years of computing (old 8088 days..), I image my hard disks regularly .. so I don't need a super security system preventing me from opening and saving my own files.

I'm just afraid to poke at it for fear of rendering these files inaccessible on my other systems.

Thanks for any advice

My System SpecsSystem Spec
26 Oct 2009   #2
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Can you right click on the file and 'Run as Administrator'?
My System SpecsSystem Spec
26 Oct 2009   #3
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Edit to the above .... 'take ownership' is what you want to click on.

BTW, I've opened many .txt files and edit them. I click the X and it asks if I want to save, don't save or cancel ... I click on save and it stays in the same folder with the same name.
My System SpecsSystem Spec

26 Oct 2009   #4


This may be a permissions folder, but it also depends upon where you are trying to write to, and especially if you upgraded / clean installed Windows 7 while carrying over folders from a previous operating system.

If you try to write to System Protected areas, like %systemroot% (aka \Windows\System32\) or %ProgramFiles% (aka \Program Files\) you'll get an error - this is by design.

If you are trying to write to a folder you definitely have access to write in (My Documents, etc) then check to see if the file is read only.

If you are trying to write to a folder that you created using an older operating system after having clean installed Windows 7, it can definitely be a permission issue. The easiest thing to do is to go folder by folder and take ownership of the folders that belong to you (meaning leave out \Recycler, and the hidden \System Restore folders, and other similar system created folders if they exist), but this can be a daunting task, as you'll then need to also add yourself to the permission list to allow yourself to read, write, etc. to those folders.

There is an easier way to fix it depending upon your scenario from the three I have listed, so please post back on which scenario fits you....
My System SpecsSystem Spec
29 Oct 2009   #5

Win 10 Pro

I cannot find any sign of a Right-click "take ownership' option.

As a commercial photographer I have over 20 external hard disks of archived jobs (everything dublicated on 2 drives) and need to be able to start up a drive, access the files and make modifications as needed.

What I have found is a 'Security' tab that allows me to set permissions for the whole drive.

I just inserted an external SATA drive and the displayed permissions are:

Everyone: Nothing ticked except Special permissions which has a gray checkmark

Creator Owner: Nothing ticked except Special permissions which has a gray checkmark

System: All choices ticked EXCEPT Special permissions

Administrators: All choices ticked EXCEPT Special permissions

Users: Full control, Modify, Write NOT ticked (Special permissions has gray checkmark)

Is this what it should be set to? Or is there something wonky which explains why I was unable to do a simple update to a .txt file?

As a test I set access permissions for Everyone to everything Allowed and that solved it. Though it took a few minutes for all the permissions to be modified on that drive and that scared me, because I still need to access these files with the other systems in my office. And I feared what that all that whirring on the hard drive would do to my ability to access those files from my other systems.

Is there a simple 'global setting' solution?

Thanks for any help

My System SpecsSystem Spec
30 Oct 2009   #6

Windows 7 Ultimate x64 (Retail)

I think you already found it. :)

But there is a simple way to add the 'take ownership' for drives, folders and files menu items to your explorer right click context menu which would make solving this problem a little easier in the future.

To do this you can use a free portable (does not need to be installed) app called 'Ultimate Windows Tweaker" to add the take ownership items to the context menu. Below is a screen shot of the part of the app that allows adding these items. As you can see, it's just a simple check box and then you'll have the take ownership entries on the right click context menu. (You can also subsequently remove them from the menu with the app by unchecking the same boxes.)

Attached Thumbnails
Can't edit and resave a .txt file??-uwt-.png  
My System SpecsSystem Spec
30 Oct 2009   #7

Win 10 Pro

In the meantime I found and installed the 'take ownership' registry tweak posted at: Take Ownership Shortcut

Should I uninstall that before installing the 'Ultimate Windows Tweaker' which looks a lot like the old XP Powertools. (thanks for that btw!)

I'm really surprised Microsoft did not predict that a lot of mom&pop computer users will want to access their files stored on removable media. And how are they supposed to deal with stuff like this? They're barely techno savvy enough to just write email. I find it hard to believe there would not be a simple pop-up warning "Security Alert! You are trying to access files on a new media volume. Do you wish to enable full read-write access?" Or something like that. Just making it impossible to open a file and re-save it (after added another cookie recipe, or an entry into a family tree) doesn't make a whole lot of sense. Why don't I see this behaviour with Vista?

My System SpecsSystem Spec
23 Dec 2009   #8

Windows 7

Are you kidding me. Microsoft never figured that people would need to edit files in their Windows 7 PC?
Are you kidding me! This is the most stupid things I have ever seen or heard of from Microsoft. WTF!

I have to go and get some kind of tweaker to edit a simple .TXT or .CFG file. You are kidding, right?
My System SpecsSystem Spec
04 Mar 2010   #9

win 7
Permissions etc: what a cock-up

Yes I agree, having spent a couple of hours to research how to change the read only status of my documents, which I find Win 7 changed without my permission.
You would expect that effecting changes would be easy but forget that, MS has other ideas. I had to mess about for ages & read various posts (many unresolved) before accidentally correcting the problem. I also had to dwnld a tweak & install (against a MS warning that the provider could not be checked & I was about to make a registry change - not mentioned in the tutorial).
This is unforgiveable, MS you should be ashamed of poor implementation of whatever it was you were supposedly providing.
My System SpecsSystem Spec
31 Jul 2010   #10

Windows 7

If you open your texteditor (e.g. notepad) "As Administrator", then open the file you want to edit from the file menu. You are then able to edit and save the file.

The suggestion earlier to "Run as Administrator" would not work as you are not trying to run the file, but edit it. What you are trying to "run" is your text editor.

I believe this is the way Microsoft intended for you to be able to edit these files.
My System SpecsSystem Spec

 Can't edit and resave a .txt file??

Thread Tools

Similar help and support threads
Thread Forum
file to edit cmd welcome text
where should i search for string, if i want to change welcome text , mean: microsoft windows ..... copyright ...... picture to know what i mean, do not suggest the red line
Can I delete or edit the file clr.lst
Not sure if this question has been asked before or not. My computer was/is infected with some rubbish search engine - Claro. I have followed all of the possible solutions I have been able to find on the internet but to no avail.:cry: Have deleted files, registry keys etc., but still it pops...
Performance & Maintenance
Cannot edit mp3\any video file
before a few days i get this problem. Here is a picture when i press right click on mp3 file\any other video file. the first tab is "General" and the other tab is "Older versions" Uploaded with i have only 2 tabs: 1....
Music, Pictures & Video
How to edit the Hosts file in 7
Hi people :) I need help here, I have some older applications that wont work unless i change their 'update ip', (dont know what its called), in the hosts file. I have found numerous ideas on how to edit in the hosts file, but none of them has worked so far. When I run Notepad as...
Network & Sharing
Unable to edit a file
hello, I facing a strange problem in windows 7. I am running PHP and Apache web-server on my windows 7 platform. I have the php.ini file in my C:/ drive <Windows> folder. I tried to edit and save the file. After editing when I tried to save the file it tells me that this file is being used by...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App