Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Firewall cannot be accessed from Control Panel

08 May 2014   #1

Windows 7 x64 build
Windows Firewall cannot be accessed from Control Panel

Hey guys,

I'm no stranger to windows at all, so I should be able to understand anything you throw at me.

That being said I can't seem to get into Windows Firewall from the Control Panel. Click on it just gives a "click" sound followed by nothing.

I've checked on it in the CMD prompt via "wmic service where name="MpsSvc" get /all /format:list" and verified that it is running, and even checked the service to see that it was running ( which it was ). I just can't access the GUI which controls it. I'm kinda befuddled.

Running a sfc /scannow returned
"Verification 100% complete. Windows Resource Protection did not find any integrity violations."

So I'm left kinda scratching my head. I really don't want to have to reformat Windows (such a pain ) in order to fix it, so... what do you guys think?

My System SpecsSystem Spec
08 May 2014   #2

Windows 7 Home Premium


Please download Security Check:
Save to your Desktop.
Double-click: SecurityCheck.exe
Follow the onscreen instructions inside the black box.

When done, a Notepad report opens automatically, called: checkup.txt

Please post the checkup.txt in your reply.
(Please do not take any corrective actions!)

Also, press on with Downloading Farbar Service Scanner

Let's get a view of all services and dependencies scoped by the tool...

Make sure the following options are checked:
Internet Services
Windows Firewall
System Restore
Security Center
Windows Update
Windows Defender

Press: Scan
When done, FSS creates a log, FSS.txt, on the Desktop.

Please provide the FSS.txt in your reply.

Thank you.
My System SpecsSystem Spec
08 May 2014   #3

Windows 7 x64 build

Everything looks normal

Results of screen317's Security Check version 0.99.82
Windows 7 Service Pack 1 x64 (UAC is disabled!)
Internet Explorer 11
``````````````Antivirus/Firewall Check:``````````````
Windows Firewall Enabled!
Microsoft Security Essentials
Antivirus up to date!
`````````Anti-malware/Other Utilities Check:`````````
Java 7 Update 55
Adobe Flash Player
Mozilla Firefox (29.0)
Google Chrome 34.0.1847.131
````````Process Check: objlist.exe by Laurent````````
Microsoft Security Essentials MSMpEng.exe
Microsoft Security Essentials msseces.exe
`````````````````System Health check`````````````````
Total Fragmentation on Drive C: 0%
````````````````````End of Log``````````````````````

Farbar Service Scanner Version: 03-05-2014
Ran by Austin (administrator) on 08-05-2014 at 23:50:15
Running from "C:\Users\UserAccount\Downloads"
Microsoft Windows 7 Ultimate Service Pack 1 (X64)
Boot Mode: Normal

Internet Services:

Connection Status:
Localhost is accessible.
LAN connected.
Google IP is accessible. is accessible. is accessible.

Windows Firewall:

Firewall Disabled Policy:

System Restore:

System Restore Disabled Policy:

Action Center:

Windows Update:

Windows Autoupdate Disabled Policy:

Windows Defender:
WinDefend Service is not running. Checking service configuration:
The start type of WinDefend service is set to Demand. The default start type is Auto.
The ImagePath of WinDefend service is OK.
The ServiceDll of WinDefend service is OK.

Windows Defender Disabled Policy:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Defender]

Other Services:

File Check:
C:\Windows\System32\nsisvc.dll => MD5 is legit
C:\Windows\System32\drivers\nsiproxy.sys => MD5 is legit
C:\Windows\System32\dhcpcore.dll => MD5 is legit
C:\Windows\System32\drivers\afd.sys => MD5 is legit
C:\Windows\System32\drivers\tdx.sys => MD5 is legit
C:\Windows\System32\Drivers\tcpip.sys => MD5 is legit
C:\Windows\System32\dnsrslvr.dll => MD5 is legit
C:\Windows\System32\mpssvc.dll => MD5 is legit
C:\Windows\System32\bfe.dll => MD5 is legit
C:\Windows\System32\drivers\mpsdrv.sys => MD5 is legit
C:\Windows\System32\SDRSVC.dll => MD5 is legit
C:\Windows\System32\vssvc.exe => MD5 is legit
C:\Windows\System32\wscsvc.dll => MD5 is legit
C:\Windows\System32\wbem\WMIsvc.dll => MD5 is legit
C:\Windows\System32\wuaueng.dll => MD5 is legit
C:\Windows\System32\qmgr.dll => MD5 is legit
C:\Windows\System32\es.dll => MD5 is legit
C:\Windows\System32\cryptsvc.dll => MD5 is legit
C:\Program Files\Windows Defender\MpSvc.dll => MD5 is legit
C:\Windows\System32\svchost.exe => MD5 is legit
C:\Windows\System32\rpcss.dll => MD5 is legit

**** End of log ****

on a slight note, I take pretty good care of my computer, and UAC is just an annoyance to me. Which is why it is disabled.
My System SpecsSystem Spec

09 May 2014   #4

Windows 7 Home Premium

Please go to Start > Search programs and files (above Start)
In the search box, type: Command Prompt

Right click Command Prompt in the search results and select: Run as Administrator

At the Command Prompt, please copy/paste (with mouse) the following:

control firewall.cpl
Press: Enter

Can you bring up the Windows Firewall?
My System SpecsSystem Spec
09 May 2014   #5

Windows 7 x64 build

Nope, the window looses focus for about a tenth of a second and then goes back to the command prompt
My System SpecsSystem Spec
09 May 2014   #6

Windows 7 Home Premium

What first comes to mind is data corruption in firewall.cpl
However, there could be other reasons, like something in the Registry...

Please right-click the Command Prompt, and select: Run as Administrator

Use the following command:

SFC /scanfile=c:\windows\system32\firewall.cpl
Press: Enter

My System SpecsSystem Spec
09 May 2014   #7

Windows 7 Home Premium

Is the Windows Firewall control panel applet the only one that does not open?

If so, is this issue something that started recently?

Have you tried using System Restore and using a Restore Point dated before the issue started?

My System SpecsSystem Spec
09 May 2014   #8

Windows 7 x64 build

Elevated Command Prompt returns this when preforming the requested operation.

Windows Resource Protection could not perform the requested operation.

I'm thinking that there might be some sort of issue, but it started after I finished installing all the updates from Windows Update. I figured it would be something that would work itself out with in time, but it never did. I verified that the file existed and that it was indeed filled with something and not just blank, but other than that, it returned no results.

Like I said, I'm kinda baffled.
My System SpecsSystem Spec
10 May 2014   #9

Windows 7 Home Premium

Let's see if the following works...

Give this a try. The file was created by kronckew, one of our colleagues.

Boot to Safe Mode.

Go to Start > All Programs > Accessories > Command Prompt
Right-click the Command Prompt, and select: Run as Administrator

At the Command Prompt, copy/paste (with the mouse) the following text inside the code box below, and press: Enter

@echo off
rem delete old files
del /q %windir%\logs\cbs\cbs.log
del /q c:\sfcdetails.txt
rem run sfc
sfc /scannow
rem filter out non essential junk from the cbs.log
findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >c:\sfcdetails.txt 
rem open details in notepad
notepad c:\sfcdetails.txt
rem optional command to shut down & restart pc after running. this may be needed if
rem sfc replaces some critical files. uncomment (remove the 'rem') to activate.
rem shutdown -r
When sfc is done, a file named sfcdetails.txt appears.

Please save the sfcdetails.txt file to the Desktop, and post it in your reply.
My System SpecsSystem Spec
10 Aug 2015   #10

Windows 7 Home Premium 64bit

Hi, I have the same problem, and followed your instructions step by step.
The previous SFC scan showed that there were some corrupt files, but couldn't fix them.


My System SpecsSystem Spec

 Windows Firewall cannot be accessed from Control Panel

Thread Tools

Similar help and support threads
Thread Forum
FireWall Settings won't open At Control Panel
hi i have a problem with control panel when going to firewall settings it wont open and Computer Properites too please help
System Security
can't open firewall settings in control panel
Hi i got my new pc everything looked right until i tried to go to firewall setting to change some staffs but i can't open it, when i click i hear the "tic" sound but nothing happens.... nothing at all i tried use "SFC /SCANNOW" command in command prompt but it says there's nothing wrong...
System Security
Unable to use MS Firewall, even through the control panel
Hello all, Today I found out that I can't use MS Firewall through control panel. It seems that this service is not working anymore. Everytime I click on it, it does that sound as if is going to open the Firewall properties but nothing happens. I checked the service (through services.msc...
System Security
Command Line Open Control Panel\All Control Panel Items
How to open "All Control Panel Items" from the command line? thanks...
General Discussion
How to change the color of the top panel in control panel
Hi everyone, Today I realized that the text in the top panel of my control panel (as shown in the picture) is very difficult to read. I think one of the themes I installed changed the colors and I don't know how to get the colors changed back to what it used to be. So this got me wondering: how...
Themes and Styles

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:51.
Twitter Facebook Google+