Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Juniper network connect fails with internet explorer 11

30 Jun 2014   #1

windows 7 professional x64
Juniper network connect fails with internet explorer 11


I have windows 7 OS and network connect 7.1.14.

My Network connect was working fine when I had internet explorer 9. But when I did windows update, I got internet explorer 11 and since then my network connect is not working.

Its not going forward from host checker.. Continuously showing the same screen.

Anyone has come across such a problem? Please share..


My System SpecsSystem Spec
30 Jun 2014   #2

Windows 10 Pro

Have you tried resetting internet explorer?

Make sure to delete personal settings:

Internet Explorer - Reset
My System SpecsSystem Spec
01 Jul 2014   #3

Windows 7 Pro x64 (1), Win7 Pro X64 (2)

Based on my own experience (and now yours too, apparently), there is something basically incompatible with IE11 and the Juniper VPN connection functionality. I myself had this occur for three separate remote customer sites I connect with, and believe it is Java related (but I'm not sure). However with IE11 Network Connect wouldn't launch at all.

I can't recall now if I tried "compatibility view" as a way to "simulate back-level IE" to get around this, though I suspect I did and it still made no difference.

Anyway, the tech support help desks at all sites said "they do not support IE11", and suggested I revert back to IE10 which I did.

Sure enough, Juniper VPN once again worked perfectly under IE10 on all three sites.

Doesn't make a serious difference to me which version of IE I'm using, since Firefox is my primary browser. I only use IE (and then IE10 at that) for customer VPN connection issues when required, including Citrix ERD sites as well as Juniper sites.

Sorry... we're both in the same boat here. IE10 is what's on my "work machines".
My System SpecsSystem Spec

01 Jul 2014   #4

windows 7 professional x64

Thanks everyone for sharing your experinces.. Yes.. Juniper network connect 7.1.14 does not support IE 11 on windows 7. I got email from Juniper support team. I reveted my IE update and now it is working fine.
My System SpecsSystem Spec
24 Apr 2015   #5

Windows 7 Enterprise x64

In my company, we have Juniper Network Connect 7.1.0 with Host Checker. Although it is not supported officially, I found a workaround.
  • Put the URL in Trusted Sites or Local Intranet zone in Internet Settings.
  • Enable Compatibility View on URL.
    • Key: HKLM\SOFTWARE\Policies\Internet Explorer\BrowserEmulation\PolicyList\
    • Value: ""
    • Type: REG_SZ
    • Data: ""
  • Make sure User Access Control (UAC) is enabled.
Indeed we identified that some of our users have disabled UAC on Windows 7 because they think that UAC is only an annoying useless feature that does nothing but bother them with popups. For a reason I don't fully understand, NC seems to crash if the user is administrator of their computer and UAC is disabled. This behavior is not observed with previous versions of IE.

I recommended to enforce UAC with Group Policies and include it in the mandatory security compliance rules for all workstations.

Hope it helps! Regards!

My System SpecsSystem Spec
29 Feb 2016   #6

windows 7 ultimate x64, windows 10

adding the VPN domain to the list of "Compatibility View" websites in IE11 worked for me.
My System SpecsSystem Spec
21 Jun 2016   #7

Win 10 x64

Yep adding to compatibility view worked here too
My System SpecsSystem Spec

 Juniper network connect fails with internet explorer 11

Thread Tools

Similar help and support threads
Thread Forum
Internet Explorer 8 update always fails after a reinstall
I just remembered this so i wanted to bring it to the experts attention , every re install i ever did i always noticed internet Explorer 8 update fails , all other updates go smoothly though and i currently use internet Explorer 11 . This is when i am doing nearly 160 updates after a reinstall...
Windows Updates & Activation
Internet Explorer 11 fails to open PDF link
I recently updated to Explorer 11, works fine but for one problem, when I try to open a site which is a pdf link it fails to open, I get the message there is a problem with this page. I had the same prob. With Explorer 10, but Explorer 9 works just fine. I have Windows 7, 64 bit. Would like to...
Browsers & Mail
Internet Explorer 9 cannot connect to internet, Cant find problem
Hi, I'm having a problem with Internet Explorer where it cant connect to any webpage at all. I have tried to troubleshoot the problem but the troubleshooter says that it cannot find the problem. It works when i start it up in no addons mode but even if i disable all the addons that i could find...
Browsers & Mail
Netgear DG834v3 router fails to connect to the internet.
Not my week so far yet another problem. Been trying all day to connect to the internet with the above router. Happened accross a screen saying Firewall settings. It says for the inbound services "BLOCK always" is this my problem? I have tried to amend this to " ALLOW always" to which the...
Network & Sharing
Following Windows 7 update, desktop fails to connect to internet
I have tried connecting to my router with both wireless and lan cable but they both fail. What is strange is that my vista laptop (currently using) has no problems connecting either wirelessly or using the same lan cable as my desktop failed with. My windows 7 desktop was working fine earlier...
Network & Sharing
Juniper Network Connect 6 for VPN access
Has anyone got Juniper Networks Network Connect working? I was able to install Juniper Network Connect, but the Juniper "host checker" refuses connection, because OS is wrong: check_os returns false. Any idea how to work around? I checked the FAQ from Juniper, but they are saying "we...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App