Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Program only runs correctly when UAC is switched OFF

01 Oct 2014   #11

Windows 7 Ultimate 32 bit

Hi Slartybart,

I am using Oracle VM VirtualBox running Windows XP Professional (SP3).

The installed QuicKeys applications runs find on the VM. No problems whatsoever.

However, when I try and capture it using the likes of Cameyo, BoxedApp, Evalaze, etc the resultant output fails to run correctly.

Each attempt is done on a "clean build".

Happy for any suggestions :-)

My System SpecsSystem Spec
01 Oct 2014   #12

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Thanks for the feedback.

Still confused though.
Quote   Quote: Originally Posted by pete101 View Post
I successfully used a macro recording application called QuicKeys on my old XP machine with no issues or problems.

Now that I have upgraded to Windows 7 the application no longer runs correctly i.e. it records the keystrokes/mouse movements ok, but on playback it halts when it reaches a mouse playback and generates a step failed error message.
QuickKeys records the macro without incident in native Win7 - yes?

I'm no guru on this, but doesn't QuickKeys provide the macro playback. I'm confused by when I try and capture it using the likes of Cameyo, BoxedApp, Evalaze, etc the resultant output fails to run correctly.

If I'm reading this correctly - you're running a VM to create the macro and then bundling the macro into a package (Cameyo, BoxedApp, Evalaze) that runs in a virtualized environment. Device drivers need to be accessible in any virtualized computing environment (although a mouse is fairly basic)

I am also by no means a guru on VMs, but found something that might point you in the right direction:
Forwarding USB devices on Oracle VirtualBox |

Good luck, that's about the extent of what I can think of to offer.
Searched a little more and found this:
and this
How to force File and registry virtualization

There are other possibles in that thread - see if any help.

My System SpecsSystem Spec
02 Oct 2014   #13

Windows 7 Ultimate 32 bit

Hi Slartybart,

Many thanks for the pointers. It's much appreciated.

As indicated Quickeys works fine on a native Windows 7 machine providing that the UAC is switched off.

When the UAC is switched on it will still record mouse/keystrokes ok, but won't play them back correctly. The keyboard strokes do still play back ok, but any mouse movements cause a QuicKeys "Step Failed" error. It's as though the UAC is blocking the mouse movement playback. If I switch the UAC off the same macro will then play with no errors.

Therefore, my plan is to try and create a virtual version of Quickeys (using a VM version of XP)

However, none of the packages which I have tried (e.g. Cameyo, BoxedApp, etc) seem to work. The resultant output fails to run on the VM even though QuicKeys itself does work without a hitch on the same VM. Each attempt is done on a clean build.

As an added check I did capture some unrelated programs on the VM, which was just to make sure that the packages weren't missing any system software. They worked ok. Only seems to be QuicKeys that is having problems being captured.

It's all very strange
My System SpecsSystem Spec

02 Oct 2014   #14

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

Can you run QuickKeys debug (step) playback in native Win7 with UAC on and try to capture the exact error. If it's just Step Failed, I'm not sure how to help.

A possible workaround:
Use Mouse Keys to move the mouse pointer
My System SpecsSystem Spec
02 Oct 2014   #15

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem

It would be very helpful to know if you're running a laptop with a touchpad and an external mouse, or a desktop with a wired or wireless mouse. I'm finding that a few drivers (Logitech) have issues with elevated priviliges - the solution isn't clear, but some suggest rolling back the mouse driver to the base MS driver - you'll lose the add-ons provided by the device mfgr, but if it solves the issue ....

These two reports will provide a lot of information about the hardware so members don't have to ask.
  1. Please add your SF Systems Specs by following this tutorial: System Info - See Your System Specs
    • In the System Manufacturer/Model Number field, manually type Desktop or Laptop adding it to the information already in the field.
      The specific model number is important - there are often many models of a given series. For example, my machine is a HP Pavilion dv6, but there are tens of the dv6 series, so dv6-6c10us is the specific model.

    • Specify Custom Build as the manufacturer if it is not an OEM machine.

    • The tool does not fill in this information but it is very important if someone has to research drivers or hardware for your machine.
    Log on to Sevenforums (SF) and let the tool fill in you System specs on your SF profile.

    Full instructions are in the tutorial. It's a simple process and it makes that information readily available on your posts. You don't have to retype the information in any thread.

    Click here to view your system specs on SevenForums.

    Click on My System Specs in the lower left of any post by any member to see what is presented about their machine.

  2. Please follow this tutorial to provide the current operating environment of your machine.
    Speccy - Publish Snapshot of your System Specs

My System SpecsSystem Spec

 Program only runs correctly when UAC is switched OFF

Thread Tools

Similar help and support threads
Thread Forum
Windows Runs Installation of Program When I Start Program
I installed Weathrbug Plus and for some odd reason recently when I run it Windows runs the installation for the program. When I run the prograsm I get the typical "Preparing to install..." abnd then tyhe 'Configuring Weatherbug. I've been in contact with Weatherbug Support all day and we can't seem...
Need to make sure program is closed on all machines before backup runs
I work in an architecture office using Quickbooks to track hours, expenses, billing, etc. The company QB files reside on the server in a shared directory that is mapped as drive Z: on all machines through a domain logon script that runs when each person logs on to their machine. The company file...
Backup and Restore
A problem caused the program to stop working correctly.
This problem exists with only a handful of programs, the main one being Serif applications and in my case Serif Webplus X4 which is a cerified Windows 7 compatible program. For example; On successful installation I try to launch the program and the following box appears saying: Serif WebPlus X4 has...
contents of C\windows switched with contents of c\program files
I am not a 100% on how I managed this but here were my last steps: - changed the host file in c\windows\system32\drivers\etc - rebooted computer - received system errors, so I ran a HDD defragmenter - I then tried to access a file in c\program files but could not find it, but it mysteriously...
General Discussion
Program runs on Startup?
I have a program installed that runs a monitor application on start-up. I have had a look at my start-up options using Chameleon Startup Manager 3 but I cannot find this application in the list at all. Any ideas on how this is being launched at start-up? :p
a problem caused the program to stop working correctly.
I setup program window live movie maker and save movie but has error follow attach files. Window live movie maker has stoped working a problem caused the program to stop working correctly. Window will close the program and notify you if a solution is available.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App