Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installing Anti-Virus Programs Problem

09 May 2015   #11
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Re: Net Framework installation and SP1. I'm not really able to offer much help but have you tried running Belarc Advisor to get a list of missing updates along with links to the installers?


My System SpecsSystem Spec
.
Reply

 Installing Anti-Virus Programs Problem




Thread Tools




Similar help and support threads
Thread Forum
Non-cloud free anti-virus programs?
I am looking for a free, non-cloud based AV free for my winXP and Win7 systems. Here is what I need: 1) FREE. 2) NOT cloud based. 3) Manual updates. (NOT automatic) The system uses a dial-up modem only. No high speed internet available. 4) No extra programs (BLOATWARE). Just a plain AV...
System Security
Quality Of Anti-Virus Programs
I use "Kaspersky Pure Total Security" as my anti virus program for years. How do members rate this program compared to others? I recently had a problem with malware and it was solved. After downloading and running the recommended programs to detect and get rid of the malware, my anti-virus was...
System Security
anti-virus programs running together
hello does anyone know if u can combine bitdefender ( supposedly really high on the list of anti-virus programs) with malwareBytes malware? thank you
System Security
Top 3 Anti-virus programs?
I need of the best antivirus programs that can protect your computer from trojan and viruses. Like a firewall, because my PC has a trojan backdoor thing..
Software
Avast, And Other Anti Virus Programs Question
Hello, Have finally convinced my son to take anti virus software seriously. Told him to try avast free which I use. He did, but removed it as he claims it slows his pc down significantly. Works fine on mine. Anyway, any suggestions as to why this might be ?
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:17.
Twitter Facebook Google+