Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SOLVED: TrustedInstaller, Access Denied, Permissions, Change Ownership

19 Aug 2017   #1
KernelOfTruth

Windows 7 Home Premium x64
 
 
SOLVED: TrustedInstaller, Access Denied, Permissions, Change Ownership

§
This thread is related to, How to remove trustedinstaller Solved - Windows 7 Help Forums, which did not solve the TrustedInstaller, Access denied, permissions issue for me. However, I did over come the problem, and wanted to pass on what I did for others to use.

Below, my actions to regain control of a directory (inappropriately) commandeered by the TrustedInstaller.

I believe it was the takeown and icacls commands that ultimately did the trick, but just in case someone else's situation is different, here’s a log of what I did,

Dir name in question: \tmp\test_extracted. # Yours will be whatever directory you're being blocked from accessing
NOTE For the past few months, within Windows Explorer, anytime I attempt to create a new folder and rename it, I encounter the following dialog,
Item Not Found
Cannot find this item
This is no longer located in <drive>:<dir>. Verify the item’s location and try again.
<folder name>
Date created: <mm>/<dd>/<ccyy> <HH>:<MM>

[Try Again] [Cancel] buttons

Clicking [Try Again] accepts the new name for the folder.

Investigating, I found info about 8dot3 tilde short filenames. Regardless, it’s wonky.
  1. I tried the Take Ownership rigmarole described here, Windows trusted installer denying access to files - Microsoft Community, and attempted many variations,
  • Change owner (including subcontainers and objects), assigned my user, granted Full Control. Attempt delete of dir,
    Unsuccessful
  • Change owner (including subcontainers and objects), assigned Admin users., granted Full Control.
    Unsuccessful
  • Logged in as built-in admin, assigned, granted.
    Unsuccessful
  • Reboot in between assignments and grants.
    Unsuccessful
  • Rebooted into Safe Mode between assignments and grants.
    Unsuccessful
2. Removed the top-level dir (tmp) from Windows Search Indexing
  • Start menu
  • Searched for: index options text entered into search textbox
  • Clicked Index Options in search results
  • Clicked Modify button
  • Within listbox (top of dialog) expanded the C drive clicked plus sign , found tmp, and de-selected it checkbox
  • Clicked OK button
  • Rebooted machine
    No change
3. Made sure TrustedInstaller service was running it was not running on my machine (deliberate on my part)
  • Launched cmd.exe with admin privilege
  • command: net start TrustedInstaller
IMPORTANT TrustedInstaller is the service name. Windows Module Installer is the display name (human consumption).
net start won’t know what to do with the display name, must use service name.
No change
4. Logged in as Administrator. Assigned ownership from TrustedInstaller to local Administrators group,
Code:
takeown  /f  c:\tmp\test_extracted  /r  /d  y

  Explanation of options,
	
      /f       <Name of dir/file>
      /r       Recurse subdirectories
      /d  y    /default answer to /r  is  yes
5. Assigned Full Control to local Administrators group
Code:
icacls  c:\tmp\test_extracted  /grant  Administrators:F  /t  /q

  Explanation of options,

      /grant   permission(s) to Windows Group, Administrators
      :F       Grant Full Control
      /t       Grant access to directory and subdirectories
      /q       Process quietly, don't show success/fail messages
6. In the end, I did not use Windows Explorer to remove the directory, I used the command line,
Code:
rmdir /s \tmp\test_extracted
Comment About Post In Prior Thread How to remove trustedinstaller Solved - Windows 7 Help Forums

LukeDouglas doesn't need to explain anything; the expectation that a human-being has full control of their personal property at any given moment is a reasonable (and protected) expectation in the US; the unTrusted INStAller over-stepped its bounds.

Long before I created \tmp\test_extracted, and encountered this issue, the TrustedInstaller service was disabled on my machine. How (and when) did TrustedInstaller gain access to a directory that has nothing to do with the OS system directory C:\Windows or the directories managing executable files (C:\Program Files (x86) or C:\Program Files)?

We’re told, “Don’t mess with TrustedInstaller or your system may become unstable.”

Wondering out loud, does Windows have a subsystem with so many vines growing out of it that no one, including its creators, truly understands what it does anymore, so we're all told to just leave it alone?

Given my situation, I should not have gotten tangled up in a permissions issue, particularly involving the unTrusted INStAller.


My System SpecsSystem Spec
.
Reply

 SOLVED: TrustedInstaller, Access Denied, Permissions, Change Ownership




Thread Tools




Similar help and support threads
Thread Forum
Ownership, permissions and now access denied
I have a WD elite hard drive that was set up on my old computer. I had changed ownership on the drive and used the Smartware to do backups. I'm pretty sure that I deleted some of the other owners when I was there too. I have a new computer and was able to change ownership back to me and can...
General Discussion
change ownership/permissions to HDD
OS: Win7 ultimate + SP1 x64 I added 2 old HDD and I can write and delete files but there are things I cannot do with this drives like organize (move folders) how can I change ownership/permissions for these 2 old drives? I tried using annoyances' takeown and Mainz univ. chown and it didn't...
Hardware & Devices
Access denied when taking ownership of a file
Hi, I recently downloaded an application file (.exe), and tried to delete it, but i keep getting the error "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item". I tried changing the ownership of the file > right click >...
System Security
Access Denied(despite ownership/permissions)
My storage drive has been showing signs of wear recently, so I have purchased a new one and was in the process of transfering files from one drive to the next. However I have come upon an issue regarding permissions. A seemingly random selection of files and folders have been denying me access to...
General Discussion
ACCESS DENIED ( ownership and permission )
hey guys babylon trans. kindly advise me about the image below what to do i tried every thing nothing work out !! http://img291.imageshack.us/img291/7232/20480444.gif Uploaded with ImageShack.us
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:14.
Twitter Facebook Google+